手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并两个副图指标,并编写选股指标

[通达信]
设置
1014 2 碧海晴空ze Lv.1 发表于 · 2020-11-13 16:10 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
第一个指标::
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:3*K-2*D,COLORYELLOW;

第二个指标:
N:=42;
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORRED,LINETHICK2;
WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N)),COLORGREEN;

合并后显示:(如下图)
当RSI1>WR1时:
1.KDJ(J)上穿WR1 显示:买入;
2.KDJ(J)下穿WR1 显示:卖出;
当RSI1下穿WR1  显示:清仓。

附件

12.png

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-13 16:57 复制 查看全部楼层
碧海晴空ze 发表于 2020-11-13 16:19
图1不完整,现补充图2

N1:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:3*K-2*D,COLORYELLOW;

N:=42;
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORRED,LINETHICK2;
WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N)),COLORGREEN;

DRAWTEXT(RSI1>WR1&&CROSS(J,WR1),20,'买入');
DRAWTEXT(RSI1>WR1&&CROSS(WR1,J),50,'卖出');
DRAWTEXT(CROSS(WR1,RSI1),80,'清仓');

查看全部打赏
  • 碧海晴空ze+10理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

碧海晴空ze
Lv.1
发表于 2020-11-13 16:19 复制 查看全部楼层
图1不完整,现补充图2

附件

13.png

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表