手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将通达信公式改为飞狐用

[飞 狐]
设置
879 2 五行鼠 Lv.3 发表于 · 2020-11-13 16:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
N:=10;
【箱顶】:PEAK(CLOSE,N,1)*0.98;
【箱底】:TROUGH(CLOSE,N,1)*1.02;
【箱高】:100*(【箱顶】-【箱底】)/【箱底】,NODRAW;
【中线】:(【箱顶】+【箱底】)/2;
DRAWBAND(【中线】,RGB(255,234,154),【箱底】,RGB(255,234,154));
DRAWBAND(【中线】,RGB(109,187,129),【箱顶】,RGB(109,187,129));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
JRS1:=DRAWICON(TJ1 AND TJ2,X,1);
JRS2:=DRAWICON(TJ0 AND TJ3,X,2);
DRAWICON(FILTER(JRS1>0,1),L*0.97,1);
DRAWICON(FILTER(JRS2>0,1),H*1.02,2);

举报

扔鸡蛋(0) 回复

五行鼠
Lv.3
发表于 2020-11-14 20:41 复制 查看全部楼层
非常感谢,谢谢老师了。

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-14 07:02 复制 查看全部楼层
有未来,kt交易师
N:=10;
箱顶:PEAK(CLOSE,N,1)*0.98;
箱底:TROUGH(CLOSE,N,1)*1.02;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
中线:(箱顶+箱底)/2;
DRAWBAND(中线,RGB(255,234,154),箱底,RGB(255,234,154));
DRAWBAND(中线,RGB(109,187,129),箱顶,RGB(109,187,129));
KLINE(o,h,LOW,CLOSE,0);
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=LINEVALUE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,0,0),COLOR00FF00;
魔王:=LINEVALUE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,0,0),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
DRAWICON(TJ1 AND TJ2,l,4);
DRAWICON(TJ0 AND TJ3,h,5);
DRAWICON(FILTER(TJ1>0,1),L*0.99,4);
DRAWICON(FILTER(TJ0>0,1),H*1.01,5);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表