手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

短中长线彩带(源码 主图 通达信 贴图)

[通达信]
设置
3552 7 灰会兔 Lv.2 发表于 · 2020-11-13 19:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 石一峰 于 2020-11-13 21:52 编辑

短中长线彩带

N:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),MA(C,N*0.78),4,0),COLORYELLOW;
STICKLINE(C<MA(C,N),MA(C,N),MA(C,N*0.78),4,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
M:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),MA(C,M*0.7),4,0),COLORYELLOW;
STICKLINE(C<MA(C,M),MA(C,M),MA(C,M*0.7),4,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,3);
VAR5:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
D1:DRAWTEXT(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) ,LOW ,'★B'),COLORRED;
D2:DRAWTEXT(REF(VAR5,1)<5 AND VAR5>REF(VAR5,1) AND REF(VAR5,1)<REF(VAR5,2) AND VAR3<-0.3,LOW ,'★B'),COLORGREEN;
D3:DRAWTEXT(CROSS(VAR4,5) AND VAR3<-0.4,LOW ,'★B'),COLORBLUE;
Y:=MA(C,120);
VAR6:=(MA(C,5)-Y)/Y;
VAR7:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
VAR8:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
E1:DRAWTEXT(CLOSE<Z AND Z<REF(Z,1) AND REF(VAR4,1)>80 AND VAR4<REF(VAR4,1) AND REF(VAR4,1)>REF(VAR4,2),HIGH,'★S'),COLORBLUE;
E2:DRAWTEXT(CROSS(90,VAR4) AND VAR5>0.2,HIGH,'★S'),COLORGREEN;
E3:DRAWTEXT(CROSS(95,VAR4) AND VAR3>0.5,HIGH ,'★S'),COLORRED;

附件

02.png

举报

扔鸡蛋(0) 回复

沈德林
Lv.4
发表于 2020-11-14 12:58 复制 查看全部楼层
支持源码,谢谢您的分享!

举报

扔鸡蛋(0) 回复

小小vey
Lv.3
发表于 2020-11-14 11:10 复制 查看全部楼层
一个亿的指标!

举报

扔鸡蛋(0) 回复

洛丽泰
Lv.3
发表于 2020-11-14 10:04 复制 查看全部楼层
支持源码

举报

扔鸡蛋(0) 回复

小狐狸88
Lv.3
发表于 2020-11-14 08:15 复制 查看全部楼层
不错我喜欢,支持源码

举报

扔鸡蛋(0) 回复

石一峰
Lv.8
发表于 2020-11-13 21:53 复制 查看全部楼层
01.png


感谢分享!同时提醒楼主,贴子标题不符合版规!
(1)班长代为你编辑了标题,请以后按此格式建立标题。
(2)标题的格式和内容:
        ①指标名称(②指标或源码,③主图或副图或选股或预警,④适用平台-通达信或大智慧或同花顺或其他软件,⑤贴图)⑥是否加密限时。
(3)若不熟悉发帖规范,最好先阅读一下然后再发帖:http://www.55188.com/thread-5143142-1-1.html

举例:
b-标题格式yf.png

举报

点亮(1) 扔鸡蛋(0) 回复

石一峰
Lv.8
发表于 2020-11-13 21:52 复制 查看全部楼层
(1)没有与指标相匹配的指标配图是违规的!
(2)帮楼主补了一张图,望以后自觉遵守版规!
(3)若不熟悉发帖规范,最好先阅读一下再发帖:http://www.55188.com/thread-5143142-1-1.html

举报

点亮(2) 扔鸡蛋(0) 回复

温柔D狼
Lv.4
发表于 2020-11-13 19:30 复制 查看全部楼层
没有图。。。。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表