手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改下选股公式

[同花顺]
设置
924 1 十分十 Lv.2 发表于 · 2020-11-13 21:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
短线:=EMA(CLOSE,17),LINETHICK2,colorwhite;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13),LINETHICK2,COLORFF00FF;
STICKLINE(BARSLAST(短线<中线)>30,-3,8,2,0),colorliblue;
STICKLINE(BARSLAST(短线>中线)>30,-3,5,2,0),colorgreen;
RR8:=MA(CLOSE,60);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
底部区域:IF(RRD,60,70),colorred,LINETHICK2;
STICKLINE(RRD,60,70,0.2,0),colorred;
VAR1:=MA(WINNER(CLOSE),9)*100;
买!: CROSS(VAR1,2)*30,COLOR0000FF ,LINETHICK3 ;
VAR2:=(1-EMA((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15)),15))*100;
VAR3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,9,1);
VAR6:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
VAR7:=REF(VAR6,1)>13 AND REF(VAR6,1)/VAR6>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
春笋: IF(VAR7 AND REF(CLOSE,1)<=COST(5),20,0),LINESTICK ,COLOR00FF00,LINETHICK2;
VAR8:=MA(CLOSE,27);
VAR9:=(CLOSE-VAR8)/VAR8*100;
VARA:=MA(VAR9,2);
VARB:=BARSLAST(CROSS(-10,VARA)=1);
VARC:=BARSLAST(CROSS(VARA,10)=1);
VARD:=VARA<-10 AND VARB>3;
VARE:=VARA>10 AND VARC>3;
黄金坑: IF(VARD,VARA,0),LINESTICK ,LINETHICK2, coloryellow;
财神到: IF(VARE,VARA,0),LINESTICK , colorgreen;
稳赚买: IF(VARA>REF(VARA,1) AND VARD AND VARA<-15,30,0),LINETHICK2,LINESTICK,COLORFFA2AF;
DRAWICON(稳赚买>0,40,1);
VARF:=REF(LOW,1)*0.9;
VAR10:=LOW*0.9;
VAR11:=(VAR10*VOL+VARF*(CAPITAL-VOL))/CAPITAL;
VAR12:=EMA(VAR11,30);
VAR13:=CLOSE-REF(CLOSE,1);
VAR14:=MAX(VAR13,0);
VAR15:=ABS(VAR13);
VAR16:=SMA(VAR14,7,1)/SMA(VAR15,7,1)*100;
VAR17:=SMA(VAR14,13,1)/SMA(VAR15,13,1)*100;
VAR18:=BARSCOUNT(CLOSE);
VAR19:=SMA(MAX(VAR13,0),6,1)/SMA(ABS(VAR13),6,1)*100;
VAR1A:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1C:=SMA((SMA(VAR1B,4,1)-50)*2,3,1);
VAR1D:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1E:=SMA(VAR1D,4,1);
VAR1F:=SMA(VAR1E,3,1);
VAR20:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR21:=VAR19<=25 AND VAR1A<-95 AND VAR20>20 AND VAR1C<-30 AND VAR1F<30 AND VAR12-CLOSE>=-0.25 AND VAR16<22 AND VAR17<28 AND VAR18>50;
超跌: STICKLINE(VAR21,0,60,5,0);
90,colorblue;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),colorred;
趋势:EMA(EMA(趋势线,3),1),colorgreen;
见底信号: 2;
买点准备: IF(趋势线<=10,50,0);
买入时间: IF(CROSS(趋势线,见底信号),100,0),colorcyan;
主进场:IF(VAR5>REF(VAR5,1),1,0);
卖出警戒:STICKLINE(趋势线>=85,100,80,2,0),colormagenta;
止损出局:STICKLINE(CROSS(90,趋势线),100,70,1,0),COLORFFF666;
VR2:=LLV(LOW,10);
VR3:=HHV(HIGH,25);
VR4:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(L,1),0),13,1);
底部:IF(EMA(IF(L<=LLV(L,30),VR4,0),3)*10<100,EMA(IF(L<=LLV(L,30),VR4,0),3)*10,100),colorwhite;
VARK1:=ZIG(3,12);//理想股票论坛 www.70822.com
VARK2:=REF(VARK1,2)>REF(VARK1,1) AND VARK1>REF(VARK1,1);
VARK3:=REF(VARK1,2)<REF(VARK1,1) AND VARK1<REF(VARK1,1);
STICKLINE((VARK2=1),0,60,2,0),colorred;
STICKLINE((VARK3=1),0,60,2,0),colorblue;
VARFS2:=TROUGHBARS(3,15,1)<4;
VARFS1:=PEAKBARS(3,15,1)<4;
STICKLINE(FILTER(VARFS2=1,5),40,0,2,0),coloryellow;
STICKLINE(FILTER(VARFS1=1,5),35,0,2,0),colorgreen;
AA:=IF(BARSLAST(CROSS((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)))>=4 AND CROSS(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100) AND (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100>50,20,0);
STICKLINE(AA,90,100,2,0),COLOR00FF00;

请老师把同花顺的改成通达信的公式并在出黄柱信号时做一个选股

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-14 07:12 复制 查看全部楼层
有未来
短线:=EMA(CLOSE,17),LINETHICK2,COLORWHITE;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13),LINETHICK2,COLORFF00FF;
STICKLINE(BARSLAST(短线<中线)>30,-3,8,2,0),COLORLIBLUE;
STICKLINE(BARSLAST(短线>中线)>30,-3,5,2,0),COLORGREEN;
RR8:=MA(CLOSE,60);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
底部区域:IF(RRD,60,70),COLORRED,LINETHICK2;
STICKLINE(RRD,60,70,0.2,0),COLORRED;
VAR1:=MA(WINNER(CLOSE),9)*100;
买!: CROSS(VAR1,2)*30,COLOR0000FF ,LINETHICK3 ;
VAR2:=(1-EMA((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15)),15))*100;
VAR3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,9,1);
VAR6:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
VAR7:=REF(VAR6,1)>13 AND REF(VAR6,1)/VAR6>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
春笋: IF(VAR7 AND REF(CLOSE,1)<=COST(5),20,0),LINESTICK ,COLOR00FF00,LINETHICK2;
VAR8:=MA(CLOSE,27);
VAR9:=(CLOSE-VAR8)/VAR8*100;
VARA:=MA(VAR9,2);
VARB:=BARSLAST(CROSS(-10,VARA)=1);
VARC:=BARSLAST(CROSS(VARA,10)=1);
VARD:=VARA<-10 AND VARB>3;
VARE:=VARA>10 AND VARC>3;
黄金坑: IF(VARD,VARA,0),LINESTICK ,LINETHICK2, COLORYELLOW;
财神到: IF(VARE,VARA,0),LINESTICK , COLORGREEN;
稳赚买: IF(VARA>REF(VARA,1) AND VARD AND VARA<-15,30,0),LINETHICK2,LINESTICK,COLORFFA2AF;
DRAWICON(稳赚买>0,40,1);
VARF:=REF(LOW,1)*0.9;
VAR10:=LOW*0.9;
VAR11:=(VAR10*VOL+VARF*(CAPITAL-VOL))/CAPITAL;
VAR12:=EMA(VAR11,30);
VAR13:=CLOSE-REF(CLOSE,1);
VAR14:=MAX(VAR13,0);
VAR15:=ABS(VAR13);
VAR16:=SMA(VAR14,7,1)/SMA(VAR15,7,1)*100;
VAR17:=SMA(VAR14,13,1)/SMA(VAR15,13,1)*100;
VAR18:=BARSCOUNT(CLOSE);
VAR19:=SMA(MAX(VAR13,0),6,1)/SMA(ABS(VAR13),6,1)*100;
VAR1A:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1C:=SMA((SMA(VAR1B,4,1)-50)*2,3,1);
VAR1D:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1E:=SMA(VAR1D,4,1);
VAR1F:=SMA(VAR1E,3,1);
VAR20:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR21:=VAR19<=25 AND VAR1A<-95 AND VAR20>20 AND VAR1C<-30 AND VAR1F<30 AND VAR12-CLOSE>=-0.25 AND VAR16<22 AND VAR17<28 AND VAR18>50;
超跌: STICKLINE(VAR21,0,60,5,0);
90,COLORBLUE;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORRED;
趋势:EMA(EMA(趋势线,3),1),COLORGREEN;
见底信号: 2;
买点准备: IF(趋势线<=10,50,0);
买入时间: IF(CROSS(趋势线,见底信号),100,0),COLORCYAN;
主进场:IF(VAR5>REF(VAR5,1),1,0);
卖出警戒:STICKLINE(趋势线>=85,100,80,2,0),COLORMAGENTA;
止损出局:STICKLINE(CROSS(90,趋势线),100,70,1,0),COLORFFF666;
VR2:=LLV(LOW,10);
VR3:=HHV(HIGH,25);
VR4:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(L,1),0),13,1);
底部:IF(EMA(IF(L<=LLV(L,30),VR4,0),3)*10<100,EMA(IF(L<=LLV(L,30),VR4,0),3)*10,100),COLORWHITE;
VARK1:=ZIG(3,12);
VARK2:=REF(VARK1,2)>REF(VARK1,1) AND VARK1>REF(VARK1,1);
VARK3:=REF(VARK1,2)<REF(VARK1,1) AND VARK1<REF(VARK1,1);
STICKLINE((VARK2=1),0,60,2,0),COLORRED;
STICKLINE((VARK3=1),0,60,2,0),COLORBLUE;
VARFS2:=TROUGHBARS(3,15,1)<4;
VARFS1:=PEAKBARS(3,15,1)<4;
STICKLINE(FILTER(VARFS2=1,5),40,0,2,0),COLORYELLOW;
STICKLINE(FILTER(VARFS1=1,5),35,0,2,0),COLORGREEN;
AA:=IF(BARSLAST(CROSS((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)))>=4 AND CROSS(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100) AND (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100>50,20,0);
STICKLINE(AA,90,100,2,0),COLOR00FF00;

有未来,选股

VARFS:=TROUGHBARS(3,15,1)<4;
FILTER(VARFS=1,5);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表