手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股和副图指标

[通达信]
设置
1291 2 刘军1122 Lv.3 发表于 · 2020-11-13 21:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师把下面的编写一个选股和副图指标  

万分感谢老师

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
Z1:=REF(HIGH,4)=HHV(HIGH,2*4+1);
Y1:=FILTER(Z1,3);
C1:=BACKSET(Y1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
V2:=FILTER(A2,3);
C2:=BACKSET(V2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,''),COLORGREEN;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU2:=BACKSET(ISLASTBAR=1,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
突破线:REF(H,BARSLAST(VV2));
持仓线:REF(H,BARSLAST(XX2));
TP1:=CROSS(C,突破线);
TP2:=CROSS(C,持仓线);
DRAWTEXT(TP1,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;
DRAWTEXT(TP2,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;

举报

扔鸡蛋(0) 回复

刘军1122
Lv.3
发表于 2020-11-14 11:38 复制 查看全部楼层
南山翁2007 发表于 2020-11-13 22:13
你要的选股和副图1:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);

麻烦老师看看这个与上面的有什么不一样   下面的能做选股和副图吗   谢谢老师

LT:=LLVBARS(L,60);
LTT:=BARSLAST(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
A:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORYELLOW,LINETHICK2;
TT:=BARSLAST(CURRBARSCOUNT=CONST(HT)+1);
AA:=CROSS(C,CONST(A));
TJ:=COUNT(AA,TT+1)=1 AND AA;
TJ1:=COUNT(V<MA(V,277),TT+1) ;
BL:=TJ1/(TT+1)*100;
XG:=TJ AND TT>40 AND BL>70;
XGT:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(XG))+1);
ZH:=REF(H,TT);
YL:=REF(L,LTT);
XC:=REF(C,XGT);
YZ:=(XC-YL)/YL*100;
ZBL:=YZ/REF(LTT,XGT);
XGA:=XG AND ZBL<2.95;
DRAWLINE(TT=0,H,LTT=0,L,0),COLORRED;
DRAWLINE(LTT=0,L,XGT=0,L,0),COLORRED;
DRAWICON(XGA,L*0.95,9);

举报

点亮(1) 扔鸡蛋(0) 回复

南山翁2007
Lv.4
发表于 2020-11-13 22:13 复制 查看全部楼层
你要的选股和副图1:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
Z1:=REF(HIGH,4)=HHV(HIGH,2*4+1);
Y1:=FILTER(Z1,3);
C1:=BACKSET(Y1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
V2:=FILTER(A2,3);
C2:=BACKSET(V2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU2:=BACKSET(ISLASTBAR=1,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
突破线:=REF(H,BARSLAST(VV2));
TP1:CROSS(C,突破线);


选股和副图2:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
Z1:=REF(HIGH,4)=HHV(HIGH,2*4+1);
Y1:=FILTER(Z1,3);
C1:=BACKSET(Y1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
V2:=FILTER(A2,3);
C2:=BACKSET(V2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU2:=BACKSET(ISLASTBAR=1,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
持仓线:=REF(H,BARSLAST(XX2));
TP2:CROSS(C,持仓线);

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表