手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改成通达信指标公式

[通达信]
设置
1532 2 自然醒2008 Lv.4 发表于 · 2020-11-14 01:37 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{D通____主图}
XDC:=DMA(C,VOL/MA(V,21));
回调认同:=EMA(EXPMA(XDC,20),13),CROSSDOT,LINETHICK1,COLORRED;
{天狼剑部分}
B1:=MA(C,1);
B2:SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
LY:=10; BL:=40;
CLY:=XMA(CLOSE,LY); JBL:=XMA(CLOSE,BL);
N:=REF(JBL,BL/2+1-CURRBARSCOUNT)/REF(JBL,BL/2+2-CURRBARSCOUNT);
M:=REF(CLY,LY/2+1-CURRBARSCOUNT)/REF(CLY,LY/2+2-CURRBARSCOUNT);
上轨:IF(CURRBARSCOUNT>BL/2,JBL*1.1,REF(JBL,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1);
下轨:IF(CURRBARSCOUNT>BL/2,JBL*0.9,REF(JBL,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
Z上:IF(CURRBARSCOUNT>LY/2,CLY*1.05,REF(CLY,LY/2+1-CURRBARSCOUNT)*
POW(M,LY/2+1-CURRBARSCOUNT)*1.05)COLORLIMAGENTA;
Z下:IF(CURRBARSCOUNT>LY/2,CLY*0.95,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*0.95)COLORLIMAGENTA;
X上:=IF(CURRBARSCOUNT>LY/2,CLY*1.02,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*1.02)COLORLIMAGENTA;
X下:=IF(CURRBARSCOUNT>LY/2,CLY*0.98,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*0.98)COLORLIMAGENTA;
{DRAWTEXT(L<=Z下,(L * 0.998),’抢’),COLORYELLOW;}
DRAWTEXT(CROSS(H,Z上),(H * 1.01),’砸’),COLORYELLOW;
H1:=HHV(MA(B2,1),13),COLORYELLOW;
H2:=HHV(MA(B2,1),21),COLORYELLOW;
H3:=HHV(MA(B2,1),34),COLORYELLOW;
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK2;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK1;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
{STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;}
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR
VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1)
AND VAR2);
{}
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
{B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);}
LP:=H>=X下 AND H>=B2 AND L<=X下 AND L<=B2 ;
DRAWICON(LP=1,Z下,25);
{DRAWTEXT(L-Z下<=0.10 AND L>=Z下,(L * 0.998),’B’),COLORYELLOW;}
险:=(( O>=Z上 AND H>REF(H,1)));
DRAWTEXT(险,H*1.02,’卖’);
机:=((L<=Z下 AND C>=REF(L,1)));
DRAWTEXT(H>=Z上 AND AA ,H*1.01,’逃’);
DRAWICON(H>=Z上 AND AA ,( HIGH*1.01),2) ,COLORBLUE;
STICKLINE(机,OPEN,CLOSE,1,0),COLORMAGENTA;
{理想论坛–股票公式网站 www.55188.com}
XS:=MA(LOW,5)*(1-5/100),LINETHICK0;
XS1:=MA(HIGH,5)*(1+5/100);
{DRAWTEXT(CROSS(XS1,C),H*1.01,’砸’),COLORWHITE;}
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
{DRAWTEXT(曙光初现,L-L*0.02,’光’),COLORGREEN;}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);
HD:=(HIGH – REF(HIGH,1));
LD:=(REF(LOW,1) – LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));
NEWVOL:=(RSI5 – WR10);
秋天梦想:=(AV + NEWVOL);
{DRAWTEXT(CROSS(秋天梦想,0),L*0.97,’秋天’),COLORFF00FF;}
{DRAWICON(CROSS(秋天梦想,0),L*0.98,1);}
DRAWTEXT(CROSS(82,VARR1),H*1.005,’回家种田’),COLORBLUE;
RSI59:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
逃命:=CROSS(80,RSI59);
DRAWICON(逃命,H*1.005,15);
TJA3:=REF("CCI.CCI",1)>90 AND "CCI.CCI"<REF("CCI.CCI",1);
TJB3:=REF("KDJ.J"(9,3,3),1)>90 AND "KDJ.J"(9,3,3)<REF( "KDJ.J"(9,3,3),1);
TJC3:=REF("RSI.RSI1",1)>70 AND "RSI.RSI1"<REF("RSI.RSI1",1);
TJD3:=COUNT(TJA3,5) AND COUNT(TJB3,5) AND COUNT(TJC3,5);
大顶:=CROSS(TJD3,0.5);
DRAWICON(大顶,H*1.005,2);
{快赢}
T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;
SL:=(T/REF(T,1)-1)*1000;
X:=XMA(XMA(XMA(SL,3),3),3)-XMA(XMA(XMA(SL,5),5),5);
中期趋势:=XMA(XMA(XMA(SL,7),7),7),LINETHICK2,COLORGREEN;
长期趋势:=XMA(XMA(XMA(SL,21),21),21),LINETHICK2,COLORBLUE;
DRAWICON(CROSS(中期趋势,长期趋势),L*0.98,13);
DRAWICON(CROSS(长期趋势,中期趋势),H*1.01,14);
DRAWICON(CROSS(X,长期趋势) AND 中期趋势>=长期趋势,L*0.97,11);
DRAWICON(CROSS(长期趋势,0),L*0.98,26);
DRAWICON(CROSS(0,长期趋势),L*0.98,27);

举报

扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-14 13:06 复制 查看全部楼层
竹隐风雷 发表于 2020-11-14 02:55
{D通____主图}
XDC:=DMA(C,VOL/MA(V,21));
回调认同:=EMA(EXPMA(XDC,20),13),CROSSDOT,LINETHICK1,COLORR ...

十分感谢竹老师

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-14 02:55 复制 查看全部楼层
{D通____主图}
XDC:=DMA(C,VOL/MA(V,21));
回调认同:=EMA(EXPMA(XDC,20),13),CROSSDOT,LINETHICK1,COLORRED;
{天狼剑部分}
B1:=MA(C,1);
B2:SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
LY:=10; BL:=40;
CLY:=XMA(CLOSE,LY); JBL:=XMA(CLOSE,BL);
N:=REF(JBL,BL/2+1-CURRBARSCOUNT)/REF(JBL,BL/2+2-CURRBARSCOUNT);
M:=REF(CLY,LY/2+1-CURRBARSCOUNT)/REF(CLY,LY/2+2-CURRBARSCOUNT);
上轨:IF(CURRBARSCOUNT>BL/2,JBL*1.1,REF(JBL,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1);
下轨:IF(CURRBARSCOUNT>BL/2,JBL*0.9,REF(JBL,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
Z上:IF(CURRBARSCOUNT>LY/2,CLY*1.05,REF(CLY,LY/2+1-CURRBARSCOUNT)*
POW(M,LY/2+1-CURRBARSCOUNT)*1.05)COLORLIMAGENTA;
Z下:IF(CURRBARSCOUNT>LY/2,CLY*0.95,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*0.95)COLORLIMAGENTA;
X上:=IF(CURRBARSCOUNT>LY/2,CLY*1.02,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*1.02)COLORLIMAGENTA;
X下:=IF(CURRBARSCOUNT>LY/2,CLY*0.98,REF(CLY,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*0.98)COLORLIMAGENTA;
{DRAWTEXT(L<=Z下,(L * 0.998),’抢’),COLORYELLOW;}
DRAWTEXT(CROSS(H,Z上),H * 1.01,'砸'),COLORYELLOW;
H1:=HHV(MA(B2,1),13),COLORYELLOW;
H2:=HHV(MA(B2,1),21),COLORYELLOW;
H3:=HHV(MA(B2,1),34),COLORYELLOW;
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK2;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK1;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
{STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;}
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR
VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1)
AND VAR2);
{}
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
{B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);}
LP:=H>=X下 AND H>=B2 AND L<=X下 AND L<=B2 ;
DRAWICON(LP=1,Z下,25);
{DRAWTEXT(L-Z下<=0.10 AND L>=Z下,(L * 0.998),’B’),COLORYELLOW;}
险:=(( O>=Z上 AND H>REF(H,1)));
DRAWTEXT(险,H*1.02,'卖');
机:=((L<=Z下 AND C>=REF(L,1)));
DRAWTEXT(H>=Z上 AND AA ,H*1.01,'逃');
DRAWICON(H>=Z上 AND AA ,( HIGH*1.01),2) ,COLORBLUE;
STICKLINE(机,OPEN,CLOSE,1,0),COLORMAGENTA;
{理想论坛–股票公式网站 WWW.55188.COM}
XS:=MA(LOW,5)*(1-5/100),LINETHICK0;
XS1:=MA(HIGH,5)*(1+5/100);
{DRAWTEXT(CROSS(XS1,C),H*1.01,’砸’),COLORWHITE;}
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
{DRAWTEXT(曙光初现,L-L*0.02,’光’),COLORGREEN;}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);
HD:=(HIGH – REF(HIGH,1));
LD:=(REF(LOW,1) – LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));
NEWVOL:=(RSI5 – WR10);
秋天梦想:=(AV + NEWVOL);
{DRAWTEXT(CROSS(秋天梦想,0),L*0.97,’秋天’),COLORFF00FF;}
{DRAWICON(CROSS(秋天梦想,0),L*0.98,1);}
DRAWTEXT(CROSS(82,VARR1),H*1.005,'回家种田'),COLORBLUE;
RSI59:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
逃命:=CROSS(80,RSI59);
DRAWICON(逃命,H*1.005,15);
TJA3:=REF(CCI.CCI,1)>90 AND CCI.CCI<REF(CCI.CCI,1);
TJB3:=REF(KDJ.J,1)>90 AND KDJ.J<REF(KDJ.J,1);
TJC3:=REF(RSI.RSI1,1)>70 AND RSI.RSI1<REF(RSI.RSI1,1);
TJD3:=COUNT(TJA3,5) AND COUNT(TJB3,5) AND COUNT(TJC3,5);
大顶:=CROSS(TJD3,0.5);
DRAWICON(大顶,H*1.005,2);
{快赢}
T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;
SL:=(T/REF(T,1)-1)*1000;
X:=XMA(XMA(XMA(SL,3),3),3)-XMA(XMA(XMA(SL,5),5),5);
中期趋势:=XMA(XMA(XMA(SL,7),7),7),LINETHICK2,COLORGREEN;
长期趋势:=XMA(XMA(XMA(SL,21),21),21),LINETHICK2,COLORBLUE;
DRAWICON(CROSS(中期趋势,长期趋势),L*0.98,13);
DRAWICON(CROSS(长期趋势,中期趋势),H*1.01,14);
DRAWICON(CROSS(X,长期趋势) AND 中期趋势>=长期趋势,L*0.97,11);
DRAWICON(CROSS(长期趋势,0),L*0.98,26);
DRAWICON(CROSS(0,长期趋势),L*0.98,27);
查看全部打赏
  • 自然醒2008+20理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表