手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个出现'狙击'的选股公式

[通达信]
设置
1650 9 阿华hxh Lv.3 发表于 · 2020-11-14 09:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
HAN:=DATE<1141230;
当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
DRAWKLINE(H,O,L,C);
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:COST(九十成本集中),LINETHICK2,COLORMAGENTA;
入1:IF(成本价>REF(成本价,1),成本价,DRAWNULL),COLORRED,LINETHICK2;
出1:IF(成本价<REF(成本价,1),成本价,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>HIGH,HIGH,LOW,0,0),COLORGREEN;
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:(C-O)/O*100,NODRAW;
V型反转:=L<成本价 AND DF2;
V型反转2:=CROSS(C,成本价) AND DF2;
V型反转3:=L<成本价 AND DF3;
DRAWTEXT(V型反转,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转2,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转3,L*0.98,'↖狙击'),COLORCYAN;
STICKLINE(V型反转=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转2=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转3=1,C,O,3.2,0),COLORRED;

举报

扔鸡蛋(0) 回复

阿华hxh
Lv.3
发表于 2020-11-15 08:04 复制 查看全部楼层
一天行情:谢谢你,作为副图导入可以。

举报

扔鸡蛋(0) 回复

阿华hxh
Lv.3
发表于 2020-11-15 07:57 复制 查看全部楼层
天子蓝1:谢谢你,导入通过了

举报

扔鸡蛋(0) 回复

天子蓝1
Lv.2
发表于 2020-11-15 00:32 复制 查看全部楼层
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:=COST(九十成本集中);
入1:=IF(成本价>REF(成本价,1),成本价,DRAWNULL);
出1:=IF(成本价<REF(成本价,1),成本价,DRAWNULL);

DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:=(C-O)/O*100,;
V型反转:=L<成本价 AND DF2;
V型反转2:=CROSS(C,成本价) AND DF2;
V型反转3:=L<成本价 AND DF3;
狙击:V型反转 OR V型反转2 OR V型反转3;

举报

扔鸡蛋(0) 回复

周游25
Lv.2
发表于 2020-11-14 22:06 复制 查看全部楼层
阿华hxh 发表于 2020-11-14 17:33
当前公式 : 狙击 (条件选股公式)  
错误句 :
当天涨幅:=(C-O)/O*100,NODRAW

楼上的答复是没有毛病的,已经验证

举报

扔鸡蛋(0) 回复

蕙澜
Lv.2
发表于 2020-11-14 18:12 复制 查看全部楼层
虽然看不懂,貌似很厉害

举报

扔鸡蛋(0) 回复

阿华hxh
Lv.3
发表于 2020-11-14 17:33 复制 查看全部楼层
当前公式 : 狙击 (条件选股公式)  
错误句 :
当天涨幅:=(C-O)/O*100,NODRAW
详细信息 : 不是画线指标公式,不能指定画线类型!
错误起始位置 : 231 ; 长度: 1

举报

扔鸡蛋(0) 回复

峰10008
Lv.3
发表于 2020-11-14 14:23 复制 查看全部楼层
阿华hxh 发表于 2020-11-14 12:15
一天行情:你这个导入通不过哟

公式可以通过的

附件

截图未命名01.png

举报

扔鸡蛋(0) 回复

阿华hxh
Lv.3
发表于 2020-11-14 12:15 复制 查看全部楼层
一天行情:你这个导入通不过哟

举报

扔鸡蛋(0) 回复

一天行情
Lv.3
发表于 2020-11-14 10:19 复制 查看全部楼层
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:=COST(九十成本集中);
入1:=IF(成本价>REF(成本价,1),成本价,DRAWNULL);
出1:=IF(成本价<REF(成本价,1),成本价,DRAWNULL);

DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:=(C-O)/O*100,NODRAW;
V型反转:=L<成本价 AND DF2;
V型反转2:=CROSS(C,成本价) AND DF2;
V型反转3:=L<成本价 AND DF3;
狙击:V型反转 OR V型反转2 OR V型反转3;

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表