手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将通达信公式改为飞狐用

[飞 狐]
设置
1241 1 五行鼠 Lv.3 发表于 · 2020-11-14 21:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWGBK(O>C,RGB(50,25,0),RGB(0,25,50),0,0,0);

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
Z4:DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.001,0.050,0,GNBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.002,0.1,0,ZDBLOCK);
LHB:SIGNALS_USER(4,1);
DRAWTEXT(LHB,H,'龙虎'),COLORWHITE;
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13),COLORYELLOW;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
顶:=1.3*AHC2;
内上:=1.06*AHC2;
内下:=AHC2*0.94;
底:=AHC2*0.87,DOTLINE,COLORGREEN;
IF((内上 <= REF(内上,1)),内上,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((内上 >= REF(内上,1)),内上,DRAWNULL),COLORMAGENTA,DOTLINE,LINETHICK2;
IF((内下 <= REF(内下,1)),内下,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((内下 >= REF(内下,1)),内下,DRAWNULL),COLORMAGENTA,DOTLINE,LINETHICK2;
爆:=REF(O<内上,1) AND C>内上 AND O>内上;
牛股:=C>内上 AND O>内上;
{
AR:=BARSLAST(牛股);
DRAWKLINE(H,O,L,C);
STICKLINE( 牛股 AND C>O,C,O,3.2,0),COLOR000066;
STICKLINE(牛股 AND C>O,C,O,2.0,0),COLOR000077;
STICKLINE(牛股 AND C>O,C,O,1.5,0),COLOR000099;
STICKLINE(牛股 AND C>O,C,O,0.9,0),COLOR0000CC;
STICKLINE(牛股 AND C>O,C,O,0.5,0),COLOR0000FF;
STICKLINE(牛股 AND C>O,O,C,0,0),COLORFFFFFF;
STICKLINE( 牛股 AND C<O,L,H,0,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,3.2,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,2.5,0),COLOR00BB00;
STICKLINE(牛股 AND C<O,C,O,1.5,0),COLOR00DD00;
STICKLINE(牛股 AND C<O,C,O,0.5,0),COLOR00FF00;
STICKLINE(牛股 AND C<O,C,O,0,0),COLORFFFFFF;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
操作线1:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
潜伏:=操作线<10 AND 内上>=REF(内上,1);
DRAWICON(潜伏,L*0.98,34);

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-15 07:19 复制 查看全部楼层
本帖最后由 注册111 于 2020-11-15 07:57 编辑

kt交易师
DRAWGBK(c>o,colorRGB(50,25,0),coloRrGB(0,25,50),0);
DRAWTEXTEX(c,0,0,0,'行业:'+INDUSTRYNAME+'  板块.概念:'+BLKNAME),colorAFFF,ALIGN5;
AHC1:=CLOSE*VOL;
AHC2:=EMA((EMA(AHC1,3)/ema(VOL,3)+ema(AHC1,6)/ema(VOL,6)+ema(AHC1,12)/ema(VOL,12)+ema(AHC1,24)/ema(VOL,24))/4,13),COLORYELLOW;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
顶:=1.3*AHC2;
内上:=1.06*AHC2;
内下:=AHC2*0.94;
底:=AHC2*0.87, LINEDOT,COLORGREEN;
PARTLINE((内上 <= REF(内上,1)),内上 ),COLORGREEN, LINEDOT,LINETHICK2;
PARTLINE((内上 >= REF(内上,1)),内上 ),COLORMAGENTA, LINEDOT,LINETHICK2;
PARTLINE((内下 <= REF(内下,1)),内下),COLORGREEN, LINEDOT,LINETHICK2;
PARTLINE((内下 >= REF(内下,1)),内下 ),COLORMAGENTA, LINEDOT,LINETHICK2;
爆:=REF(O<内上,1) AND C>内上 AND O>内上;
牛股:=C>内上 AND O>内上;
AR:=BARSLAST(牛股);
KLINE(o,h,l,c,0);
{STICKLINE( 牛股 AND C>O,C,O,8,0),COLOR000066;
STICKLINE(牛股 AND C>O,C,O,2.0,0),COLOR000077;
STICKLINE(牛股 AND C>O,C,O,1.5,0),COLOR000099;
STICKLINE(牛股 AND C>O,C,O,0.9,0),COLOR0000CC;
STICKLINE(牛股 AND C>O,C,O,0.5,0),COLOR0000FF;
STICKLINE(牛股 AND C>O,O,C,0,0),COLORFFFFFF;
STICKLINE( 牛股 AND C<O,L,H,0,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,8,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,2.5,0),COLOR00BB00;
STICKLINE(牛股 AND C<O,C,O,1.5,0),COLOR00DD00;
STICKLINE(牛股 AND C<O,C,O,0.5,0),COLOR00FF00;
STICKLINE(牛股 AND C<O,C,O,0,0),COLORFFFFFF};
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
操作线1:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
潜伏:=操作线<10 AND 内上>=REF(内上,1);
DRAWICON(潜伏,L*0.98,6);
查看全部打赏
  • 快乐398+18理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表