手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做钱袋子和金K线选股

[通达信]
设置
1108 1 邵建国064 Lv.3 发表于 · 2020-11-15 08:55 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
CS:="MFI.MFI"(12,9);M3:MA(CLOSE,3);
X3:=IF(DATE<2342.46*500,1,1);主力线:MA(CLOSE,13)*X3,COLORYELLOW;
趋势线:MA(CLOSE,34)*X3,COLORRED,LINETHICK2;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL)*X3,COLORGREEN,LINETHICK2;
C2:=REF(C,1);强:=V/REF(MA(V,5),1);JDZB:=强>135 AND 强<137;
BA:=IF((DATETODAY(DATE))<9999,1,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来COLOR00FFFF}
BG2:=IF((H-L)*100/C2>=3.58,1,0)*BA;
BB1:=L<REF(L,1)*BA;
SELL1:=BG AND BB1 ;
BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);{COLOR00FFFF第二个条件开盘价太低升上来COLOR00FFFF}
STICKLINE(BR,O,C,3,0)*BA,COLORRED;
DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
BUY1:=BR AND BB2  AND BB4;
DAY2:=BARSLAST(BUY1)*X3;
S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
STICKLINE(S1,O,C,3,0)*X3,COLORGREEN;
STICKLINE(B1,H,L,0.3,0)*X3,COLORRED;
STICKLINE(B1,O,C,3,1)*X3,LINETHICK2,COLORRED;
AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
STICKLINE(FF2,H,L,0.3,0)*X3;
B4:=BARSLAST(FF2);
E4:=B4<5;
F4:=E4 AND C>REF(C,1);
STICKLINE(F4,H,L,0.3,0)*BA,COLORLIRED;
SFKG:=(强>4.18 AND 强<4.192);
SFKG3:=(强>2.67 AND 强<2.69);
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1)*BA ;
STICKLINE(CC,H,L,0.3,0)*X3,COLORRED;
STICKLINE(CC,O,C,3,1)*X3,LINETHICK2,COLORRED;
SCSM:=(强>2.07 AND 强<2.08);
SJGW:=(强>3.75 AND 强<3.77);
CF1:=BARSLAST(CC);
CF2:=CF1<3;
CF3:=CF2 AND C>REF(C,1);
STICKLINE(CF3,O,C,3,0),COLORGREEN;
CD:=CROSS(VAR2,VAR1);
STICKLINE(CD,H,L,0.3,0)*X3,COLORGREEN;
STICKLINE(CD,O,C,3,1)*X3,COLORGREEN;
HBGS:=(强>4.67 AND 强<4.69);
JOGF:=(强>2.91 AND 强<2.93);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0)*BA;
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0)*XS;
LFFZ:=(强>3.28 AND 强<3.30);
TYDL:=(强>6.77 AND 强<6.79);
RUO:=JDZB OR SFKG OR SFKG3 OR HBGS OR JOGF  OR SCSM OR SJGW OR LFFZ OR TYDL;
DRAWICON(FILTER((VAR4AA>90),40),(LOW)*(0.93),9)*X3;
DRAWICON(RUO,(LOW)*(0.93),9)*X3;
VAR111:=(C+H+O+L)/4;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE(CROSS(84,VAR7),CLOSE,OPEN,2.8,0)*BA,COLORGREEN;
卖出:=CROSS(84,VAR7)*X3;
DRAWTEXT(卖出,H*1.001,'')*X3,COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)*BA)*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
何氏抄底:=REF(J,1)<10  AND REF(MACD,1)<REF(MACD,2) AND MACD>REF(MACD,1) AND MACD<0 AND
CCI>REF(CCI,1)*BA AND (REF(CCI,2)<-100 OR REF(CCI,3)<-100)*X3;
STICKLINE(何氏抄底,CLOSE,OPEN,3.2,0)*X3,COLORYELLOW;
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA)*BA;
周金叉:=CROSS(周DIF,周DEA)*BA;
月金叉:=CROSS(月DIF,月DEA)*BA;
金叉共振:=IF(CROSS(周DIF,周DEA)*BA,MACD+0.1,0)*X3,COLORWHITE,LINETHICK2;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉) AND C/REF(C,1)>1.08
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉)*BA OR (日金叉 AND 周金叉 AND 月金叉)*BA,MACD+0.2,0)*X3,COLORF00FF0,LINETHICK3;  
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,3.2,0),COLOR0077FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,2.5,0),COLOR0099FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.9,0),COLOR00BBFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.2,0),COLOR00DDFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,0.3,0),COLOR00FFFF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,3,0),COLOR000099;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,2.2,0),COLOR0000CC;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,1.5,0),COLOR0000FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,0.5,0),COLORCC66FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.05,C,0.5,0),COLORYELLOW;
STICKLINE(RUO AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,3.2,0),COLOR0077FF;
STICKLINE(RUO AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,2.5,0),COLOR0099FF;
STICKLINE(RUO AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.9,0),COLOR00BBFF;
STICKLINE(RUO AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.2,0),COLOR00DDFF;
STICKLINE(RUO AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,0.3,0),COLOR00FFFF;
STICKLINE(RUO AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,3,0),COLOR000099;
STICKLINE(RUO AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,2.2,0),COLOR0000CC;
STICKLINE(RUO AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,1.5,0),COLOR0000FF;
STICKLINE(RUO AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,0.5,0),COLORCC66FF;
STICKLINE(RUO AND C/REF(C,1)>1.08,REF(C,1)*1.05,C,0.5,0),COLORYELLOW;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-15 12:00 复制 查看全部楼层
CS:="MFI.MFI"(12,9);M3:=MA(CLOSE,3);
X3:=IF(DATE<2342.46*500,1,1);
主力线:=MA(CLOSE,13)*X3;
趋势线:=MA(CLOSE,34)*X3;
C2:=REF(C,1);强:=V/REF(MA(V,5),1);
JDZB:=强>135 AND 强<137;
BA:=IF((DATETODAY(DATE))<9999,1,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来COLOR00FFFF}
BG2:=IF((H-L)*100/C2>=3.58,1,0)*BA;
BB1:=L<REF(L,1)*BA;
SELL1:=BG AND BB1 ;
BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);{COLOR00FFFF第二个条件开盘价太低升上来COLOR00FFFF}
DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
BUY1:=BR AND BB2  AND BB4;
DAY2:=BARSLAST(BUY1)*X3;
S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
B4:=BARSLAST(FF2);
E4:=B4<5;
F4:=E4 AND C>REF(C,1);
SFKG:=(强>4.18 AND 强<4.192);
SFKG3:=(强>2.67 AND 强<2.69);
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1)*BA ;
SCSM:=(强>2.07 AND 强<2.08);
SJGW:=(强>3.75 AND 强<3.77);
CF1:=BARSLAST(CC);
CF2:=CF1<3;
CF3:=CF2 AND C>REF(C,1);
CD:=CROSS(VAR2,VAR1);
HBGS:=(强>4.67 AND 强<4.69);
JOGF:=(强>2.91 AND 强<2.93);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0)*BA;
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0)*XS;
LFFZ:=(强>3.28 AND 强<3.30);
TYDL:=(强>6.77 AND 强<6.79);
RUO:=JDZB OR SFKG OR SFKG3 OR HBGS OR JOGF  OR SCSM OR SJGW OR LFFZ OR TYDL;
FILTER((VAR4AA>90),40)*X3||RUO*X3;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表