手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个波段选股公式

[通达信]
设置
1094 3 吃大面1 Lv.1 发表于 · 2020-11-15 12:28 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师写个选股公式谢谢
1、去除ST,去除创业板,
2、换手大于3%
3、macd在0轴上最近5天内金叉。
4、5日均线上穿20日均线,10日均线小于20日均线、
5、5日、10日.20日、40日、120日均线多头排列
6.5日均线上穿30日均线

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-17 09:13 复制 查看全部楼层
吃大面1 发表于 2020-11-16 23:47
老师你好看下这个 有问题,帮修改一下谢谢
去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE ...

去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0;
换手率:=COUNT(V/CAPITAL*100>5,12)>=3;
TA:=BARSLAST(CLOSE);
MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=MA(C,20);
MA4:=MA(C,60);
MA5:=MA(C,120);
MA6:=MA(C,250);

均线小:=C>MA3 AND C>MA4 AND MA4>=REF(MA4 ,1);
均线中:=C>MA3 AND C>MA4 AND MA5 AND MA4>=REF(MA4 ,1);
均线大:=C>MA3 AND C>MA4 AND MA5 AND MA4>=REF(MA4 ,1) AND C>MA6;
均线:=IF(TA>=250,均线大,均线大) OR IF(TA<=250,均线中,均线大)
OR IF(TA<=120,均线小,均线中);

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
FF:=EXIST(CROSS(DIF,DEA),5) AND DEA>3 AND CROSS(MA1,MA3);
预选:去ST AND  换手率  AND 均线 AND FF;

举报

点亮(0) 扔鸡蛋(0) 回复

吃大面1
Lv.1
发表于 2020-11-16 23:47 复制 查看全部楼层
许昌舍得 发表于 2020-11-15 20:15
去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0
AND NAMELIKE('S*ST')=0 AND NAME ...

老师你好看下这个 有问题,帮修改一下谢谢
去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0
换手率:=COUNT(V/CAPITAL*100>5,12)>=3;
TA:=BARSSIHCE(CLOSE);
MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=MA(C,20);
MA4:=MA(C,60);
MA5:=MA(C,120);
MA6:=MA(C,250);

均线小:=C>MA3 AND C>MA4 AND MA4>=REF(MA4 ,1);
均线中:=C>MA3 AND C>MA4 AND MA5 AND MA4>=REF(MA4 ,1);
均线中:=C>MA3 AND C>MA4 AND MA5 AND C>MA6 AND MA4>=REF(MA4 ,1);
均线:=IF(TA>=250,均线大,均线大)OR IF(TA<=250,均线中,均线大)
OR IF(TA<=120,均线小,均线);

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9)
MACD:=(DIF-DEA)*2;
FF:=EXIST(CROSS(DIF,DEA),5) AND DEA>3 AND CROSS(MA1,MA3);
预选:去除ST AND 流通股 AND 换手率  AND 均线 FF;

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-15 20:15 复制 查看全部楼层
去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0
AND NAMELIKE('S*ST')=0 AND NAMELIKE('S ST')=0 ;

去创业板:=IF(CODELIKE('300'),0,1);

TJ:去ST AND 去创业板
AND HSL.HSL>3
AND EXIST(MACD.DEA>0 AND CROSS(MACD.DIF,MACD.DEA),5)
AND CROSS(MA(C,5),MA(C,20)) AND MA(C,10)<MA(C,20)
AND MA(C,5)>MA(C,10) AND  MA(C,10)>MA(C,20) AND  MA(C,20)>MA(C,40) AND  MA(C,40)>MA(C,120)
AND CROSS(MA(C,5),MA(C,30));
查看全部打赏
  • 吃大面1+2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表