手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股

[通达信]
设置
801 1 狼要吃肉 Lv.3 发表于 · 2020-11-15 15:41 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1 AND T3;



XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1);

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-11-15 16:14 复制 查看全部楼层
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:= REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1);
XG: (XG1 || XG2 || XG3 || XG4) && (ST && TP1) && M1 && T3 && 挖坑;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表