请老师帮忙合并一个选股

[通达信]
设置
1349 5 狼要吃肉 Lv.3 发表于 · 2020-11-15 15:43 显示全部楼层 正序浏览 |
跳转到指定楼层
选股一
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1 AND T3;



选股二
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
A:=250;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);

JH:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIFF,DEA),A);
SH:=INTPART(JH/DH)/2;
DIFF50:=SH*DIFF+50,COLORFFFF00;
DEA50:=SH*DEA+50,COLORBLUE;

诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);

洗盘:=FILTER(诱空,3) AND 诱空;

XA_1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_2:=REF(CLOSE,1);
XA_3:=SMA(MAX(CLOSE-XA_2,0),2,1)/SMA(ABS(CLOSE-XA_2),2,1)*100;
XA_4:=45;
XA_5:=20;
XA_6:=XA_3<XA_4 AND REF(XA_3,1)>XA_4;
XA_7:=XA_3<XA_5 AND REF(XA_3,1)>XA_5;
XA_8:=REF(COUNT(XA_1,5),1)>=1;
XA_9:=SMA(LOW,4,3);
XG:XA_9 AND (REF(XA_6,1) OR REF(XA_7,1)) AND XA_8 AND 洗盘 AND C/REF(C,1)<1.05;

举报

使用道具 扔鸡蛋(0) 回复

周游25
Lv.3
发表于 2020-11-15 16:49 复制 查看全部楼层

那就没有办法了!毕竟你合并公式,可能会因为条件太多的因素

举报

使用道具 点亮(3) 扔鸡蛋(0) 回复

狼要吃肉
Lv.3
发表于 2020-11-15 16:46 复制 查看全部楼层
周游25 发表于 2020-11-15 16:44
再试试看,已经试过了

选不出票呀

举报

使用道具 扔鸡蛋(0) 回复

周游25
Lv.3
发表于 2020-11-15 16:44 复制 查看全部楼层

再试试看,已经试过了

举报

使用道具 扔鸡蛋(0) 回复

狼要吃肉
Lv.3
发表于 2020-11-15 16:34 复制 查看全部楼层
周游25 发表于 2020-11-15 16:25
A11:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A21:=REF(C,1)REF(O,3) AND REF(O,1)/REF(O,3)MA(C ...

不对啊

举报

使用道具 扔鸡蛋(0) 回复

周游25
Lv.3
发表于 2020-11-15 16:25 复制 查看全部楼层
本帖最后由 周游25 于 2020-11-15 16:43 编辑

A11:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A21:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A31:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG11:=A11 AND A21 AND A31;
AB11:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB21:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB31:=O<REF(O,1) AND C>REF(H,1);
XG21:=AB11 AND AB21 AND AB31;
ZA11:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA21:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA31:=C>REF(H,1);
XG31:=ZA11 AND ZA21 AND ZA31;
AC11:=REF(C,1)/REF(C,2)<0.92;
AC21:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC31:=O/REF(C,1)<1.09;
XG41:=AC11 AND AC21 AND AC31;
ST1:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP11:=DYNAINFO(4)>0;
AA1:=EMA(SLOPE(C,21)*20+C,42);
T71:=(L-AA1)/L<0.05;
MS1:=(O/REF(C,1)-1)*100;
M11:=MS1<7;
ZT1:=(CLOSE/REF(CLOSE,1)-1)*100;
A111:=ZT1>9.3 AND CLOSE=HIGH;
XG111:=REF(A111,1);
T31:=COUNT(XG111,100)>0;
条件1:=(XG11 OR XG21 OR XG31 OR XG41) AND (ST1 AND TP11) AND M11 AND T31;
{------------------------------------------}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
A:=250;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
JH:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIFF,DEA),A);
SH:=INTPART(JH/DH)/2;
DIFF50:=SH*DIFF+50,COLORFFFF00;
DEA50:=SH*DEA+50,COLORBLUE;
诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
洗盘:=FILTER(诱空,3) AND 诱空;
XA_1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_2:=REF(CLOSE,1);
XA_3:=SMA(MAX(CLOSE-XA_2,0),2,1)/SMA(ABS(CLOSE-XA_2),2,1)*100;
XA_4:=45;
XA_5:=20;
XA_6:=XA_3<XA_4 AND REF(XA_3,1)>XA_4;
XA_7:=XA_3<XA_5 AND REF(XA_3,1)>XA_5;
XA_8:=REF(COUNT(XA_1,5),1)>=1;
XA_9:=SMA(LOW,4,3);
条件2:=XA_9 AND (REF(XA_6,1) OR REF(XA_7,1)) AND XA_8 AND 洗盘 AND C/REF(C,1)<1.05;

合并选股: 条件1 AND 条件2;

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表