手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做一个量王大于0,同时MACD零轴之上金叉的选股器

[通达信]
设置
1005 1 纪钦尚 Lv.3 发表于 · 2020-11-15 16:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
M1:=5;M2:=30;M3:=120;
VOLT:VOL,VOLSTICK;
XA_1:=VOLT>REF(VOLT,1)*2;
XA_2:=LLV(VOLT,5);
XA_3:=HHV(VOLT,5);
XA_4:=LLV(VOLT,250);
XA_5:=HHV(VOLT,250);
XA_6:=LLV(VOLT,120);
XA_7:=HHV(VOLT,120);
MA1:MA(VOLT,M1),COLORWHITE;
MA2:MA(VOLT,M2),COLORYELLOW;
MA3:MA(VOLT,M3),COLORMAGENTA;
XA_8:=(XA_2+XA_3+XA_4+XA_5+XA_6+XA_7+MA(VOLT,5)+MA(VOLT,250)+MA(VOLT,120))/9;
XA_9:=VOL>XA_8 AND VOL>MA(VOL,120) AND CLOSE>MA(CLOSE,20);
XA_10:=REF(XA_9,1) AND CLOSE=OPEN AND CLOSE>REF(CLOSE,1)*1.098;
XA_11:=REF(XA_10,1) AND CLOSE=OPEN AND CLOSE>REF(CLOSE,1)*1.098;
量王:XA_9 OR XA_10 OR XA_11;
XA_12:=XA_1;
STICKLINE(XA_12,0,VOL,3,0),COLORMAGENTA;
STICKLINE(量王,0,VOL,3,0),COLORRED;

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-11-15 17:07 复制 查看全部楼层
{量王大于0,同时MACD零轴之上金叉的选股器}

M1:=5;M2:=30;M3:=120;
VOLT:=VOL;
XA_1:=VOLT>REF(VOLT,1)*2;
XA_2:=LLV(VOLT,5);
XA_3:=HHV(VOLT,5);
XA_4:=LLV(VOLT,250);
XA_5:=HHV(VOLT,250);
XA_6:=LLV(VOLT,120);
XA_7:=HHV(VOLT,120);
MA1:=MA(VOLT,M1);
MA2:=MA(VOLT,M2);
MA3:=MA(VOLT,M3);
XA_8:=(XA_2+XA_3+XA_4+XA_5+XA_6+XA_7+MA(VOLT,5)+MA(VOLT,250)+MA(VOLT,120))/9;
XA_9:=VOL>XA_8 AND VOL>MA(VOL,120) AND CLOSE>MA(CLOSE,20);
XA_10:=REF(XA_9,1) AND CLOSE=OPEN AND CLOSE>REF(CLOSE,1)*1.098;
XA_11:=REF(XA_10,1) AND CLOSE=OPEN AND CLOSE>REF(CLOSE,1)*1.098;
量王:=XA_9 OR XA_10 OR XA_11;
XA_12:=XA_1;
XG: 量王>0 && CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA>0;

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表