手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并成一个选股预警

[通达信]
设置
1039 1 狼要吃肉 Lv.3 发表于 · 2020-11-15 17:00 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1 AND T3;

选股二
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
A:=250;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);

JH:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIFF,DEA),A);
SH:=INTPART(JH/DH)/2;
DIFF50:=SH*DIFF+50,COLORFFFF00;
DEA50:=SH*DEA+50,COLORBLUE;

诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);

洗盘:FILTER(诱空,3) AND 诱空;


选股三
XA_1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_2:=REF(CLOSE,1);
XA_3:=SMA(MAX(CLOSE-XA_2,0),2,1)/SMA(ABS(CLOSE-XA_2),2,1)*100;
XA_4:=45;
XA_5:=20;
XA_6:=XA_3<XA_4 AND REF(XA_3,1)>XA_4;
XA_7:=XA_3<XA_5 AND REF(XA_3,1)>XA_5;
XA_8:=REF(COUNT(XA_1,5),1)>=1;
XA_9:=SMA(LOW,4,3);
XG:XA_9 AND (REF(XA_6,1) OR REF(XA_7,1)) AND XA_8,COLORRED;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-15 17:30 复制 查看全部楼层
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
AA:=(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1 AND T3;


RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
AX:=250;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);

JH:=HHV(MAX(K,MAX(D,J)),AX);
DH:=HHV(MAX(DIFF,DEA),AX);
SH:=INTPART(JH/DH)/2;
DIFF50:=SH*DIFF+50,COLORFFFF00;
DEA50:=SH*DEA+50,COLORBLUE;

诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);

洗盘:=FILTER(诱空,3) AND 诱空;



XA_1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_2:=REF(CLOSE,1);
XA_3:=SMA(MAX(CLOSE-XA_2,0),2,1)/SMA(ABS(CLOSE-XA_2),2,1)*100;
XA_4:=45;
XA_5:=20;
XA_6:=XA_3<XA_4 AND REF(XA_3,1)>XA_4;
XA_7:=XA_3<XA_5 AND REF(XA_3,1)>XA_5;
XA_8:=REF(COUNT(XA_1,5),1)>=1;
XA_9:=SMA(LOW,4,3);
XG:=XA_9 AND (REF(XA_6,1) OR REF(XA_7,1)) AND XA_8,COLORRED;

HBXG:AA AND 洗盘 AND XG;

举报

点亮(4) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表