手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并成一个选股

[通达信]
设置
1077 1 狼要吃肉 Lv.3 发表于 · 2020-11-15 18:59 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
A:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-A)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1 AND T3;


选股二
VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力进出:=IF((MMS>REF(MMS,1) AND MMB>REF(MMB,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1)),65,0);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);

精准买卖:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1))
AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND MMB>MMC AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
短中精:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
主力买卖:=IF(短中精,60,0);
主力轨迹:=IF(ABV>M2 AND MMS>MML AND CROSS(MMB,MMC) AND MMB>REF(MMB,1) AND MMC>REF(MMC,1),55,0);

拉升在即:=IF(S<X AND Y<X AND MMS>MML AND ABV>M1 AND CROSS(S,Y),50,0);

底部构成:=IF(V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1)
AND ABV>M2 AND MMB>MMC,45,0);

ROC:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;

CTP1:=CROSS(MACD.DIF,MACD.DEA) OR (MACD.MACD>0 AND MACD.MACD<0.5);


CTP11:=EXIST(主力买卖,5);
CTP13:=EXIST(主力进出,5);


YGQF:=CTP11 OR CTP13;


冲天炮:IF(CROSS(ROC,16) AND 100*VOL/CAPITAL>3.5,40,0) AND YGQF;



选股三
妖股线:=EMA((CLOSE-MA((1.2*CLOSE+HIGH+LOW)/3,20))/MA((1.2*CLOSE+HIGH+LOW)/3,20)*100,3);
XG:CROSS(妖股线,5);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-15 20:03 复制 查看全部楼层
A1:=REF(C,3)/REF(C,4)>1.093 AND REF(C,3)>REF(O,3);
A2:=REF(C,1)<REF(C,2) AND REF(C,1)>REF(O,3) AND REF(O,1)/REF(O,3)<1.05 AND REF(C,1)<REF(C,3);
A3:=L/REF(O,3)<1.03 AND C>REF(C,3);
XG1:=A1 AND A2 AND A3;
AB1:=C>MA(C,5) AND C>MA(C,10) AND C>MA(C,20) AND MA(C,5)>MA(C,10);
AB2:=REF((H-MAX(O,C))/MAX(O,C)*100>3,1) AND REF((MIN(O,C)-L)/L*100<2,1);
AB3:=O<REF(O,1) AND C>REF(H,1);
XG2:=AB1 AND AB2 AND AB3;
ZA1:=REF(O,1)>REF(H,2) AND REF(C,1)<REF(O,1) AND REF(H,1)=REF(O,1);
ZA2:=REF(V,1)=HHV(V,15) AND REF(V,1)/REF(V,2)>=3 AND REF(C,1)/REF(C,2)>1.02;
ZA3:=C>REF(H,1);
XG3:=ZA1 AND ZA2 AND ZA3;
AC1:=REF(C,1)/REF(C,2)<0.92;
AC2:=C>REF(O,1) AND C/REF(C,1)>1.05;
AC3:=O/REF(C,1)<1.09;
XG4:=AC1 AND AC2 AND AC3;
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
TP1:=DYNAINFO(4)>0;
AA:=EMA(SLOPE(C,21)*20+C,42);
T7:=(L-AA)/L<0.05;
MS:=(O/REF(C,1)-1)*100;
M1A:=MS<7;
ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
A11:=ZT>9.3 AND CLOSE=HIGH;
XG11:=REF(A11,1);
T3:=COUNT(XG11,100)>0;
TJ1:=(XG1 OR XG2 OR XG3 OR XG4) AND (ST AND TP1) AND M1A AND T3;



VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力进出:=IF((MMS>REF(MMS,1) AND MMB>REF(MMB,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1)),65,0);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);

精准买卖:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1))
AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND MMB>MMC AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
短中精:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
主力买卖:=IF(短中精,60,0);
主力轨迹:=IF(ABV>M2 AND MMS>MML AND CROSS(MMB,MMC) AND MMB>REF(MMB,1) AND MMC>REF(MMC,1),55,0);

拉升在即:=IF(S<X AND Y<X AND MMS>MML AND ABV>M1 AND CROSS(S,Y),50,0);

底部构成:=IF(V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1)
AND ABV>M2 AND MMB>MMC,45,0);

ROC:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;

CTP1:=CROSS(MACD.DIF,MACD.DEA) OR (MACD.MACD>0 AND MACD.MACD<0.5);


CTP11:=EXIST(主力买卖,5);
CTP13:=EXIST(主力进出,5);


YGQF:=CTP11 OR CTP13;


冲天炮:=IF(CROSS(ROC,16) AND 100*VOL/CAPITAL>3.5,40,0) AND YGQF;



妖股线:=EMA((CLOSE-MA((1.2*CLOSE+HIGH+LOW)/3,20))/MA((1.2*CLOSE+HIGH+LOW)/3,20)*100,3);
TJ3:=CROSS(妖股线,5);


XG:TJ1 AND 冲天炮 AND TJ3;





举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表