手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个均线和成交量的指标公式(显示在主图)

[通达信]
设置
2397 3 星无名 Lv.1 发表于 · 2020-11-15 20:07 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙编写一个均线和成交量的指标公式,通达信版本;显示在主图;我的要求如下:

1.股价首次站上60均线,设定关注,

2.20均线与60均线金叉,设定进入多头带,用橙色表示;20均线与60均线死叉,设定进入空头带,用绿色表示;

3.股价回调后再次站上20均线的同时,成交量站上20.120均量线,设定为建仓信号。

4.在多头带运行过程中,股价再次站上20均线,且成交量站上20.120均量线,设定为加仓信号。

5.在多头带运行过程中,跌破20均线,设定为减仓信号;

6.股价跌破60均线,设定为减仓信号;

7.20均线与60均线死叉,进入空头带,设定为空仓信号;


图例如下: 多头图.png 空头图.png

谢谢大神解惑!!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-19 06:47 复制 查看全部楼层
星无名 发表于 2020-11-18 22:41
老师可否修复一下,中间很多股价是阴线,成交量突破也发出了加仓信号,可否将这规避一下呢?

整体上还 ...

加仓一句换成下面。
DRAWTEXT(EMA(C,60)<EMA(C,20)&&C>REF(EMA(C,20),1)&&
CROSS(V>MA(V,120)&&V>MA(V,20)&&CROSS(MACD.MACD,0),0.5),L,'加仓');

举报

点亮(0) 扔鸡蛋(0) 回复

星无名
Lv.1
发表于 2020-11-18 22:41 复制 查看全部楼层
注册111 发表于 2020-11-16 08:15
DRAWBAND(EMA(C,20),RGB(200, 0, 0),EMA(C,60),RGB(50, 205, 50));
DRAWKLINE(H,O,L,C);
E20:EMA(C,20),C ...

老师可否修复一下,中间很多股价是阴线,成交量突破也发出了加仓信号,可否将这规避一下呢?

整体上还算觉得加仓太过于频繁了。
可否让老师帮忙添加一个MACD金叉+股价大于20均线+成交量大于20.120均量线作为加仓信号呢?

谢谢老师了。

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-16 08:15 复制 查看全部楼层
DRAWBAND(EMA(C,20),RGB(200, 0, 0),EMA(C,60),RGB(50, 205, 50));
DRAWKLINE(H,O,L,C);
E20:EMA(C,20),COLORWHITE;
E60:EMA(C,60),COLORYELLOW;
DRAWTEXT(CROSS(C>EMA(C,60),0.5)&&EMA(C,60)>EMA(C,20),L,'关注');
DRAWTEXT(CROSS(C>EMA(C,20),0.5)&&EMA(C,60)<EMA(C,20)&&EMA(C,20)<REF(EMA(C,20),1)&&
CROSS(V>MA(V,120)&&V>MA(V,20),0.5),L,'建仓');
DRAWTEXT(EMA(C,60)<EMA(C,20)&&C>REF(EMA(C,20),1)&&
CROSS(V>MA(V,120)&&V>MA(V,20),0.5),L,'加仓');
DRAWTEXT(EMA(C,60)<EMA(C,20)&&(CROSS(C<EMA(C,20),0.5)||CROSS(C<EMA(C,60),0.5)), H,'减仓');
DRAWTEXT(CROSS(EMA(C,20)<EMA(C,60),0.5),EMA(C,60),'空仓');

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表