手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个主图和选股公式

[通达信]
设置
1882 7 天罗菇娘 Lv.2 发表于 · 2020-11-15 20:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
1,macd在0轴上方涨停;2,涨停后在这个涨停k线后面出现两个阴k线(跌停,假阴也算),这两根阴线不管间隔有没有阳k线还是连续阴k线,把第二根阴k线的最高点画一根直线,这根直线就是后来的阻力线。选股就是突破这根阻力。谢谢

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-19 01:34 复制 查看全部楼层
清晨万象 发表于 2020-11-17 12:11
收盘日的前连续三个月

M49:=MA(C,49);
ZT:=C/REF(C,1)>1.09465 AND C=H ;
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
SUM(M49<MIN(REF(L,BH)+CZ*0.5,MIN(REF(L,BH),REF(H,BH))),60)=60;

举报

点亮(0) 扔鸡蛋(0) 回复

清晨万象
Lv.1
发表于 2020-11-17 12:11 复制 查看全部楼层
收盘日的前连续三个月

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-17 10:31 复制 查看全部楼层
清晨万象 发表于 2020-11-17 10:24
北沙老师,我测试了下,筛选出的不尽是49日下方,可能是我没有表达清楚,想选出如下图的股-在收盘日的连 ...

一直在三线下方,时间多长?
查看全部打赏
  • 清晨万象+10理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

清晨万象
Lv.1
发表于 2020-11-17 10:24 复制 查看全部楼层
北沙 发表于 2020-11-16 09:25
现在三线是最后一个涨停后画线,现改为画所有线,这样就能显示所有三线:
M49:=MA(C,49);
ZT:=C/REF(C, ...

北沙老师,我测试了下,筛选出的不尽是49日下方,可能是我没有表达清楚,想选出如下图的股-在收盘日的连续3个月,49日线在其他三线下方,
麻烦老师写个选股公式,谢谢您!

附件

微信图片_20201117101900.png
微信图片_20201117101900.png

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-16 09:25 复制 查看全部楼层
清晨万象 发表于 2020-11-15 21:32
北沙老师能帮写一个选股公式吗,谢谢!
求前三个月49日线一直都在三条线下方

现在三线是最后一个涨停后画线,现改为画所有线,这样就能显示所有三线:
M49:=MA(C,49);
ZT:=C/REF(C,1)>1.09465 AND C=H ;
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
REF(M49<MIN(REF(L,BH)+CZ*0.5,MIN(REF(L,BH),REF(H,BH))),60);

举报

点亮(2) 扔鸡蛋(0) 回复

清晨万象
Lv.1
发表于 2020-11-15 21:32 复制 查看全部楼层
北沙 发表于 2020-11-15 20:40
主图:
涨停:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),C=ZTPRICE(REF(C,1),0.05),
IF(CODELIKE('688') OR  ...

北沙老师能帮写一个选股公式吗,谢谢!
求前三个月49日线一直都在三条线下方



ZT:=C/REF(C,1)>1.09465 AND C=H ;
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
DRAWLINE(ZT,(REF(L,BH)+CZ*0.5),ISLASTBAR,(REF(L,BH)+CZ*0.5),1),COLORRED;
DRAWLINE(ZT,REF(L,BH),ISLASTBAR,REF(L,BH),1),COLOR00FF00;
DRAWLINE(ZT,REF(H,BH),ISLASTBAR,REF(H,BH),1),COLORWHITE;

举报

点亮(2) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-15 20:40 复制 查看全部楼层
主图:
涨停:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),C=ZTPRICE(REF(C,1),0.05),
IF(CODELIKE('688') OR (CODELIKE('300') AND DATE>=1200824),C=ZTPRICE(REF(C,1),0.2),
C=ZTPRICE(REF(C,1),0.1)));
条件:=涨停 AND MACD.MACD>0;
画线:=SUM(C<O,BARSLAST(条件))=2 AND C<O;
DRAWLINE(画线,H,REF(画线,1),REF(H,1),1);
选股:=CROSS(SUM(CROSS(C>REF(H,BARSLAST(画线)),0.5),BARSLAST(画线))=1,0.5);
DRAWICON(选股,REF(H,BARSLAST(画线)),1);
选股:
涨停:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),C=ZTPRICE(REF(C,1),0.05),
IF(CODELIKE('688') OR (CODELIKE('300') AND DATE>=1200824),C=ZTPRICE(REF(C,1),0.2),
C=ZTPRICE(REF(C,1),0.1)));
条件:=涨停 AND MACD.MACD>0;
画线:=SUM(C<O,BARSLAST(条件))=2 AND C<O;
选股:CROSS(SUM(CROSS(C>REF(H,BARSLAST(画线)),0.5),BARSLAST(画线))=1,0.5);

举报

点亮(7) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表