手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

公式源码//免费//来源于网络//提供给有需要的朋友

[飞狐]
设置
4046 4 股市V老叶 Lv.2 发表于 · 2020-11-16 00:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 股市V老叶 于 2020-11-16 00:14 编辑

公式来源于网络,有的自己修改了下,有的没有改。在KT交易师上面完全可以使用。其他软件能不能用不知道。
在此,感谢大师们的辛勤付出。


第一个  .在主图上显示文字。
DRAWTEXTEX(C,1,300,10, '多周期组合排除主力骗线  ' +  '      反转坐标功能判断股票的顶和底  '+'      实时主图切换功能判断股票的强弱 '),ColorMagenta,LineThick20;
DRAWTEXTEX(C,1,500,60,'上涨家数:  '+NUMTOSTR(INDEXADV,0)+'   下跌家数:  '+NUMTOSTR(INDEXDEC,0)),ColorMagenta,LineThick20;

{基本面}
DRAWTEXTEX(C,1,1,30,'板块: '+BLKNAME),COLORYELLOW;
DRAWTEXTEX(C,1,1,60,'总股本: '+NUMTOSTR(FINANCE(1)/10000 ,2 )+'亿'+' 流通A股: '+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'),COLORYELLOW;
DRAWTEXTEX(C,1,1,110,'每股收益: '+ NUMTOSTR(FINANCE(33),2)+'   市盈率:  '+NUMTOSTR(DYNAINFO(39),2)+'   净资产: '+NUMTOSTR(FINANCE(34),2)+'   净资产收益率: '+NUMTOSTR(FINANCE(37),2)),COLORYELLOW;
DRAWTEXTEX(C,1,1,160,'主营业务增长率: '+NUMTOSTR(FINANCE(53),2 )+'%'+' 税后利润增长率: '+NUMTOSTR(FINANCE(54),2 )+'%'+' 净资产增长率: '+NUMTOSTR(FINANCE(55),2 )+'%'),ColorYellow;

{支撑压力1}
DRAWTEXTEX(C,1,1,350,'阻力1:  '+NUMTOSTR(((REF(H,1)+REF(L,1)+REF(O,1)+REF(C,1))/4*2-REF(L,1)),2)+' (昨最高价:'+NUMTOSTR(REF(H,1),2)+')'),COLORYELLOW;
DRAWTEXTEX(C,1,1,400,'阻力2:  '+NUMTOSTR(((REF(H,1)+REF(L,1)+REF(O,1)+REF(C,1))/4+(REF(H,1)-REF(L,1))),2) +' ('+NUMTOSTR(REF(C,1)+(REF(H,1)-REF(L,1)),2)+')'),COLORYELLOW;
DRAWTEXTEX(C,1,1,450,'支撑1:  '+NUMTOSTR(((REF(H,1)+REF(L,1)+REF(O,1)+REF(C,1))/4*2-REF(H,1)),2)+' (昨最低价:'+NUMTOSTR(REF(L,1),2)+')'),COLORYELLOW;
DRAWTEXTEX(C,1,1,500,'支撑2:  '+NUMTOSTR(((REF(H,1)+REF(L,1)+REF(O,1)+REF(C,1))/4-(REF(H,1)-REF(L,1))),2) +' ('+NUMTOSTR(REF(C,1)-(REF(H,1)-REF(L,1)),2)+')'),COLORYELLOW;
{支撑压力2}  {K线形态  支撑压力}
JRH:=HHV(C,2);
JRL:=LLV(C,2);
R1:=(C>REF(C,1) AND C>REF(C,2));
R2:=(REF(R1,1) AND C<REF(C,1) AND C>=REF(C,2));
R3:=(REF(R2,1) AND C>=REF(C,1) AND C<=REF(C,2));
R4:=(REF(R3,1) AND C<=REF(C,1) AND C>=REF(C,2));
R5:=(REF(R4,1) AND C>=REF(C,1) AND C<=REF(C,2));
R6:=(REF(R5,1) AND C<=REF(C,1) AND C>=REF(C,2));
R7:=(REF(R6,1) AND C>=REF(C,1) AND C<=REF(C,2));
R8:=(REF(R7,1) AND C<=REF(C,1) AND C>=REF(C,2));
R9:=(REF(R8,1) AND C>=REF(C,1) AND C<=REF(C,2));
RA:=(REF(R9,1) AND C<=REF(C,1) AND C>=REF(C,2));
RB:=(REF(RA,1) AND C>=REF(C,1) AND C<=REF(C,2));
RC:=(REF(RB,1) AND C<=REF(C,1) AND C>=REF(C,2));
RD:=(C<REF(C,1) AND C<REF(C,2));
RE:=(REF(RD,1) AND C>=REF(C,1) AND C<=REF(C,2));
RF:=(REF(RE,1) AND C<=REF(C,1) AND C>=REF(C,2));
R10:=(REF(RF,1) AND C>=REF(C,1) AND C<=REF(C,2));
R11:=(REF(R10,1) AND C<=REF(C,1) AND C>=REF(C,2));
R12:=(REF(R11,1) AND C>=REF(C,1) AND C<=REF(C,2));
R13:=(REF(R12,1) AND C<=REF(C,1) AND C>=REF(C,2));
R14:=(REF(R13,1) AND C>=REF(C,1) AND C<=REF(C,2));
R15:=(REF(R14,1) AND C<=REF(C,1) AND C>=REF(C,2));
R16:=(REF(R15,1) AND C>=REF(C,1) AND C<=REF(C,2));
R17:=(REF(R16,1) AND C<=REF(C,1) AND C>=REF(C,2));
R18:=(REF(R17,1) AND C>=REF(C,1) AND C<=REF(C,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
春买:=R19,COLOR00DD00;
秋离场:=R1A,COLOR2288EE;
红持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,COLOR0000FF;
阴观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,COLOR999999;
离场:=IF(红持股,JRL,0);
明离场价:=离场,COLORFF99FF,LINETHICK0;
今离场价:=REF(离场,1),COLOR0000FF,LINETHICK0;
进:=IF(阴观望,JRH,0);
明进场价:=进,COLOR33AACC,LINETHICK0;
今进场价:=REF(明进场价,1),COLOR00FF00,LINETHICK0;
DRAWTEXTEX(BARSTATUS=2 ,1,500,100,'-----------------------------------'),Coloryellow,ALIGN4,ALIGN2;
DRAWTEXTEX(C,1,600,130,'  今进场价=:'+NUMTOSTR(今进场价 ,2 )+' '),ColorFF00FF,ALIGN4,ALIGN2,LineThick25;
DRAWTEXTEX(进,1,600,200,'  明进场价=:'+NUMTOSTR(明进场价 ,2 )+' '),,Colorff00FF,ALIGN4,ALIGN2,LineThick25;
DRAWTEXTEX(离场,1,450,200,'明离场价=:'+NUMTOSTR(明离场价 ,2 )+' '),ALIGN4,Colorgreen,ALIGN2,LineThick25;
DRAWTEXTEX(C,1,450,130,'  今离场价=:'+NUMTOSTR(今离场价 ,2 )+' '),Color00FF00,ALIGN4,ALIGN2,LineThick25;
DRAWTEXTEX(C ,1,500,260,'----------------------------------'),Coloryellow,ALIGN4,ALIGN2;




第二个  
{均线变色和色带}
MA60:EMA(C,60),ColorYellow,POINTDOT ,LINETHICK5;
PARTLINE(MA60<REF(MA60,1),MA60),ColorBlue,POINTDOT ,LINETHICK5;
MA120:EMA(C,120),ColorMagenta,LINETHICK1;
PARTLINE(MA120<REF(MA120,1),MA120),ColorBlue,LINETHICK1;
MA240:EMA(C,240),ColorRed,POINTDOT,LINETHICK3;
PARTLINE(MA240<REF(MA240,1),MA240),ColorGreen,POINTDOT,LINETHICK3;
MA8:=EMA(C,8),ColorMagenta,LINETHICK1;
PARTLINE(MA8<REF(MA8,1),MA8),ColorGreen,LINETHICK1;
MA5:=EMA(C,5),ColorMagenta,LINETHICK1;
PARTLINE(MA5<REF(MA5,1),MA5),ColorGreen,LINETHICK1;
MA3:=EMA(C,3),ColorMagenta,LINETHICK1;
PARTLINE(MA3<REF(MA3,1),MA3),ColorGreen,LINETHICK1;
DRAWBAND(EMA(C,3),COLORRGB(255,97,0),EMA(C,7),COLORRGB(0,255,0));{填颜色20线与30线交叉}

附件

在主图上显示文字

在主图上显示文字

均线变色和色带

均线变色和色带

举报

扔鸡蛋(0) 回复

股市V老叶
Lv.2
发表于 2020-11-16 12:51 复制 查看全部楼层
正邪委员 发表于 2020-11-16 01:10
可惜在通达信上都不能用

可以自己动手改下。

举报

扔鸡蛋(0) 回复

雄关漫步
Lv.4
发表于 2020-11-16 09:07 复制 查看全部楼层
谢谢分享,为你点赞。

举报

扔鸡蛋(0) 回复

雪客fvptk
Lv.4
发表于 2020-11-16 08:57 复制 查看全部楼层
源码分享为你点赞了。

举报

扔鸡蛋(0) 回复

正邪委员
Lv.2
发表于 2020-11-16 01:10 复制 查看全部楼层
可惜在通达信上都不能用

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表