请老师帮忙改个选股指标

[通达信]
设置
1662 5 枫之舞0001 Lv.3 发表于 · 2020-11-16 08:37 显示全部楼层 正序浏览 |
跳转到指定楼层
{波段介入点}
J1:=REF(CLOSE,2);
J2:=SMA(MAX(CLOSE-J1,0),7,1)/SMA(ABS(CLOSE-J1),7,1)*100;
波介入:IF(J2<19,19,0),LINETHICK5,COLORFF00FF;
{极品逃亡}
VAR1:=REF(CLOSE,2);
会员专用:= SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORFFAA66;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
逃亡: IF(会员专用< REF(会员专用,1) AND 会员专用>79,会员专用,0),COLORFFAA66,STICK;
DRAWTEXT (逃亡,65,'逃亡针'),COLORFFAA66;

主力:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2;
见底:= 10, LINETHICK2,COLORRED ;
准备:= IF(主力<=10,50,10), LINETHICK4,COLOR369258;
买入时机: IF(CROSS(主力,见底),100,10), LINETHICK2,COLORYELLOW;

{红柱抄底}
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
红柱抄底:STICKLINE(CROSS(BIAS,乖离)  AND 乖离<-9.5,60,0,2,0),COLORRED;
DRAWTEXT (红柱抄底,65,'曙光'),COLORRED;


V机10:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
V机11:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
V机12:=V机10<REF(V机11,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
庄进场:= V机12 AND COUNT(V机12,30)=1;
DRAWTEXT(V机12 AND COUNT(V机12,30)=1,40,'有庄进场!'),COLORYELLOW;
黄柱介入:STICKLINE(庄进场,40,0,2,0),COLORYELLOW;

A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2));
庄家轨迹:=(EMA(A7,A2)),COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8));
A17:=(EMA(A16,5));
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
庄启动:DRAWICON((A28 OR A31),庄家轨迹,26);
DRAWTEXT((A28 OR A31),庄家轨迹,'←庄启动'),COLORMAGENTA;
STICKLINE( 庄启动,40,0,2,0),COLORMAGENTA;

庄筹:EMA(WINNER(C)*70,5), COLORRED ,LINETHICK1;
散筹:EMA((WINNER(C*1.1)-WINNER(C*0.91))*80,3), COLORGREEN ,LINETHICK1;
KS13:=(C-SMA(C,13,1))/SMA(C,13,1)*(-100);
AAA:=REF(KS13,1)>13 AND REF(KS13,1)/KS13>1.23 AND C/REF(C,1)>1.03;
AA1:=REF(庄筹,30)> 40 OR REF(庄筹,20)> 40;
BB1:=CROSS(28,庄筹) AND 散筹> 40 AND AA1=1;
CC:=REF(散筹,1)> 散筹 AND REF(庄筹,1)< 庄筹 AND 庄筹> 30 AND 散筹> 30 AND REF(庄筹,1)-REF(庄筹,2)> 3.535;
DD:=COUNT(REF(散筹,1)> REF(庄筹,1),5);
鸡雀: CROSS(庄筹,散筹) AND CC=1 AND DD>=5,COLORMAGENTA;
鸡雀升天:IF(鸡雀,30,0) ,COLOR00FFFF,LINETHICK4;
筹动力:IF(庄筹>REF(庄筹,1),庄筹,DRAWNULL),COLORRED,LINETHICK7;
活鱼:IF(AAA AND REF(C,1)<COST(1),30,0),COLORWHITE ,LINETHICK2;
STICKLINE(庄筹>散筹,庄筹-1,散筹+1,1,0), COLOR00FFFF;
捞活鱼: CROSS(5,庄筹) AND 散筹< 20;
DRAWTEXT_FIX(1,0.08,0.0001,0,''),COLORMAGENTA;
DRAWTEXT_FIX(1,0.08,0.1001,0,''),COLORYELLOW;
DRAWTEXT_FIX(1,0.08,0.2001,0,''),COLORRED;
DRAWTEXT_FIX(1,0.08,0.3001,0,''),COLORWHITE;




帮忙把标有 庄启动 的改选股  谢谢


举报

使用道具 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 09:01 复制 查看全部楼层


A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2));
庄家轨迹:=(EMA(A7,A2)),COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8));
A17:=(EMA(A16,5));
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
A28 OR A31;

举报

使用道具 点亮(1) 扔鸡蛋(0) 回复

枫之舞0001
Lv.3
发表于 2020-11-16 10:23 复制 查看全部楼层
还有老师帮忙吗

举报

使用道具 扔鸡蛋(0) 回复

枫之舞0001
Lv.3
发表于 2020-11-16 10:01 复制 查看全部楼层
南山翁2007 发表于 2020-11-16 09:49
你要的庄启动选股:
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;

帮忙在改改

举报

使用道具 扔鸡蛋(0) 回复

枫之舞0001
Lv.3
发表于 2020-11-16 10:00 复制 查看全部楼层
要不显示图标 要要选股 麻烦再改改

举报

使用道具 扔鸡蛋(0) 回复

南山翁2007
Lv.4
发表于 2020-11-16 09:49 复制 查看全部楼层
你要的庄启动选股:
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2));
庄家轨迹:=(EMA(A7,A2)),COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8));
A17:=(EMA(A16,5));
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
庄启动:DRAWICON((A28 OR A31),庄家轨迹,26);

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表