手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个通达信公式

[通达信]
设置
993 2 自然醒2008 Lv.4 发表于 · 2020-11-16 13:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{自动通道线,有长期和短期}
TY:=(C+L+H)/3;
DD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LL:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
UU:=BACKSET(BARSTATUS=2 ,BARSLAST(LL)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LL),1)+2);
XX:=WW>REF(WW,1);
DRAWLINE(XX,L,VV,L,1),ColorFFA500,LINEDASH,LINETHICK1;
UU2:=BACKSET(BARSTATUS=2 ,BARSLAST(DD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(DD),1)+2);
XX2:=WW2>REF(WW2,1);
DRAWLINE(XX2,H,VV2,H,1),ColorFFA500,LINEDASH,LINETHICK1;

D:=FILTER(BACKSET(FILTER(REF(TY,21)=HHV(TY,2*21+1),21),21+1),21);
L5:=FILTER(BACKSET(FILTER(REF(TY,21)=LLV(TY,2*21+1),21),21+1),21);
U:=BACKSET(BARSTATUS=2 ,BARSLAST(L5)+1);
V5:=U>REF(U,1);
W:=BACKSET(V5,REF(BARSLAST(L5),1)+2);
X:=W>REF(W,1);
DRAWLINE(X,L,V5,L,1),ColorMagenta,LINEDASH,LINETHICK1;
U2:=BACKSET(BARSTATUS=2 ,BARSLAST(D)+1);
V2:=U2>REF(U2,1);
W2:=BACKSET(V2,REF(BARSLAST(D),1)+2);
X2:=W2>REF(W2,1);
DRAWLINE(X2,H,V2,H,1),ColorMagenta,LINEDASH,LINETHICK1;

举报

扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-16 20:04 复制 查看全部楼层
感谢天地一号老师!

举报

扔鸡蛋(0) 回复

天地一号1
Lv.3
发表于 2020-11-16 14:33 复制 查看全部楼层
{自动通道线,有长期和短期}
TY:=(C+L+H)/3;
DD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LL:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
UU:=BACKSET(BARSTATUS=2 ,BARSLAST(LL)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LL),1)+2);
XX:=WW>REF(WW,1);
DRAWLINE(XX,L,VV,L,1),COLORFFA500,LINETHICK1;
UU2:=BACKSET(BARSTATUS=2 ,BARSLAST(DD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(DD),1)+2);
XX2:=WW2>REF(WW2,1);
DRAWLINE(XX2,H,VV2,H,1),COLORFFA500,LINETHICK1;

D:=FILTER(BACKSET(FILTER(REF(TY,21)=HHV(TY,2*21+1),21),21+1),21);
L5:=FILTER(BACKSET(FILTER(REF(TY,21)=LLV(TY,2*21+1),21),21+1),21);
U:=BACKSET(BARSTATUS=2 ,BARSLAST(L5)+1);
V5:=U>REF(U,1);
W:=BACKSET(V5,REF(BARSLAST(L5),1)+2);
X:=W>REF(W,1);
DRAWLINE(X,L,V5,L,1),COLORMAGENTA,LINETHICK1;
U2:=BACKSET(BARSTATUS=2 ,BARSLAST(D)+1);
V2:=U2>REF(U2,1);
W2:=BACKSET(V2,REF(BARSLAST(D),1)+2);
X2:=W2>REF(W2,1);
DRAWLINE(X2,H,V2,H,1),COLORMAGENTA,LINETHICK1;
查看全部打赏
  • 自然醒2008+20理想币 : 理想精神:互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表