手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个通达信指标

[通达信]
设置
1034 4 自然醒2008 Lv.4 发表于 · 2020-11-16 13:16 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
短趋5:MA(CLOSE,5),COLORYELLOW,LINETHICK1;
涨:IF(短趋5>REF(短趋5,1),短趋5,DRAWNULL),COLORFFAAFF,LINETHICK2;
平:=IF(短趋5=REF(短趋5,1),短趋5,DRAWNULL),COLORYELLOW,LINETHICK2;
跌:IF(短趋5<REF(短趋5,1),短趋5,DRAWNULL),COLORGREEN,LINETHICK1;
强弱34:MA(CLOSE,34),LINETHICK1;
涨1:IF(强弱34>REF(强弱34,1),强弱34,DRAWNULL),COLORMAGENTA,LINETHICK2;
平1:=IF(强弱34=REF(强弱34,1),强弱34,DRAWNULL),COLORYELLOW,LINETHICK2;
跌1:IF(强弱34<REF(强弱34,1),强弱34,DRAWNULL),COLORLIGREEN,LINETHICK1;
趋144:MA(CLOSE,144),COLORYELLOW,LINETHICK2;
涨2:IF(趋144>REF(趋144,1),趋144,DRAWNULL),COLOR3366FF,LINETHICK2;
平2:=IF(趋144=REF(趋144,1),趋144,DRAWNULL),COLORYELLOW,LINETHICK2;
跌2:IF(趋144<REF(趋144,1),趋144,DRAWNULL),COLORLIGRAY,LINETHICK2;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
强弱线34:EMA(X,34)NODRAW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
BDGD:=C=HHV(C,强弱线34);
GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;
高点:REF(C,GDSJ),COLORGREEN,POINTDOT;
突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT;
DRAWTEXT(突破,LOW,'▲'),COLORYELLOW;
BDDD:=C=LLV(C,强弱线34);
DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;
低点:REF(C,DDSJ),COLORLIRED,POINTDOT;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,13) - CLOSE)) / (HHV(HIGH,13) - LLV(LOW,13)));
NEWVOL:=(RSI5 - WR10);
回踩买入:=(AV + NEWVOL);
HJX:=MAX(MA(C,5),MAX(MAX(MA(C,13),MA(C,24)),MAX(MA(C,34),MA(C,144))));
DRAWTEXT(CROSS(C,HJX) AND CROSS(C,强弱34) AND CROSS(C,强弱线34),L,'干')COLORMAGENTA;
{涨跌停K线}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,1.6,0),COLORYELLOW;{黄色}
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,1.6,0),COLOR80FF00;{绿色}
DRAWTEXT_FIX(1,0.00,0.10,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.10,0,CONST(WINNER(C )*100)),COLOR0080FF;
DRAWTEXT_FIX(1,0.10,0.10,0,'动态PE:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.10,0,CONST(DYNAINFO(39))),COLOR0080FF;
DRAWTEXT_FIX(1,0.18,0.10,0,'市值:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.21,0.10,0,FINANCE(40)/100000000),COLOR0080FF;
DRAWTEXT_FIX (1,0.25,0.10,0,'公积金(股):'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.31,0.10,0,FINANCE(18)),COLOR0080FF;
DRAWTEXT_FIX (1,0.34,0.10,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.37,0.10,0,FINANCE(33)),COLOR0080FF;
所属板块:=STRCAT('【板块】',STRCAT(STRCAT(STRCAT(STRCAT('     行业>',HYBLOCK),STRCAT('     地域>',DYBLOCK)),STRCAT('     概念>',GNBLOCK)),STRCAT('     风格>',FGBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0,0.98,0 ,所属板块),COLORGREEN;
总股本:=STRCAT(STRCAT('     总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT('     流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT('     全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT('     流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日:=STRCAT('     上市日: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
营业收入:=STRCAT(STRCAT('     营业收入:',CON2STR(FINANCE(20)/100000000,2)),'亿');
同比增长:=STRCAT(STRCAT('     同比增长:',CON2STR(FINANCE(44),2)),'%');
利润增长:=STRCAT(STRCAT('     利润增长:',CON2STR(FINANCE(43),2)),'%');
市盈率:=STRCAT('     市盈率:',CON2STR(C/FINANCE(33),2));
市净率:=STRCAT('     市净率:',CON2STR(C/FINANCE(34),2));
净利润:=STRCAT(STRCAT('     净利润:',CON2STR(FINANCE(30)/10000,2)),'万');
当前业绩:=STRCAT('【业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(营业收入,同比增长),净利润),利润增长),市盈率),市净率));
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,当前业绩),COLORYELLOW;

买卖盘比▇: 1/DYNAINFO(51),COLORGRAY,NODRAW;
IF(买卖盘比▇ >0.9,买卖盘比▇,DRAWNULL),COLORWHITE,NODRAW;
IF(买卖盘比▇ >1.3,买卖盘比▇,DRAWNULL),COLORRED,NODRAW;
DRAWTEXT_FIX(1,0.5,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.51,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.52,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.53,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.54,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.55,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.56,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.57,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.58,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >0.5,0.5,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.6,0.51,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.7,0.52,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.75,0.53,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.8,0.54,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.85,0.55,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.9,0.56,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >0.95,0.57,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >1,0.58,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(1,0.56,0,0,' 9'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.6,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.61,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.62,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.63,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.64,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.65,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.66,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.67,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.68,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >1.05,0.6,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.1,0.61,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.15,0.62,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.2,0.63,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.25,0.64,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.3,0.65,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.4,0.66,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.5,0.67,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.6,0.68,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(1,0.65,0,0,' 7'),COLORLIBLUE;
{成交量卖点}
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE(CROSS(84,VAR7),CLOSE,OPEN,2,0),COLORGREEN;
卖出:=CROSS(84,VAR7);
DRAWTEXT(卖出,H*1.001,''),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIF:=EMA(CLOSE,5)-EMA(CLOSE,13);
DEA:=EMA(DIF,8);
MACD:=(DIF-DEA)*2;
抄底:=REF(J,1)<10 AND REF(MACD,1)<REF(MACD,2) AND MACD>REF(MACD,1) AND MACD<0 AND
CCI>REF(CCI,1) AND (REF(CCI,2)<-100 OR REF(CCI,3)<-100);
{DRAWTEXT(抄底,L*0.899,'↖波段买'),COLORYELLOW;}
STICKLINE(抄底,CLOSE,OPEN,2,0),COLORFFAAFF;
X_12:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_13:=(20*X_12+19*REF(X_12,1)+18*REF(X_12,2)+17*REF(X_12,3)+16*REF(X_12,4)+15*REF(X_12,5)+14*REF(X_12,6)+13*REF(X_12,7)+12*REF(X_12,8)+11*REF(X_12,9)+10*REF(X_12,10)+9*REF(X_12,11)+8*REF(X_12,12)+7*REF(X_12,13)+6*REF(X_12,14)+5*REF(X_12,15)+4*REF(X_12,16)+3*REF(X_12,17)+2*REF(X_12,18)+REF(X_12,20))/210;
回调认同:EMA(X_13,13),COLORCYAN,LINETHICK2;
X_14:=MACD.MACD#WEEK(5,13,8);
X_15:=(EMA(回调认同,2)-REF(EMA(回调认同,2),2))/REF(EMA(回调认同,2),2)*100;
IF(X_15>=0,回调认同,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(MACD.DIF>=0 AND X_14>=0,回调认同,DRAWNULL),COLORRED,LINETHICK2;
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD+0.1,0),COLORWHITE,LINETHICK2;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉) AND C/REF(C,1)>1.08
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0),COLORF00FF0,LINETHICK3;  
DRAWTEXT(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.058,'----抓'),COLORYELLOW;
DRAWTEXT(金叉共振 AND C/REF(C,1)>1.05,REF(C,1)*1.030,'-干'),COLORFFAAFF;
XA:=REF(C,1)/REF(C,3)>=1.2 AND O/REF(C,1)<=1.01 AND L<REF(C,1) AND C/REF(C,1)>1.05;
启动1:=XA AND COUNT(XA,4)=1;
STICKLINE(启动1,O,C,2.5,0),COLORFFAAFF;
DRAWTEXT(启动1,L*0.92,'-爆'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-16 22:27 复制 查看全部楼层
许老师我的版本是

附件

8989.JPG

举报

扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-16 22:24 复制 查看全部楼层
许老师怎么出了点线了?

附件

89898.JPG

举报

扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-16 19:58 复制 查看全部楼层
感谢许老师

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 14:22 复制 查看全部楼层
短趋5:MA(CLOSE,5),COLORYELLOW,LINETHICK1;
涨:IF(短趋5>REF(短趋5,1),短趋5,DRAWNULL),COLORFFAAFF,LINETHICK2;
平:=IF(短趋5=REF(短趋5,1),短趋5,DRAWNULL),COLORYELLOW,LINETHICK2;
跌:IF(短趋5<REF(短趋5,1),短趋5,DRAWNULL),COLORGREEN,LINETHICK1;
强弱34:MA(CLOSE,34),LINETHICK1;
涨1:IF(强弱34>REF(强弱34,1),强弱34,DRAWNULL),COLORMAGENTA,LINETHICK2;
平1:=IF(强弱34=REF(强弱34,1),强弱34,DRAWNULL),COLORYELLOW,LINETHICK2;
跌1:IF(强弱34<REF(强弱34,1),强弱34,DRAWNULL),COLORLIGREEN,LINETHICK1;
趋144:MA(CLOSE,144),COLORYELLOW,LINETHICK2;
涨2:IF(趋144>REF(趋144,1),趋144,DRAWNULL),COLOR3366FF,LINETHICK2;
平2:=IF(趋144=REF(趋144,1),趋144,DRAWNULL),COLORYELLOW,LINETHICK2;
跌2:IF(趋144<REF(趋144,1),趋144,DRAWNULL),COLORLIGRAY,LINETHICK2;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
强弱线34:EMA(X,34)NODRAW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
BDGD:=C=HHV(C,强弱线34);
GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;
高点:REF(C,GDSJ),COLORGREEN,POINTDOT;
突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT;
DRAWTEXT(突破,LOW,'▲'),COLORYELLOW;
BDDD:=C=LLV(C,强弱线34);
DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;
低点:REF(C,DDSJ),COLORLIRED,POINTDOT;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,13) - CLOSE)) / (HHV(HIGH,13) - LLV(LOW,13)));
NEWVOL:=(RSI5 - WR10);
回踩买入:=(AV + NEWVOL);
HJX:=MAX(MA(C,5),MAX(MAX(MA(C,13),MA(C,24)),MAX(MA(C,34),MA(C,144))));
DRAWTEXT(CROSS(C,HJX) AND CROSS(C,强弱34) AND CROSS(C,强弱线34),L,'干')COLORMAGENTA;
{涨跌停K线}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,1.6,0),COLORYELLOW;{黄色}
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,1.6,0),COLOR80FF00;{绿色}
DRAWTEXT_FIX(1,0.00,0.10,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.10,0,CONST(WINNER(C )*100)),COLOR0080FF;
DRAWTEXT_FIX(1,0.10,0.10,0,'动态PE:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.10,0,CONST(DYNAINFO(39))),COLOR0080FF;
DRAWTEXT_FIX(1,0.18,0.10,0,'市值:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.21,0.10,0,FINANCE(40)/100000000),COLOR0080FF;
DRAWTEXT_FIX (1,0.25,0.10,0,'公积金(股):'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.31,0.10,0,FINANCE(18)),COLOR0080FF;
DRAWTEXT_FIX (1,0.34,0.10,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.37,0.10,0,FINANCE(33)),COLOR0080FF;
所属板块:=STRCAT('【板块】',STRCAT(STRCAT(STRCAT(STRCAT('     行业>',HYBLOCK),STRCAT('     地域>',DYBLOCK)),STRCAT('     概念>',GNBLOCK)),STRCAT('     风格>',FGBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0,0.98,0 ,所属板块),COLORGREEN;
总股本:=STRCAT(STRCAT('     总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT('     流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT('     全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT('     流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日:=STRCAT('     上市日: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
营业收入:=STRCAT(STRCAT('     营业收入:',CON2STR(FINANCE(20)/100000000,2)),'亿');
同比增长:=STRCAT(STRCAT('     同比增长:',CON2STR(FINANCE(44),2)),'%');
利润增长:=STRCAT(STRCAT('     利润增长:',CON2STR(FINANCE(43),2)),'%');
市盈率:=STRCAT('     市盈率:',CON2STR(C/FINANCE(33),2));
市净率:=STRCAT('     市净率:',CON2STR(C/FINANCE(34),2));
净利润:=STRCAT(STRCAT('     净利润:',CON2STR(FINANCE(30)/10000,2)),'万');
当前业绩:=STRCAT('【业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(营业收入,同比增长),净利润),利润增长),市盈率),市净率));
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,当前业绩),COLORYELLOW;

买卖盘比▇: 1/DYNAINFO(51),COLORGRAY,NODRAW;
IF(买卖盘比▇ >0.9,买卖盘比▇,DRAWNULL),COLORWHITE,NODRAW;
IF(买卖盘比▇ >1.3,买卖盘比▇,DRAWNULL),COLORRED,NODRAW;
DRAWTEXT_FIX(1,0.5,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.51,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.52,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.53,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.54,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.55,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.56,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.57,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.58,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >0.5,0.5,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.6,0.51,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.7,0.52,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.75,0.53,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.8,0.54,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.85,0.55,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.9,0.56,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >0.95,0.57,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >1,0.58,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(1,0.56,0,0,' 9'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.6,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.61,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.62,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.63,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.64,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.65,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.66,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.67,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.68,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >1.05,0.6,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.1,0.61,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.15,0.62,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.2,0.63,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.25,0.64,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.3,0.65,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.4,0.66,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.5,0.67,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.6,0.68,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(1,0.65,0,0,' 7'),COLORLIBLUE;
{成交量卖点}
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE(CROSS(84,VAR7),CLOSE,OPEN,2,0),COLORGREEN;
卖出:=CROSS(84,VAR7);
DRAWTEXT(卖出,H*1.001,''),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIF:=EMA(CLOSE,5)-EMA(CLOSE,13);
DEA:=EMA(DIF,8);
MACD:=(DIF-DEA)*2;
抄底:=REF(J,1)<10 AND REF(MACD,1)<REF(MACD,2) AND MACD>REF(MACD,1) AND MACD<0 AND
CCI>REF(CCI,1) AND (REF(CCI,2)<-100 OR REF(CCI,3)<-100);
{DRAWTEXT(抄底,L*0.899,'↖波段买'),COLORYELLOW;}
STICKLINE(抄底,CLOSE,OPEN,2,0),COLORFFAAFF;
X_12:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_13:=(20*X_12+19*REF(X_12,1)+18*REF(X_12,2)+17*REF(X_12,3)+16*REF(X_12,4)+15*REF(X_12,5)+14*REF(X_12,6)+13*REF(X_12,7)+12*REF(X_12,8)+11*REF(X_12,9)+10*REF(X_12,10)+9*REF(X_12,11)+8*REF(X_12,12)+7*REF(X_12,13)+6*REF(X_12,14)+5*REF(X_12,15)+4*REF(X_12,16)+3*REF(X_12,17)+2*REF(X_12,18)+REF(X_12,20))/210;
回调认同:EMA(X_13,13),COLORCYAN,LINETHICK2;
X_14:=MACD.MACD#WEEK(5,13,8);
X_15:=(EMA(回调认同,2)-REF(EMA(回调认同,2),2))/REF(EMA(回调认同,2),2)*100;
IF(X_15>=0,回调认同,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(MACD.DIF>=0 AND X_14>=0,回调认同,DRAWNULL),COLORRED,LINETHICK2;
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD+0.1,0),COLORWHITE,LINETHICK2;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉) AND C/REF(C,1)>1.08
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0),COLORF00FF0,LINETHICK3;  
DRAWTEXT(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.058,'----抓'),COLORYELLOW;
DRAWTEXT(金叉共振 AND C/REF(C,1)>1.05,REF(C,1)*1.030,'-干'),COLORFFAAFF;
XA:=REF(C,1)/REF(C,3)>=1.2 AND O/REF(C,1)<=1.01 AND L<REF(C,1) AND C/REF(C,1)>1.05;
启动1:=XA AND COUNT(XA,4)=1;
STICKLINE(启动1,O,C,2.5,0),COLORFFAAFF;
DRAWTEXT(启动1,L*0.92,'-爆'),COLORYELLOW;

附件

tdxjietu11.JPG
查看全部打赏
  • 自然醒2008+20理想币 : 理想精神:互助,友善,传递正能量!
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表