手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将此改为出'上升趋势'的选股公式

[通达信]
设置
1449 4 钱误股人 Lv.3 发表于 · 2020-11-16 14:15 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
N:=8;
N1:=17;
N2:=34;
A1A:=EMA(CLOSE, 9);
A1B:=((A1A-EMA(CLOSE,5))<0);
STICKLINE(C>0,40,60,10,0),COLOR999999;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
A1C:=((A1A-EMA(CLOSE,5))>0);
A1D:=BARSLAST(A1B);
短K:SMA(RSV,3,1),COLORF580F5,LINETHICK0;
短D:SMA(短K,3,1),COLORCCDD33,LINETHICK0;
A1E:=BARSLAST(A1C);
A1F:=IF((A1E>0),(CLOSE-REF(CLOSE,1))/REF(CLOSE, 1)*100,0);
RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
A20:=SUM(A1F,0);
A21:=IF((A1D>0),(0-2),0);
中K:SMA(RSV1,5,1),COLORRED,LINETHICK0;
中D:SMA(中K,10,1),COLOR00FFFF,LINETHICK0;
A22:=IF((A1E>0),SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,A1E),0);
A23:=A22/A1E;
短:=3*短K-2*短D,COLORRED,LINETHICK4;
中:=3*中K-2*中D,COLORRED,LINETHICK4;
A25:=EMA(EMA(EMA(CLOSE,3),3),3);
上升通道:((A25 - REF(A25,1))+A25),COLORRED;
趋势线:(短+中)/2,COLORFF9900,LINETHICK2;
底线:10,COLORWHITE;
顶线:90,COLOR33FF33;
反转通道:MA(上升通道,15),COLORGREEN;
IF(上升通道>REF(上升通道,1),上升通道,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;
IF(反转通道>REF(反转通道,1),反转通道,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;
BB:=IF(BARSLAST(CROSS(短K,RSV))>=3 AND CROSS(RSV,短K) AND 短K<30,20,0);
STICKLINE((上升通道>反转通道),反转通道,上升通道,1,0),COLORMAGENTA;
STICKLINE((反转通道>上升通道),上升通道,反转通道,1,0),COLORFF0000;
STICKLINE(BB,0,50,2.8,1),COLOR0000BB;
STICKLINE(BB,0,50,1.4,1),COLOR0000DD;
STICKLINE(BB,0,50,0.7,1),COLOR0000FF;
DRAWTEXT(CROSS(反转通道,上升通道),上升通道*1.08,'下降趋势'),COLOR00FF00;
DRAWTEXT(CROSS(上升通道,反转通道),反转通道*0.97,'上升趋势'),COLOR0000FF;
AA:=IF(BARSLAST(CROSS(RSV,短K))>=4 AND CROSS(短K,RSV) AND RSV>50,20,0);
DRAWICON(((REF(A21,1)=(0-2)) AND (A21=0)),LOW,5);
DRAWICON(((REF(A1E,1)>0) AND (A1E=0)),HIGH,6);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 15:08 复制 查看全部楼层
雨竹168 发表于 2020-11-16 14:48
许老师您好
请在写一个公式中的 红柱 选股 谢谢

RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
A1C:=((A1A-EMA(CLOSE,5))>0);
A1D:=BARSLAST(A1B);
短K:=SMA(RSV,3,1),COLORF580F5,LINETHICK0;
短D:=SMA(短K,3,1),COLORCCDD33,LINETHICK0;
A1E:=BARSLAST(A1C);
A1F:=IF((A1E>0),(CLOSE-REF(CLOSE,1))/REF(CLOSE, 1)*100,0);
RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
A20:=SUM(A1F,0);
A21:=IF((A1D>0),(0-2),0);
中K:=SMA(RSV1,5,1),COLORRED,LINETHICK0;
中D:=SMA(中K,10,1),COLOR00FFFF,LINETHICK0;
A22:=IF((A1E>0),SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,A1E),0);
A23:=A22/A1E;
短:=3*短K-2*短D,COLORRED,LINETHICK4;
中:=3*中K-2*中D,COLORRED,LINETHICK4;

BB:BARSLAST(CROSS(短K,RSV))>=3 AND CROSS(RSV,短K) AND 短K<30;

举报

点亮(1) 扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-16 14:57 复制 查看全部楼层
许昌舍得 发表于 2020-11-16 14:35
A25:=EMA(EMA(EMA(CLOSE,3),3),3);
上升通道:=((A25 - REF(A25,1))+A25),COLORRED;

许老师您好
请把公式源码中上升趋势和下降趋势保留同时也保留虚线,因为压缩的太小了看不清其它去掉,谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-16 14:48 复制 查看全部楼层
许昌舍得 发表于 2020-11-16 14:35
A25:=EMA(EMA(EMA(CLOSE,3),3),3);
上升通道:=((A25 - REF(A25,1))+A25),COLORRED;

许老师您好
请在写一个公式中的 红柱 选股 谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 14:35 复制 查看全部楼层
A25:=EMA(EMA(EMA(CLOSE,3),3),3);
上升通道:=((A25 - REF(A25,1))+A25),COLORRED;

反转通道:=MA(上升通道,15),COLORGREEN;

XG:CROSS(上升通道,反转通道);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表