请老师帮助把F上穿赢富线做个预警公式

[通达信]
设置
1449 7 鑫股民 Lv.3 发表于 · 2020-11-16 14:39 显示全部楼层 正序浏览 |
跳转到指定楼层
M:=24;N:=24;
      资金异动:=VOL/MA(VOL,55)*100;
      箱顶:=MA(HHV(C,30),2);
      箱顶线:IF(H>箱顶,DRAWNULL,箱顶),COLOR0000FF,LINETHICK2;
      AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,M))/MA(CLOSE,M);
      赢富线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
      CC:=(CLOSE/赢富线); {}
      MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
      MAAA:=((MA1-赢富线)/赢富线)/3;
      TMP:=MA1-MAAA*MA1;
      Y:IF(TMP<=赢富线,赢富线,DRAWNULL),LINETHICK3,COLORWHITE;
      F:TMP,LINETHICK2,COLORYELLOW;
      X:IF(TMP<=赢富线,TMP,DRAWNULL),LINETHICK2,COLORGREEN;
      乾坤线:(EMA(C,18)),LINETHICK2,COLORBLUE;
      A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
      A4:=EMA(C,10);
      A5:=REF(C,2);
      A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
      A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
      A8:=LLV(L,21);
      A9:=HHV(H,21);
      A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
      A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
      A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
      A13:=LLV(L,55);
      A14:=HHV(H,34);
      A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
      A16:=(A11 + A15) / 2;
      A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
      A18:=EMA(A16,5);
      A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
      A20:=CROSS(A10,A11);
      A21:=(CROSS(A10,A19)) AND (A19 < 30);
      A22:=A21 * 0.6;
      A23:=((C + L) + H) / 3;
      A24:=EMA(A23,6);
      A25:=EMA(A24,5);
      A26:=CROSS(A24,A25);{
      STICKLINE(((C >= 乾坤线) AND (C >= O)),H,L,0,1),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C >= O)),O,C,2,1),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C <= O)),H,L,0,0),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C <= O)),O,C,2,0),COLORRED;
      STICKLINE(((C < 乾坤线) AND (C >= O)),H,L,0,1),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C >= O)),O,C,2,1),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C <= O)),H,L,0,0),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C <= O)),O,C,2,0),COLORGREEN;}
      BOLL:=MA(CLOSE,N);
      UPPER:=BOLL+2*STD(CLOSE,N);
      LOWER:=BOLL-2*STD(CLOSE,N);

      VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
      VAR2:=SMA(VAR1,9,1)+100;
      VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
      VAR4:=SMA(VAR3,3,1);
      VAR5:=SMA(VAR4,3,1)+100;
      VAR6:=VAR5-VAR2;
      趋势:= IF(VAR6>45,VAR6-45,0);
      AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
      AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
      AA5:=SMA(AA4,13,8);
      走势:=CEILING(SMA(AA5,13,8));
      AA6:=SMA(AA3,21,8);
      卖临界:=STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
      主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
      SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1,POINTDOT;
      超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORLIRED;

      RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
      K:=SMA(RSV,3,1);
      D:=SMA(K,3,1);
      J:=3*K-2*D;
      卖点1:=C>UPPER AND ((趋势>=70 AND 超短线>=90) OR 趋势>=80);
      卖点2:=REF(超短线,1)=100 AND 超短线<100 AND 趋势>90;
      买点:=CROSS(A4,A3);{本文来源:'WWW.328588.COM' }
      选股:=C<LOWER AND ((趋势<=30 AND 超短线<=10) OR 趋势<=20) AND 资金异动<75;{超跌,BOLL与捕捉启动股}
      选股2:=选股 AND J<= -10;
      DRAWTEXT(选股2, L,'买'),COLORRED;

举报

使用道具 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 16:16 复制 查看全部楼层
枫之舞0001 发表于 2020-11-16 15:58
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);


  A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2));
庄家轨迹:=(EMA(A7,A2)),COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8));
A17:=(EMA(A16,5));
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
庄启动:(A28 OR A31)

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 16:14 复制 查看全部楼层
鑫股民 发表于 2020-11-16 15:12
老师,可以了,我自己找到问题所在已解决。再次感谢。

  M:=9;
      资金异动:=VOL/MA(VOL,55)*100;
      箱顶:=MA(HHV(C,30),2);
      箱顶线:IF(H>箱顶,DRAWNULL,箱顶),COLOR0000FF,LINETHICK2;
      AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,M))/MA(CLOSE,M);
      赢富线:=DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
      CC:=(CLOSE/赢富线); {}
      MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
      MAAA:=((MA1-赢富线)/赢富线)/3;
      TMP:=MA1-MAAA*MA1;
      Y:IF(TMP<=赢富线,赢富线,DRAWNULL),LINETHICK3,COLORWHITE;
      
      F:=TMP,LINETHICK2,COLORYELLOW;
   XG:CROSS(F,  赢富线);

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

枫之舞0001
Lv.3
发表于 2020-11-16 15:58 复制 查看全部楼层
许昌舍得 发表于 2020-11-16 14:58
M:=24;N:=24;
      资金异动:=VOL/MA(VOL,55)*100;
      箱顶:=MA(HHV(C,30),2);

A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2));
庄家轨迹:=(EMA(A7,A2)),COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8));
A17:=(EMA(A16,5));
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
庄启动:DRAWICON((A28 OR A31),庄家轨迹,26);


能不能麻烦你帮我把庄启动 改选股呀

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

鑫股民
Lv.3
发表于 2020-11-16 15:12 复制 查看全部楼层
老师,可以了,我自己找到问题所在已解决。再次感谢。

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

鑫股民
Lv.3
发表于 2020-11-16 15:02 复制 查看全部楼层
老师,公式有错误局。
当前公式 : 资金异动预警 (条件选股公式)  
错误句 :
      TMP:=MA1-MAAA*MA1
详细信息 : 未知字符串 MAAA
错误起始位置 : 390 ; 长度: 4

举报

使用道具 扔鸡蛋(0) 回复

鑫股民
Lv.3
发表于 2020-11-16 15:00 复制 查看全部楼层
谢谢老师!

举报

使用道具 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 14:58 复制 查看全部楼层
本帖最后由 福阿德 于 2020-11-16 15:06 编辑

    M:=24;N:=24;
      资金异动:=VOL/MA(VOL,55)*100;
      箱顶:=MA(HHV(C,30),2);
      箱顶线:=IF(H>箱顶,DRAWNULL,箱顶),COLOR0000FF,LINETHICK2;
      AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,M))/MA(CLOSE,M);
      赢富线:=DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
      CC:=(CLOSE/赢富线); {}
      MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
      TMP:=MA1-MAAA*MA1;
      
      F:=TMP,LINETHICK2,COLORYELLOW;
   XG:CROSS(F,  赢富线);

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表