手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个:出现如图中所示颜色的选股指标(洋红色和金色)

[通达信]
设置
1075 4 红花绿叶配 Lv.3 发表于 · 2020-11-16 18:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

X_2:=IF(CLOSE>OPEN,CLOSE,OPEN);
X_3:=IF(CLOSE>OPEN,OPEN,CLOSE);
X_4:=LLV(X_2,4);
X_5:=HHV(X_3,4);
X_6:=X_2>=X_4 AND X_3<=X_4 AND X_2>=X_5 AND X_3<=X_5;
X_7:=REF(X_2,1)>=X_4 AND REF(X_3,1)<=X_4 AND REF(X_2,1)>=X_5 AND REF(X_3,1)<=X_5;
X_8:=REF(X_2,2)>=X_4 AND REF(X_3,2)<=X_4 AND REF(X_2,2)>=X_5 AND REF(X_3,2)<=X_5;
X_9:=REF(X_2,3)>=X_4 AND REF(X_3,3)<=X_4 AND REF(X_2,3)>=X_5 AND REF(X_3,3)<=X_5;
X_10:=X_6 AND X_7 AND X_8 AND X_9;
X_11:=REF(X_5,BARSLAST(X_10));
X_12:=(REF(OPEN,5)+REF(CLOSE,5))/2;
X_13:=(HIGH+LOW+CLOSE+OPEN)/4;
X_14:=MAX(X_12,MAX(X_13,HHV(HIGH,5)));
X_15:=MIN(X_12,MIN(X_13,LLV(LOW,5)));
DRAWKLINE(X_14,X_12,X_15,X_13);
X_16:=X_14=X_12;
X_17:=X_16;
X_18:=REF(X_14,BARSLAST(X_17));
X_19:=EMA(CLOSE,5)-EMA(CLOSE,55);
X_20:=EMA(X_19,10);
X_21:=X_19-X_20;
X_22:=CLOSE>X_18 AND X_21>0;
STICKLINE(X_22,X_14,X_15,3.2,1),COLORMAGENTA;
STICKLINE(X_22,X_12,X_13,3.2,0),COLORMAGENTA;
STICKLINE(X_22,X_12,X_13,3,0),COLORMAGENTA;
STICKLINE(X_22,X_12,X_13,1.9,0),COLORMAGENTA;
STICKLINE(X_22,X_12,X_13,1.1,0),COLORMAGENTA;
STICKLINE(X_22,X_12,X_13,0.3,1),COLORMAGENTA;
STICKLINE(X_22<1,X_14,X_15,3.2,1),COLORLIBLUE;
STICKLINE(X_22<1,X_12,X_13,3.2,0),COLORLIBLUE;
STICKLINE(X_22<1,X_12,X_13,2,0),COLORLIBLUE;
STICKLINE(X_22<1,X_12,X_13,1,1),COLORLIBLUE;
X_23:=X_15=REF(X_15,1) AND X_14<REF(X_14,1) AND X_16;
X_24:=X_15=REF(X_15,1) AND X_15=REF(X_15,2) AND X_15=REF(X_15,3) AND X_15=REF(X_15,4);
STICKLINE(X_24,X_14,X_15,3.2,1),COLORGREEN;
STICKLINE(X_24,X_12,X_15,2.6,0),COLORGREEN;
STICKLINE(X_24,X_12,X_13,2.6,0),COLORGREEN;
STICKLINE(X_24,X_12,X_15,0.5,1),COLORGREEN;
X_25:=X_1>=9.84 AND REF(X_1<9.84,1) AND REF(X_1<9.84,2);
STICKLINE(X_1>=9.84,X_12*1.05,X_13*0.95,3.4,0),COLOR00AAFF;
STICKLINE(X_1>=9.84,X_12*1.05,X_13*0.95,2,0),COLOR00CCFF;
STICKLINE(X_1>=9.84,X_12*1.05,X_13*0.95,0.5,0),COLORYELLOW;
STICKLINE(X_25,X_12*1.05,X_13*0.95,0.5,0),COLORRED;
STICKLINE(CLOSE,X_18-X_18*0.0035,X_18,3,0),COLORGREEN,LINETHICK3;
X_26:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_27:=X_26>9.85匒ND NOT(OPEN=CLOSE) AND X_1>4;
X_28:=X_26>9.85 AND NOT(OPEN=CLOSE) AND X_1>4 AND X_1<9.3;
X_29:=REF(HIGH,BARSLAST(X_28));
X_30:=REF(LOW,BARSLAST(X_28));
STICKLINE(HIGH,X_29-X_29*0.003,X_29,3,0),COLORWHITE;
X_31:=MA(OPEN,20);
X_32:=OPEN>MA(OPEN,5);
X_33:=MA(OPEN,5)>MA(OPEN,10);
X_34:=OPEN>MA(OPEN,10);
X_35:=MA(OPEN,5)>MA(OPEN,20);
X_36:=OPEN>MA(OPEN,20);
X_37:=REF(X_31,1);
X_38:=X_31>X_37;
X_39:=IF(X_32,10,0-10)+IF(X_33,10,0-10)+IF(X_34,10,0-10)+IF(X_35,10,0-10)+IF(X_36,10,0-10)+IF(X_38,10,0-10);
X_40:=MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1) AND MA(CLOSE,60)>REF(MA(CLOSE,60),1);
X_41:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60);
X_42:=LOW<MA(CLOSE,5) AND LOW<MA(CLOSE,10) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10);
X_43:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
WWW70822COM:=X_43>9.85 AND X_24;
X_44:=X_43>9.85 AND X_24;
X_45:=X_26>9.85 AND NOT(OPEN=CLOSE) AND X_1>4 AND X_1<9.3;
X_46:=(CLOSE-REF(CLOSE,BARSLAST(X_45)))/REF(CLOSE,BARSLAST(X_45))*100;
B:REF(X_5,BARSLAST(X_10)),NODRAW;
A:REF(HIGH,BARSLAST(X_28)),NODRAW;
S:REF(X_14,BARSLAST(X_17)),NODRAW;
X_47:=B=REF(B,1);
X_48:=BARSLAST(NOT(X_47));
STICKLINE(X_5,X_11-X_11*0.003,X_11,3,0),COLORYELLOW,LINETHICK3;
DRAWNUMBER(X_47>0,B*0.99,X_48),COLORYELLOW;
DRAWICON(X_39>40 AND X_22 AND EXIST(X_10,12),X_11*0.9,89);
X_49:=EMA(EMA(EMA(X_14,5),5),5);



出现如图中所示颜色的选股指标:洋红色  和金色 。

附件

截图00.png

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-16 21:09 复制 查看全部楼层
个别洋红色图中未能显示,原因是被后面的绿色给覆盖,选股洋红色或金色:
X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_12:=(REF(OPEN,5)+REF(CLOSE,5))/2;
X_13:=(HIGH+LOW+CLOSE+OPEN)/4;
X_14:=MAX(X_12,MAX(X_13,HHV(HIGH,5)));
X_16:=X_14=X_12;
X_17:=X_16;
X_18:=REF(X_14,BARSLAST(X_17));
X_19:=EMA(CLOSE,5)-EMA(CLOSE,55);
X_20:=EMA(X_19,10);
X_21:=X_19-X_20;
X_22:=CLOSE>X_18 AND X_21>0;
X_22 OR  ...楼主推荐 推荐

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-17 13:14 复制 查看全部楼层
红花绿叶配 发表于 2020-11-17 11:50
老师,能不能再加个条件,再绿色或蓝色后面第一次出现   洋红色 的选股指标。

和上个选股合并:
X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_12:=(REF(OPEN,5)+REF(CLOSE,5))/2;
X_13:=(HIGH+LOW+CLOSE+OPEN)/4;
X_14:=MAX(X_12,MAX(X_13,HHV(HIGH,5)));
X_15:=MIN(X_12,MIN(X_13,LLV(LOW,5)));
X_16:=X_14=X_12;
X_17:=X_16;
X_18:=REF(X_14,BARSLAST(X_17));
X_19:=EMA(CLOSE,5)-EMA(CLOSE,55);
X_20:=EMA(X_19,10);
X_21:=X_19-X_20;
X_22:=CLOSE>X_18 AND X_21>0;
X_24:=X_15=REF(X_15,1) AND X_15=REF(X_15,2) AND X_15=REF(X_15,3) AND X_15=REF(X_15,4);
(X_22 OR  X_1>=9.84) OR ((REF(X_24,1) OR REF(X_22<1,1)) AND X_22);

举报

点亮(0) 扔鸡蛋(0) 回复

红花绿叶配
Lv.3
发表于 2020-11-17 11:50 复制 查看全部楼层
北沙 发表于 2020-11-16 21:09
个别洋红色图中未能显示,原因是被后面的绿色给覆盖,选股洋红色或金色:
X_1:=(CLOSE-REF(CLOSE,1))/REF( ...

老师,能不能再加个条件,再绿色或蓝色后面第一次出现   洋红色 的选股指标。

举报

点亮(0) 扔鸡蛋(0) 回复

红花绿叶配
Lv.3
发表于 2020-11-17 10:13 复制 查看全部楼层
北沙 发表于 2020-11-16 21:09
个别洋红色图中未能显示,原因是被后面的绿色给覆盖,选股洋红色或金色:
X_1:=(CLOSE-REF(CLOSE,1))/REF( ...

非常感谢!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表