手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个出现'←共振买'预警选股公式

[通达信]
设置
1258 2 感悟人生真缔 Lv.4 发表于 · 2020-11-16 20:37 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;
RSV:=(C-LL)/(HH-LL)*100;
K1:=SMA(RSV,3,1);
DA:=SMA(K1,3,1);
J1:=3*K1-2*DA;
K:K1*FG+LL,NODRAW;
D:DA*FG+LL,NODRAW;
J:=J1*FG+LL;
DRAWBAND(K,RGB(250,0,0),D,RGB(0,180,0));
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2*(ZIF-ZEA);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
导向:ZXH,COLORFFFFFF;
平滑:ZPH,COLOR00FFFF;
牛熊:ZNX,COLORFF00FF;
趋势:ZQS,COLORFFFF00;
DRAWKLINE(H,O,L,C);
NL:=(VOL+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/3.3;
XG1:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND CROSS(ZXH,ZQS);
XG2:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND ZXH>ZPH AND ZXH>REF(ZXH,1);
DRAWTEXT(XG1 OR XG2,L,'←共振买'),COLORRED;

举报

扔鸡蛋(0) 回复

感悟人生真缔
Lv.4
发表于 2020-11-16 21:09 复制 查看全部楼层
竹隐风雷 发表于 2020-11-16 20:44
HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;

谢谢老师,谢谢。

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-16 20:44 复制 查看全部楼层
HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;
RSV:=(C-LL)/(HH-LL)*100;
K1:=SMA(RSV,3,1);
DA:=SMA(K1,3,1);
J1:=3*K1-2*DA;
K:=K1*FG+LL;
D:=DA*FG+LL;
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;
NL:=(VOL+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/3.3;
XG1:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND CROSS(ZXH,ZQS);
XG2:=V>NL AND REF(J1<50,1) AND CROSS(K,D) AND ZXH>ZPH AND ZXH>REF(ZXH,1);
DRAWTEXT(XG1 OR XG2,L,'&#161;&#251;12&#213;&#241;&#194;ò'),COLORRED;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表