手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助在箱顶线断掉的那天写个选股

[通达信]
设置
1279 4 中国饭店 Lv.4 发表于 · 2020-11-16 21:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
M:=24;N:=24;
      资金异动:=VOL/MA(VOL,55)*100;
      箱顶:=MA(HHV(C,30),2);
      箱顶线:IF(H>箱顶,DRAWNULL,箱顶),COLOR0000FF,LINETHICK2;
      AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,M))/MA(CLOSE,M);
      赢富线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
      CC:=(CLOSE/赢富线);
      MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
      MAAA:=((MA1-赢富线)/赢富线)/3;
      TMP:=MA1-MAAA*MA1;
      Y:IF(TMP<=赢富线,赢富线,DRAWNULL),LINETHICK3,COLORWHITE;
      F:TMP,LINETHICK2,COLORYELLOW;
      X:IF(TMP<=赢富线,TMP,DRAWNULL),LINETHICK2,COLORGREEN;
      乾坤线:(EMA(C,18)),LINETHICK2,COLORBLUE;
      A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
      A4:=EMA(C,10);
      A5:=REF(C,2);
      A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
      A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
      A8:=LLV(L,21);
      A9:=HHV(H,21);
      A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
      A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
      A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
      A13:=LLV(L,55);
      A14:=HHV(H,34);
      A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
      A16:=(A11 + A15) / 2;
      A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
      A18:=EMA(A16,5);
      A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
      A20:=CROSS(A10,A11);
      A21:=(CROSS(A10,A19)) AND (A19 < 30);
      A22:=A21 * 0.6;
      A23:=((C + L) + H) / 3;
      A24:=EMA(A23,6);
      A25:=EMA(A24,5);
      A26:=CROSS(A24,A25);{
      STICKLINE(((C >= 乾坤线) AND (C >= O)),H,L,0,1),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C >= O)),O,C,2,1),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C <= O)),H,L,0,0),COLORRED;
      STICKLINE(((C >= 乾坤线) AND (C <= O)),O,C,2,0),COLORRED;
      STICKLINE(((C < 乾坤线) AND (C >= O)),H,L,0,1),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C >= O)),O,C,2,1),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C <= O)),H,L,0,0),COLORGREEN;
      STICKLINE(((C < 乾坤线) AND (C <= O)),O,C,2,0),COLORGREEN;}
      BOLL:=MA(CLOSE,N);
      UPPER:=BOLL+2*STD(CLOSE,N);
      LOWER:=BOLL-2*STD(CLOSE,N);

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-16 22:02 复制 查看全部楼层
北沙 发表于 2020-11-16 21:24
箱顶:=MA(HHV(C,30),2);
箱顶线:=IF(H>箱顶,DRAWNULL,箱顶);
箱顶线=DRAWNULL AND REF(箱顶线,1)>0;

涨学问无效数还能当有效值用

举报

扔鸡蛋(0) 回复

中国饭店
Lv.4
发表于 2020-11-16 21:54 复制 查看全部楼层
谢谢舍得老师

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 21:30 复制 查看全部楼层
   资金异动:=VOL/MA(VOL,55)*100;
       箱顶:=MA(HHV(C,30),2);
       箱顶线:=IF(H>箱顶,DRAWNULL,箱顶),COLOR0000FF,LINETHICK2;

XG:REF(C<MA(HHV(C,30),2),1) AND C>MA(HHV(C,30),2);

附件

tdxjietu2.JPG

举报

点亮(3) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-16 21:24 复制 查看全部楼层
箱顶:=MA(HHV(C,30),2);
箱顶线:=IF(H>箱顶,DRAWNULL,箱顶);
箱顶线=DRAWNULL AND REF(箱顶线,1)>0;

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表