手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式选出缩涨字样的

[通达信]
设置
1187 1 小鱼刺 Lv.3 发表于 · 2020-11-17 06:54 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选出出现“缩涨”字样的股票

精准眼:=BETWEEN(C,DYNAINFO(11)+0.01,DYNAINFO(11)-0.01)   AND C>MA(C,20);
STICKLINE(精准眼,O,C,1,0),COLORBLUE;
STICKLINE(精准眼,H,L,0,0),COLORBLUE;
波幅眼:=BETWEEN(MAX(C,O)-MIN(C,O),0.01,-0.01) AND NOT(H=L)  AND C>MA(C,20);
STICKLINE(波幅眼,O,C,3,0),COLORMAGENTA;
STICKLINE(波幅眼,H,L,0,0),COLORMAGENTA;


黄金阴眼:=O>REF(C,1)  AND V<REF(V,1)*0.51 AND C<REF(C,1) AND C>MA(C,20) ;
STICKLINE(黄金阴眼,O,C,1,0),COLORYELLOW;
DRAWTEXT(黄金阴眼, L*0.99, '黄金阴眼'),COLORWHITE;
黄金眼:=O<REF(C,1)  AND V<REF(V,1)*0.7  AND C>O  AND C<REF(C,1) AND REF(C,1)<REF(C,2)
AND REF(O,1)>REF(C,1)  AND C>MA(C,20);
STICKLINE(黄金眼,O,C,1,0),COLORCYAN;
DRAWTEXT(黄金眼, L*0.99, '黄金眼'),COLORWHITE;
腾空眼:=O>REF(C,1) AND C>O  AND REF(C,1)>REF(C,2) AND (V<REF(V,1)*0.7  OR V=LLV(V,50))  AND C>MA(C,20);
STICKLINE(腾空眼,O,C,1,0),COLORRED;
DRAWTEXT(腾空眼, L*0.98, '腾空眼'),COLORRED;
腾空阳:=O>REF(C,1) AND C>O  AND REF(C,1)>REF(C,2) AND V>=REF(V,1)*0.7 AND  V<REF(V,1)  AND C>MA(C,20);
STICKLINE(腾空阳,O,C,1,0),COLORMAGENTA;
DRAWTEXT(腾空阳, L*0.99, '腾空阳'),COLORWHITE;
黄金阳:=O<REF(C,1)   AND  V<REF(V,1) AND C>O  AND C<REF(C,1)
AND REF(C,1)>REF(C,2) AND REF(C,1)>REF(O,1)  AND C>MA(C,20);
STICKLINE(黄金阳,O,C,1,0),COLORCYAN;
DRAWTEXT(黄金阳, L*0.99, '黄金阳'),COLORWHITE;
黄金阴:=O>REF(C,1)  AND V<REF(V,1)  AND V>REF(V,1)*0.51  AND C<REF(C,1)  AND C>MA(C,20);
STICKLINE(黄金阴,O,C,1,0),COLORLIRED;
DRAWTEXT(黄金阴, L*0.99, '黄金阴'),COLORWHITE;
小阳三连元:=IF(DYNAINFO(4)>0,LAST(O>REF(C,1)  AND C>REF(C,1)  AND  C/REF(C,1)<=1.06  AND C>MA(C,20) ,2,0),0);
DRAWTEXT(小阳三连元, L*0.99, '三连元'),COLORWHITE;
跳空阳:=L>REF(H,1) AND C>O AND V>=REF(V,1)  AND C>MA(C,20);

DRAWTEXT(跳空阳, L*0.99, '跳空阳'),COLORWHITE;
量缩价涨:=REF(V,3)=HHV(V,4) AND REF(C,3)>REF(C,4) AND REF(C,3)>REF(O,3) AND C=HHV(C,4)  AND C>MA(C,20);
DRAWTEXT(量缩价涨, L*0.99, '缩涨'),COLORMAGENTA;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
长期线1:=A+100;
短期线1:=B+100;
中期线1:=D+100;
底部:=(长期线1<12 AND 中期线1<8 AND (短期线1<7.2 OR REF(短期线1,1)<5) AND (中期线1>REF(中期线1,1) OR 短期线1>REF(短期线1,1)))
OR (长期线1<8 AND 中期线1<7 AND 短期线1<15 AND 短期线1>REF(短期线1,1)) OR (长期线1<10 AND 中期线1<7 AND 短期线1<1) ;
底部区域:=FILTER(底部,10);
金叉:=长期线1<15 AND REF(长期线1,1)<15 AND 中期线1<18 AND 短期线1>REF(短期线1,1) AND CROSS(短期线1,长期线1) AND 短期线1>中期线1
AND (REF(短期线1,1)<5 OR REF(短期线1,2)<5 ) AND (中期线1>=长期线1 OR REF( 短期线1,1)<1 );
低位金叉:=FILTER(金叉,10);
DRAWTEXT(低位金叉, L*0.99, '低金'),COLORLIGREEN;
DRAWTEXT(底部区域, L*0.99, '底部'),COLORYELLOW;
均值:=(3*CLOSE+OPEN+LOW+HIGH)/6;
短期线:(19*均值+19*REF(均值,1)+18*REF(均值,2)+17*REF(均值,3)+16*REF(均值,4)+15*REF

(均值,5)+14*REF(均值,6)
+13*REF(均值,7)+12*REF(均值,8)+11*REF(均值,9)+10*REF(均值,10)+9*REF(均值,11)+8*REF

(均值,12)
+7*REF(均值,13)+6*REF(均值,14)+5*REF(均值,15)+4*REF(均值,16)+3*REF(均值,17)+2*REF

(均值,20)+
REF(均值,19))/210,COLORYELLOW;
长期线:MA(短期线,5),COLORRED;



{涨跌停价格显示};
AA:=(C-REF(C,1))/REF(C,1)*100;
ZS:=(NAMELIKE('ST') OR NAMELIKE('*ST') OR  NAMELIKE('S')) AND AA>=4.945;
DS:=(NAMELIKE('ST') OR NAMELIKE('*ST') OR  NAMELIKE('S')) AND AA<=-4.945;
涨停价:IF(ZS,REF(C,1)*1.05,REF(C,1)*1.1),NODRAW,COLORRED;
跌停价:IF(DS,REF(C,1)*0.95,REF(C,1)*0.9),NODRAW,COLORGREEN;

{涨跌停K线标识};
ST:=NAMELIKE('ST')=1 OR NAMELIKE('*ST')=1 OR NAMELIKE('SST')=1
                     OR NAMELIKE('S*ST')=1 OR NAMELIKE('S ST')=1;
涨停:=C/REF(C,1)>1.097 OR (C/REF(C,1)>1.0495 AND ST);
跌停:=REF(C,1)/C>1.0995  AND REF(C,1)/C<1.1 OR (REF(C,1)/C>1.0495 AND ST);
STICKLINE(涨停,C,O,3,0),COLORMAGENTA;
STICKLINE(跌停,C,O,3,0),COLORGREEN;
DRAWICON(H=ZTPRICE(REF(CLOSE,1),0.1)  AND C=H,L*0.965,15);

LDM4:=CONST(HHV(REF(HIGH,1),240));
LDM5:=CONST(LLV(REF(LOW,1),240));
LDM6:=LDM4-LDM5;
LDM7:=LOW-LDM6*0.03;
LDM8:=HIGH+LDM6*0.03;
LDM9:=CLOSE>500;
LDM10:=MAX(CLOSE,OPEN);
LDM11:=MIN(CLOSE,OPEN);
LDM12:=0;
LDM13:=1;
LDM14:=IF(LDM9,HIGH,LDM10);
LDM15:=IF(LDM9,LOW,LDM11);
LDM16:=IF(CLOSE>OPEN,IF(LDM13=0,LOW,LDM15),IF(LDM13=0,HIGH,LDM14));
LDM17:=2/1000;
LDM18:=CURRBARSCOUNT;
LDM19:=400;
LDM20:=LDM18<=LDM19;
LDM21:=LOW;
LDM22:=IF(LDM12=0,LDM21,REF(LDM12,LDM12));
基准价:IF(LDM20,CONST(LDM22),DRAWNULL),DOTLINE,COLORWHITE;
LDM23:=基准价;
LDM24:=LDM23*LDM17;
LDM25:=ABS(LOW-LDM23)<=LDM24;
LDM26:=ABS(OPEN-LDM23)<=LDM24;
LDM27:=ABS(CLOSE-LDM23)<=LDM24;
LDM28:=ABS(HIGH-LDM23)<=LDM24;
LDM29:=LDM25 OR LDM26 OR LDM27 OR LDM28 AND LDM20 AND LDM18=1;
LDM30:=COUNT(LDM29,LDM19);
精准点个数:IF(LDM30>0,LDM30+1,0),NODRAW,COLORWHITE;
LDM1:='神龙强势.神龙强势#DAY';
DRAWTEXT_FIX(ISLASTBAR ,0.75,0.95,0,'【神龙强势】')COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,0.9,0.95,0,CON2STR(LDM1,1))COLORWHITE;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 07:35 复制 查看全部楼层
REF(V,3)=HHV(V,4) AND REF(C,3)>REF(C,4) AND REF(C,3)>REF(O,3) AND C=HHV(C,4)  AND C>MA(C,20);

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表