请老师帮助做个选股公式选出出现黄柱却没出现底背离的个股

[通达信]
设置
1576 4 小鱼刺 Lv.3 发表于 · 2020-11-17 06:56 显示全部楼层 正序浏览 |
跳转到指定楼层
选出只出现黄柱,没提示底背离这几个字的股票

工作:EMA(CLOSE,5),COLORFFFFFF;
操盘:MA(CLOSE,9),COLORFFFF00;
DRAWICON( FILTER(CROSS(工作,操盘),1),L*0.97,1);
DRAWICON( FILTER(CROSS(操盘,工作),1),H*1.03,2);
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.94),'底背离'),COLORYELLOW;
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));

举报

使用道具 扔鸡蛋(0) 回复

小鱼刺
Lv.3
发表于 2020-12-18 09:36 复制 查看全部楼层
注册111 发表于 2020-12-18 06:41
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(C ...

十分感谢老师指导

举报

使用道具 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-12-18 06:41 复制 查看全部楼层
小鱼刺 发表于 2020-12-17 18:52
老师,麻烦帮我做个选股公式,十分感谢

VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);
VAR5<-36;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

小鱼刺
Lv.3
发表于 2020-12-17 18:52 复制 查看全部楼层
注册111 发表于 2020-11-17 07:48
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
FF:=EMA(CLOSE,3);
MA15:= ...

老师,麻烦帮我做个选股公式,十分感谢

VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR4:=(VAR1+2*VAR2+3*VAR3)/6;
VAR5:=MA(VAR4,3)-STD(VAR4,3);

乖离36: STICKLINE(VAR5<-36,125,110,6,0),COLOR95FBDD

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 07:48 复制 查看全部楼层

V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
CROSS(FF,MA15)=0&&V2>1;

举报

使用道具 点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表