请老师帮忙做个能选出出现'日月'字样的选股公式

[通达信]
设置
1742 4 小鱼刺 Lv.3 发表于 · 2020-11-17 06:57 显示全部楼层 正序浏览 |
跳转到指定楼层
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=GJTJ1=GJTJ2 AND GJTJ2=GJTJ3 AND GJTJ1=100 AND GJTJ4>96;
B:=COUNT(A,2)=1;
D:=GJTJ1<GJTJ2 AND GJTJ1<GJTJ3 AND GJTJ1<GJTJ4 AND GJTJ2<GJTJ3 AND GJTJ4<95;
YH:=INDEXC/REF(INDEXC,1)*REF(C,1);
YH1:=REF(C,1)+C-INDEXC/REF(INDEXC,1)*REF(C,1);
X1:=EMA(YH1,7);
X2:=EMA(YH1,14);
X3:=EMA(X1,14);
E:=X1>X2 AND X2>X3;
竟星:=B AND D AND E;
DRAWTEXT(竟星,(L * 0.95),'竟星'),COLORWHITE;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5  AND GJTJ1>GJTJ4;
天瀑:=COUNT(XG,3)=1 AND XG;
DRAWTEXT(天瀑,(L * 0.95),'天瀑'),COLORYELLOW;
STICKLINE(天瀑,C,O,6,0),COLORYELLOW;
STICKLINE(天瀑,H,L,1,0),COLORYELLOW;
A1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
B1:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
E1:=GJTJ1>60 AND GJTJ4>70;
白金:=A1 AND B1  AND E1;
DRAWTEXT(白金,(L * 0.95),'白金'),COLORGREEN;
STICKLINE(白金,C,O,6,0),COLORGREEN;
{日月}
A2:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B2:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=A2 AND B2;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A4:=AA AND BA ;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A8:=AAA AND BAA ;
B21:=REF(A3,1);
B3:=REF(A4,1);
B4:=REF(A8,1);
D2:=GJTJ1=100 AND GJTJ2=100  AND A3 ;
D3:=GJTJ1=100 AND GJTJ2=100  AND A4 ;
D4:=GJTJ1=100 AND GJTJ2=100  AND A8 ;
日月:=D2 OR D3 OR D3;
DRAWTEXT(日月,(L * 0.95),'日月'),COLORF00FF0;
A5:=BARSLAST(CROSS(95,GJTJ1))<=2;
B5:=BARSLAST(CROSS(95,GJTJ2))<=2;
E5:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
F1:=GJTJ2>50 AND GJTJ3>50;
G1:=GJTJ1=100 AND GJTJ2=100;
TX:=COUNT(G1,2)=1;
青干:=A5 AND B5 AND E5 AND F1 AND TX;
DRAWTEXT(青干,(L * 0.95),'青干'),COLORRED;
STICKLINE(青干,C,O,6,0),COLORRED;
STICKLINE(青干,H,L,1,0),COLORRED;
A6:=GJTJ3=100;
B6:=GJTJ4<90;
莫问:=COUNT(A6,2) = 2 AND B6;
DRAWTEXT(莫问,(L * 0.95),'莫问'),COLORBLUE;
A7:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
B7:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
黄金:=A7 AND B7;
DRAWTEXT(黄金,(L * 0.95),'黄金'),COLORFFBB00;
三十:MA(C,30),COLORRED,LINETHICK2;
跌:IF(MA(CLOSE,30)<=REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORGREEN,LINETHICK2;

举报

使用道具 扔鸡蛋(0) 回复

小鱼刺
Lv.3
发表于 2020-12-5 16:46 复制 查看全部楼层

谢谢,十分感谢

举报

使用道具 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-12-5 16:29 复制 查看全部楼层
小鱼刺 发表于 2020-12-5 16:15
求老师帮忙做两个选股公式,一个是出现上边绿下边蓝这个条件后第一次出现红箭头。
另一个选股公式是出现 ...

试试
1
BHG1:=1;
BHG2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
BHG3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
BHG4:=SMA(BHG3,3,2);
VARE:=SMA(BHG4,3,2);
BHG5:=BHG2*1.5*BHG1;
BHG6:=(ABS(VARE-BHG5)<1)*BHG1;
BHG7:=(ABS(VARE-BHG5)<5)*BHG1;
上边绿下边蓝:=BHG6 AND BHG7;
BHG8:=(HIGH+LOW+CLOSE)/3*BHG1;
BHG9:=(BHG8-MA(BHG8,14))/(0.015*AVEDEV(BHG8,14))*BHG1;
红箭头:=BHG9<(-100) AND BHG9>REF(BHG9,1);
BARSLAST(上边绿下边蓝)>0&&红箭头;
2
BHG1:=1;
BHG2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
BHG3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
BHG4:=SMA(BHG3,3,2);
VARE:=SMA(BHG4,3,2);
BHG5:=BHG2*1.5*BHG1;
BHG6:=(ABS(VARE-BHG5)<1)*BHG1;
BHG7:=(ABS(VARE-BHG5)<5)*BHG1;
上边绿下边蓝:=BHG6 AND BHG7;
BHG8:=(HIGH+LOW+CLOSE)/3*BHG1;
BHG9:=(BHG8-MA(BHG8,14))/(0.015*AVEDEV(BHG8,14))*BHG1;
红箭头:=BHG9<(-100) AND BHG9>REF(BHG9,1);
BARSLAST(上边绿下边蓝)<5&&红箭头;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

小鱼刺
Lv.3
发表于 2020-12-5 16:15 复制 查看全部楼层
注册111 发表于 2020-11-17 07:56
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3 ...

求老师帮忙做两个选股公式,一个是出现上边绿下边蓝这个条件后第一次出现红箭头。
另一个选股公式是出现上边绿下边蓝后5天内出现了红箭头
麻烦老师了

BHG1:=1;
BHG2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
BHG3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
BHG4:=SMA(BHG3,3,2);
VARE:=SMA(BHG4,3,2);
BHG5:=BHG2*1.5*BHG1;
BHG6:=(ABS(VARE-BHG5)<1)*BHG1;
BHG7:=(ABS(VARE-BHG5)<5)*BHG1;
上边绿下边蓝:BHG6 AND BHG7;





BHG1:=1;
BHG8:=(HIGH+LOW+CLOSE)/3*BHG1;
BHG9:=(BHG8-MA(BHG8,14))/(0.015*AVEDEV(BHG8,14))*BHG1;
红箭头:BHG9<(-100) AND BHG9>REF(BHG9,1);

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 07:56 复制 查看全部楼层
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
{日月}
A2:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
B2:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A3:=A2 AND B2;
AA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
A4:=AA AND BA ;
D2:=GJTJ1=100 AND GJTJ2=100  AND A3 ;
D3:=GJTJ1=100 AND GJTJ2=100  AND A4 ;
D2 OR D3 OR D3;

举报

使用道具 点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表