手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个通达信选股公式

[通达信]
设置
1204 1 小辉狼 Lv.2 发表于 · 2020-11-17 11:46 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮助编写一个通达信选股公式,这是指标源码:

DRAWGBK(O>C,RGB(0,25,180),RGB(0,80,0),0,'',0);
VAR1:=(CLOSE*2+HIGH+LOW)/4;
VAR2:=EMA(VAR1,13)-EMA(VAR1,34);
VAR3:=EMA(VAR2,5);
中轴:0,COLORWHITE,POINTDOT;  
主力做多:2*(VAR2-VAR3)*3.8,LINETHICK2,COLORRED;
主力做空:(-2)*(VAR2-VAR3)*3.8,LINETHICK2,COLORGREEN,NODRAW;
DRAWICON(CROSS(主力做多,主力做空),-0.2,1);
波线:=SMA(主力做多,50,5),LINETHICK2,COLORFFFF00;
STICKLINE(REF(主力做空,2)<主力做空,主力做空,REF(主力做空,2),2,0),COLOR00FF00,NODRAW;
STICKLINE(REF(主力做多,1)<主力做多,主力做多,REF(主力做多,1),2,0),COLOR0000FF;
TJ1:=VOL>=HHV(VOL,20);
TJ2:=VOL/REF(VOL,1)>=2;
TJ3:=TJ1 AND TJ2;
TJ4:=C/O>1.02 AND C>REF(C,1);
量价配合选股:IF(TJ3 AND TJ4,1,DRAWNULL),STICK,LINETHICK7,COLORFF00FF;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
天之:=(AV + NEWVOL);
天天选股:IF(CROSS(天之,0),0.5,0),COLORFFFFFF;

当出现下图这种白色箭头时。当天应该只有白色箭头的一半。

附件

微信图片_20201117114500.png
微信图片_20201117114539.png

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 12:58 复制 查看全部楼层

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
天之:=(AV + NEWVOL);
CROSS(天之,0);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表