手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把该公式做个选股

[通达信]
设置
1383 1 韦神 Lv.3 发表于 · 2020-11-17 12:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师把有庄和筹码小于0做个选股,谢谢
    VAR09:=SMA((OPEN-VAR05)/VAR07,20,1);
    VAR10:=REF(LOW,1);
    VAR11:=SMA(ABS(LOW-VAR10),3,1)/SMA(MAX(LOW-VAR10,0),3,1)*100;
    VAR12:=EMA(IF(CLOSE*1.2,VAR11*10,VAR11/10),3);
    VAR13:=LLV(LOW,38);
    VAR14:=HHV(VAR12,38);
    VAR15:=IF(LLV(LOW,90),1,0);
    VAR16:=EMA(IF(LOW<=VAR13,(VAR12+VAR14*2)/2,0),3)/618*VAR15;
    VARA:=3*VAR08-2*SMA(VAR08,15,1);
    VARB:=3*VAR09-2*SMA(VAR09,15,1);
    VARC:=100-VARB;
    有庄的影子:STICKLINE(VAR16,0,VAR16,2,1),COLORLIRED;
    庄影:VAR16,NODRAW,COLORLIRED;
    新庄:(100-IF(VAR02>5,IF(VAR02<100,VAR02,VAR04-10),0))*VAR01,COLOR4E2F2F,POINTDOT;
    新庄图标:STICKLINE(1,新庄,100,2,1),COLOR4E2F2F;
    短线:=MA(WINNER(CLOSE*0.95)*100,3)*VAR01,COLORWHITE,DOTLINE;
    主力中线筹码:=(100-VARA)*VAR01,COLOR0099FF,DOTLINE;
    中线筹码:=(REVERSE(主力中线筹码)+100)COLORWHITE,DOTLINE;
    筹码:MEMA(中线筹码,2)COLOR8C7853,DOTLINE;{COLOR8C7853 青铜色}
    收盘:=MEMA((0+VARA)*VAR01,2),COLORRED,LINETHICK1;
    开盘:=MEMA((0+VARB)*VAR01,3),COLORGREEN,LINETHICK1;
    趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,COLORRED;
    VARD:=短线>VAR04;VARE:=REF(LOW,1)*0.9;VARF:=LOW*0.9;
    VAR17:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
    VAR18:=EMA(VAR17,30);
    VAR19:=CLOSE-REF(CLOSE,1);
    VAR20:=MAX(VAR12,0);
    VAR21:=ABS(VAR12);
    VAR22:=SMA(VAR20,7,1)/SMA(VAR21,7,1)*100;
    VAR23:=SMA(VAR20,13,1)/SMA(VAR21,13,1)*100;
    VAR24:=BARSCOUNT(CLOSE);
    VAR25:=SMA(MAX(VAR19,0),6,1)/SMA(ABS(VAR19),6,1)*100;
    VAR26:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
    VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
    VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
    VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
    VAR1D:=SMA(VAR1C,4,1);
    VAR1E:=SMA(VAR1D,3,1);
    VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
    VAR27:=VAR25<=25 AND VAR26<-95 AND VAR1F>20 AND VAR1B<-30
    AND VAR1E<30 AND VAR25-CLOSE>=-0.25 AND VAR22<22
    AND VAR23<28 AND VAR24>50;
    RSV91:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
    中线:=SMA(RSV91,5,1),COLORLIMAGENTA,LINETHICK2;
    VARD图标:=STICKLINE(VARD,VAR04,短线,2.5,0),COLORGREEN;
    中线走势:=收盘<=(15)AND LONGCROSS(REF(收盘,0),REF(开盘,0),30);
    中线多头:DRAWTEXT(FILTERX(中线走势,30),6.58,'★中线多头')COLOR0099FF;
    VAR1控盘:=EMA(EMA(CLOSE,13),13);
    控盘:=(VAR1控盘-REF(VAR1控盘,1))/REF(VAR1控盘,1)*1000;
    控1:=STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
    控2:=STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
    无庄控盘:=控盘<0;
    控3:=STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
    有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
    VAR2控盘:=100*WINNER(CLOSE*0.95);
    控4:=STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
    主力出货:=控盘<REF(控盘,1) AND 控盘>0;
    控5:=STICKLINE(VAR2控盘>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
    高度控盘:=VAR2控盘>50 AND COST(85)<CLOSE AND 控盘>0,COLORMAGENTA,LINETHICK2;
    A101:=CROSS(控盘,0);
    控盘B:=FILTER(IF(A101,1,0),5);
    JJ:=DYNAINFO(11);
    P:=55;S:=8;M11:=3;
    财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
    神:=EMA(财,M11),COLORGREEN,LINETHICK1;
    控6:=DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50));
    BTJ1:=(C-JJ)/JJ<-0.03;
    BTJ11:=(C-JJ)/JJ<-0.03;
    BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
    STJ1:=(C-JJ)/JJ>0.005;
    STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
    STJ02:=控盘>0;
    BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
    BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
    BTJ3:=CROSS(财,神) AND  财<-0.3;
    BTJ32:=CROSS(财,神) AND  财<-0.1;
    STJ31:=CROSS(神,财);
    STJ32:=CROSS(神,财) AND  财>1.618;
    BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
    BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
    BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
    控7:=DRAWTEXT(BTJ81,神,'↑买底'),COLORRED;
    控8:=DRAWTEXT(BTJ811,神*1.2,'↑有庄'),COLORWHITE;
    STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
    STJ82:=FILTER(STJ02 AND STJ32 ,13);
    STJ83:=STJ81 AND STJ82;
    控9:=DRAWTEXT(STJ83,神,'↓卖'),COLOR00FF00;
    DIFF值:=(EMA(CLOSE,8) - EMA(CLOSE,55))*10,COLORRED;
    DEA值:=EMA(DIFF值,3),COLORGREEN;
    庄:=BTJ11 AND BTJ2 AND BTJ3;
    庄底:=FILTER(庄,55),COLORWHITE;
    买底:DRAWTEXT(FILTERX(BTJ811 AND BTJ81 AND 收盘<=(15),30),-6.58,'   庄底'),COLORLIMAGENTA;
    卖顶:DRAWTEXT(STJ81 AND STJ82 AND 收盘>=(85),105.58,'   庄顶'),COLORLIBLUE;
    庄底柱标1:=STICKLINE(买底,-12,-0.18,0.0001,1),COLORLIMAGENTA;
    庄顶柱标1:=STICKLINE(卖顶,112,100.18,0.001,1),COLORLIBLUE;
    庄底图标2:DRAWICON(买底,-6.58,17),COLORLIMAGENTA;
    庄顶图标2:DRAWICON(卖顶,105.58,17),COLORLIBLUE;
    成交量:=VOL,VOLSTICK,COLORLIBLUE;
    启动量05:=MA(成交量,05)COLORWHITE;
    洗盘量10:=MA(成交量,10)COLORYELLOW;
    异动量35:=MA(成交量,35)COLORMAGENTA;
    多头量1:DRAWTEXT(FILTERX(CROSS(REF(启动量05,0),REF(洗盘量10,1))AND 筹码<(0),18),-18,'●量金叉')COLORRED;
    多头量2:DRAWTEXT(FILTERX(CROSS(REF(洗盘量10,0),REF(异动量35,1))AND 筹码<(5),10),-18,'●量金叉')COLORYELLOW;
    空头量1:DRAWTEXT(FILTERX(CROSS(REF(洗盘量10,1),REF(启动量05,0))AND 筹码>(100),18),-18,'●量死叉')COLORLIBLUE;
    AT:=IF(CAPITAL=0,AMOUNT/100000000,VOL/CAPITAL*100);
    ATM1:=EMA(AT,5);
    ATM2:=MA(AT,13);
    阶段地量:=AT<REF(LLV(AT,25),1) && ATM1<ATM2;
    地量1:=STICKLINE(阶段地量,0,HHV(V,15),2.21,1),COLORGREEN;
    地量2:=STICKLINE(阶段地量,0,HHV(V,15),2.21,1),COLORGREEN;
    VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL)COLORWHITE,NODRAW;
    VVOL柱标:=STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLORLIBLUE;
    VAR2:=REF(LOW,1);
    VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
    VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
    VAR5:=LLV(LOW,38);
    VAR6:=HHV(VAR4,38);
    VAR7:=IF(LLV(LOW,90),1,0);
    VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
    DD:=VAR8>5;
    VAR1S:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2S:=SMA(ABS(LOW-VAR1S),13,1)/SMA(MAX(LOW-VAR1S,0),10,1);
    VAR3S:=EMA(VAR2S,10);
    VAR4S:=LLV(LOW,33);
    VAR5S:=EMA(IF(LOW<=VAR4S,VAR3S,0),3);
    主力进场:=IF(VAR5S>REF(VAR5S,1),VAR5S,0)*1.1,LINETHICK1,COLORRED;
    进场柱标:=STICKLINE(VAR5S>REF(VAR5S,1),0,VAR5S,1.80,1),COLORRED;
    震仓:=IF(VAR5S<REF(VAR5S,1),VAR5S,0),COLORGREEN;
    A:=(启动 CROSS 洗盘);
    AB:=(启动 CROSS 洗盘);
    BB2:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
    主动买:=IF(CLOSE>OPEN,BB2*(HIGH-LOW),IF(CLOSE<OPEN,BB2*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
    主买:主动买/10000,COLORRED,LINETHICK1,NODRAW;
    主动卖:=IF(CLOSE>OPEN,0-BB2*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB2*(HIGH-LOW),0-VOL/2));
    主卖:-主动卖/10000,COLORGREEN,LINETHICK1,NODRAW;
    参与:主买/(主买+主卖),NODRAW,COLORLIBLUE;
    盘比:(主买/主卖),NODRAW,COLORYELLOW;
    量比:DYNAINFO(17),NODRAW,COLORRED;
    买入:=IF((COUNT(DD,2)=2),-20,0)COLORBLACK;
    底:IF((CROSS(震仓,主力进场)AND 买入=-20),100,0),STICK,COLORMAGENTA,LINETHICK1;
    V1:=(C*3+H+L)/5*10;
    V2:=EMA(V1,13)-EMA(V1,34);
    V3:=EMA(V2,5);V4:=2*(V2-V3)*5.5;
    V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;V6:=EMA(3*V5-2*SMA(V5,18,1),5);
    V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;V8:=(INDEXC*2+INDEXH+INDEXL)/4;
    V9:=EMA(V8,13)-EMA(V8,34);
    VA:=EMA(V9,3);VB:=(V9-VA)/2;
    主力动向:=EMA(V4,2),COLORRED;
    机构动向:=EMA(VB,2),COLORMAGENTA;
    主力动向1:=(SLOPE(主力动向,2)>0 AND SLOPE(机构动向,2)>0,主力动向),COLORRED,LINETHICK1;
    主力动向2:=(SLOPE(主力动向,2)<0,主力动向),COLORGREEN,LINETHICK1;
    机构动向1:=(SLOPE(机构动向,2)>0 AND SLOPE(主力动向,2)>0,机构动向),COLORMAGENTA,LINETHICK1;
    机构动向2:=(SLOPE(机构动向,2)<0,机构动向),COLORWHITE,LINETHICK1;
    ZLCM:=EMA(WINNER(CLOSE)*70,3);
    SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
    ZZLKP:=ZLCM/(ZLCM+SHCM)*100;ZZLJJ:=EMA(ZZLKP,89);ZJLRQD:=ZZLKP-ZZLJJ;
    AAA:=EMA(ZJLRQD,1);BBB:=EMA(AAA,5);CCC:=AAA-BBB;
    CCC柱标1:=STICKLINE(CCC<REF(CCC,2),CCC,0,2,1), COLOR00FF00;
    CCC柱标2:=STICKLINE(CCC>REF(CCC,2),CCC,0,2,1), COLORRED;
    主力资金试盘:=IF(CROSS(AAA,BBB),3,0),STICK,LINETHICK4,COLOR0080FF;
    主力对倒出货:=IF(CROSS(BBB,AAA),-3,0),STICK,LINETHICK4,COLOR00FF00;
    VAR881:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR82:=SMA(ABS(LOW-VAR881),13,1)/SMA(MAX(LOW-VAR881,0),10,1);
    VAR83:=EMA(VAR82,10);
    VAR84:=LLV(LOW,33);
    VAR85:=EMA(IF(LOW<=VAR84,VAR83,0),5);
    惨跌柱标:STICKLINE(VAR85>REF(VAR85,1),0,VAR85,2,0),COLORGREEN;
    洗盘阴柱标:STICKLINE(VAR85<REF(VAR85,1) AND C<O,0,VAR85,2,0),COLORLIBLUE;
    主力拉升柱标:STICKLINE(VAR85<REF(VAR85,1),0,VAR85,2,0),COLORRED;
    庄出没:=惨跌柱标+洗盘阴柱标+主力拉升柱标;{下面手指主力动向之庄出没}
    {引入有庄控盘之金手指}
    VAR1G:=EMA(EMA(CLOSE,9),9);
    主力控盘:=(VAR1G-REF(VAR1G,1))/REF(VAR1G,1)*100;
    无庄:IF(主力控盘<0,主力控盘,0),COLORLIBLUE,NODRAW;
    无庄柱标:STICKLINE(主力控盘<0,主力控盘+100,100,1,1),COLORLIBLUE;
    A10:=CROSS(主力控盘,0);
    有庄:IF(A10,5,0),LINETHICK1,COLORMAGENTA;
    有庄图标:DRAWICON(A10 AND 筹码<(20),-6.5,11);{金手指出现}            
    初控:IF(主力控盘>REF(主力控盘,1) AND 主力控盘>0,主力控盘,0),COLOR0099FF,NODRAW;
    初控柱标:STICKLINE(主力控盘>REF(主力控盘,1) AND 主力控盘>0,主力控盘,0,1,1),COLOR0099FF;
    VAR2G:=100*WINNER(CLOSE*0.95);
    高控:IF(VAR2G>50 AND COST(85)<CLOSE AND 主力控盘>0,主力控盘,1),COLORRED,NODRAW;
    高控柱标:STICKLINE(VAR2G>50 AND COST(85)<CLOSE AND 主力控盘>0,主力控盘,0,1,1),COLORRED;
    出货:IF(主力控盘<REF(主力控盘,1) AND 主力控盘>0,主力控盘,0),COLORGREEN,NODRAW;
    出货柱标:STICKLINE(出货,(-出货+100),100,1,1),COLORGREEN;
    RSV999:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
    K1999:=SMA(RSV999,3,1);
    D1999:=SMA(K1999,3,1);
    KK999:=INTPART(K1999);
    DD999:=INTPART(D1999);
    风险系数:=KK999+DD999;{变异KD风险系数TFXXS}
    乖离系数:=(风险系数-REF(风险系数,1));{变异KD乖离系数TGLXS:资金流向}
    主力筹码:=EMA(WINNER(CLOSE)*70,3);{主力筹码估算ZLCM}
    散户筹码:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{散户筹码估算SHCM}
    散户套牢:=散户筹码/(主力筹码+散户筹码)*100;{散户套牢筹码系数ZSHTL}
    主力布控:=主力筹码/(主力筹码+散户筹码)*100;{主力控盘筹码系数ZZLKP}
    散户警戒:=EMA(散户套牢,55);{散户警戒ZSHJJ}
    主力警戒:=EMA(主力布控,55);{主力警戒ZZLJJ}
    散兵坑:=IF(主力布控<=10,主力布控,主力布控),COLORMAGENTA,NODRAW;
    散兵坑柱标:STICKLINE(主力布控<=10,-3,-0.08,1,0),{COLORDD00DD}COLOR0099FF;
    散兵坑过滤:=FILTERX(主力布控<=10,18)AND 筹码<(10);
    散兵坑字标:DRAWTEXT(散兵坑过滤,105.58,'“散兵坑”')COLOR0099FF;
    高山:112.98,COLOR4E2F2F;
    地界:-25.00,COLOR4E2F2F;
    零轴:0,COLOR4E2F2F;
    高点线:=80,COLORGREEN,DOTLINE;
    低点线:=20,COLORRED,DOTLINE;
    界轴:100,COLOR4E2F2F;
    辅助线1:=-10,COLORLICYAN;
    中轴:=50,DOTLINE,COLOR4E2F2F;
    D1:=1;
    AA1:=DRAWGBK(' “庄底”苹果 买股-“庄顶”苹果 卖股,-“有庄”下面"手指"“蓝三角"表示。','.','.','.','.','.');
    AA1字标:DRAWTEXT_FIX(D1=1,0,0.1350.18,0,AA1),COLORLIMAGENTA;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-17 13:33 复制 查看全部楼层
1
VAR01:=1;
    VAR02:=1/WINNER(CLOSE);
    VAR03:=MA(CLOSE,13);
    VAR04:=100-ABS((CLOSE-VAR03)/VAR03*100);
    VAR05:=LLV(LOW,75);
VAR06:=HHV(HIGH,75);
    VAR07:=(VAR06-VAR05)/100;
    VAR08:=SMA((CLOSE-VAR05)/VAR07,20,1);
    VARA:=3*VAR08-2*SMA(VAR08,15,1);
    主力中线筹码:=(100-VARA)*VAR01;
    中线筹码:=(REVERSE(主力中线筹码)+100);
    筹码:=MEMA(中线筹码,2);
筹码<0;

2
VAR1控盘:=EMA(EMA(CLOSE,13),13);
    控盘:=(VAR1控盘-REF(VAR1控盘,1))/REF(VAR1控盘,1)*1000;
    JJ:=DYNAINFO(11);
    P:=55;S:=8;M11:=3;
    财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10;
    神:=EMA(财,M11);
    BTJ11:=(C-JJ)/JJ<-0.03;
    BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
    BTJ3:=CROSS(财,神) AND  财<-0.3;
    BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
    BTJ811;

3,合并
VAR01:=1;
    VAR02:=1/WINNER(CLOSE);
    VAR03:=MA(CLOSE,13);
    VAR04:=100-ABS((CLOSE-VAR03)/VAR03*100);
    VAR05:=LLV(LOW,75);
VAR06:=HHV(HIGH,75);
    VAR07:=(VAR06-VAR05)/100;
    VAR08:=SMA((CLOSE-VAR05)/VAR07,20,1);
    VARA:=3*VAR08-2*SMA(VAR08,15,1);
    主力中线筹码:=(100-VARA)*VAR01;
    中线筹码:=(REVERSE(主力中线筹码)+100);
    筹码:=MEMA(中线筹码,2);
VAR1控盘:=EMA(EMA(CLOSE,13),13);
    控盘:=(VAR1控盘-REF(VAR1控盘,1))/REF(VAR1控盘,1)*1000;
    JJ:=DYNAINFO(11);
    P:=55;S:=8;M11:=3;
    财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10;
    神:=EMA(财,M11);
    BTJ11:=(C-JJ)/JJ<-0.03;
    BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
    BTJ3:=CROSS(财,神) AND  财<-0.3;
    BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
    BTJ811&&筹码<0;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表