请老师帮忙看下通达信副图指标窗口被压扁

[通达信]
设置
1909 10 元煜999 Lv.2 发表于 · 2020-11-28 08:43 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
从飞狐指标复制过来的一个指标公式,但是到了通达信之后窗口被压扁了,请各前老师帮忙看下,感谢!
N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*100,COLORWHITE;
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSI2:=SMA(MAX(CLOSE-LC,0),N1*2,1)/SMA(ABS(CLOSE-LC),N1*2,1)*100,COLORAAAA00;
PLOYLINE(RSI1<50,RSI1),LINETHICK2;
短趋势:=EMA(RSI,N1/3);
中趋势:EMA(RSI1,N1/2);
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:=REF(RSI1,BARSLAST(D1)),COLORFF00FF,LINETHICK;
下:=REF(RSI1,BARSLAST(D2)),COLOR00FF00,LINETHICK;
向上:CROSS(RSI1,上*1.01),LINETHICK;
相对能量:=(RSI1-(上+下)/2)/(上+下)/2*100,LINETHICK;
STICKLINE(相对能量>0,50,相对能量+50,2,0),COLORRED;
STICKLINE(相对能量<0,50,相对能量+50,2,0),COLORCYAN;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
STICKLINE(C>0,下,下,1,0),COLOR00FF00;
STICKLINE(C>0,上,上,1,0),COLORFF00FF;
DRAWTEXT(CROSS(RSI1,H*1.01),上,'★');
DRAWTEXT(CROSS(L*0.99,RSI1),下,'★');

DRAWICON(D1,RSI1,2);
DRAWICON(D2,RSI1,1);
20;50;80;

附件

001.jpg

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-30 11:59 复制 查看全部楼层

RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:=SMA(K4,3,1);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
加仓:FILTER((VAR4AA>90),35);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-30 11:58 复制 查看全部楼层
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
鼠波段入:CROSS(D1,K1);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-30 11:55 复制 查看全部楼层
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
牛起步:CROSS(V1,V2);
查看全部打赏
  • 元煜999+10理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。

举报

扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-30 09:17 复制 查看全部楼层
许昌舍得 发表于 2020-11-28 09:25
N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*10 ...

您好许老师:
请在帮忙写下选股公式:谢谢许老师

1:牛起步
2:鼠波段入
3:★加仓

源码:

MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORYELLOW;
MA22:MA(C,22),COLORFF00FF;
MA66:MA(C,66);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
低吸:=CROSS(RSI,11);
DRAWTEXT(低吸,L,'★'),COLORWHITE;
DRAWTEXT(低吸,L-0.05,'鼠吸'),COLORWHITE;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORFF00FF;
DRAWTEXT(FILTER(VARB,6),L-0.05,'坚决买进'),COLORFF00FF;
DRAWTEXT(FILTER(VARB,6),L,'★'),COLORFF00FF;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L,'★'),COLORYELLOW;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L-0.05,'鼠出击'),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠仓,L*0.99,'老鼠仓'),COLOR0099FF;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
DRAWTEXT(CROSS(D1,K1),L-0.20,'鼠波段入'),COLORRED;
{DRAWTEXT(CROSS(D1,K1),L,'★'),COLOR0099FF;}
多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
天线:=78.89;
STICKLINE(CROSS(天线,多方趋势),H*1.02,H*1.00,6,0),COLOR00FF00;
DRAWTEXT(CROSS(天线,多方趋势),H*1.04,'鼠逃顶'),COLOR00FF00;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:=SMA(K4,3,1);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLORFF00FF;
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
准备资金:=趋势<13;
开始建仓:=趋势<13 AND VV4>13;
VA1:=(CLOSE*2+HIGH+LOW)/4*10;
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA14:=VA2-VA3;
VA15:=EMA(VA14,5);
VA16:=2*(VA14-VA15)*5.5;
AAA:=VA16>=0 AND 趋势<13;
主力进场:=FILTER(AAA,5);
转折:=REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1);
共振抄底:=EXIST(开始建仓,3) AND EXIST(主力进场,1) AND 中期波段>REF(中期波段,1);
短线波段:=(EXIST(转折,2) AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1));
WWWCHNMONEYCOM:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
ZT:=C>REF(C,1)*1.095;
DRAWTEXT(共振抄底,LOW-0.05,'鼠抄底'),COLORRED;
DRAWTEXT(FILTER(短线波段,3),LOW,'鼠'),COLORYELLOW;
DRAWTEXT(主力进场,LOW-0.05,'鼠庄进'),COLORFF00FF;

举报

点亮(1) 扔鸡蛋(0) 回复

刚刚干活
Lv.2
发表于 2020-11-29 09:18 复制 查看全部楼层
这个指标带未来函数啊。

举报

扔鸡蛋(0) 回复

元煜999
Lv.2
发表于 2020-11-28 15:21 复制 查看全部楼层

是的,就是这样,衷心感谢@许昌舍得 老师!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-28 11:37 复制 查看全部楼层
元煜999 发表于 2020-11-28 10:20
抱歉第一次发贴求助,不太熟悉操作,理想币共享币不太清楚,点少了


再试试指标


N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*100,COLORWHITE;
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSI2:=SMA(MAX(CLOSE-LC,0),N1*2,1)/SMA(ABS(CLOSE-LC),N1*2,1)*100,COLORAAAA00;
TJ1:=PLOYLINE(RSI1<50,RSI1),LINETHICK2;
短趋势:=EMA(RSI,N1/3);
中趋势:EMA(RSI1,N1/2),NODRAW;
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:=REF(RSI1,BARSLAST(D1)),COLORFF00FF,LINETHICK;
下:=REF(RSI1,BARSLAST(D2)),COLOR00FF00,LINETHICK;
向上:CROSS(RSI1,上*1.01),LINETHICK,NODRAW;
相对能量:=(RSI1-(上+下)/2)/(上+下)/2*100,LINETHICK;
STICKLINE(相对能量>0,50,相对能量+50,2,0),COLORRED;
STICKLINE(相对能量<0,50,相对能量+50,2,0),COLORCYAN;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
STICKLINE(C>0,下,下,1,0),COLOR00FF00;
STICKLINE(C>0,上,上,1,0),COLORFF00FF;
DRAWTEXT(CROSS(RSI1,H*1.01),上,'★');
DRAWTEXT(CROSS(L*0.99,RSI1),下,'★');

DRAWICON(D1,RSI1,2);
DRAWICON(D2,RSI1,1);
{20;50;80;};

附件

tdxjietu1.JPG
查看全部打赏
  • 元煜999+10理想币 +2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

元煜999
Lv.2
发表于 2020-11-28 10:20 复制 查看全部楼层
许昌舍得 发表于 2020-11-28 09:25
N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*10 ...

抱歉第一次发贴求助,不太熟悉操作,理想币共享币不太清楚,点少了

举报

点亮(0) 扔鸡蛋(0) 回复

元煜999
Lv.2
发表于 2020-11-28 10:08 复制 查看全部楼层
许昌舍得 发表于 2020-11-28 09:25
N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*10 ...

感谢@许昌舍得 老师!

我这里还是有点压缩,请教是否指标坐标什么的造成的?缩放整个窗口后发现左下有很大一块,相对要显示的右侧框选区域,这一块在下方占很大比例,也许是这里造成的?     

舍得老师您选的一个股可能刚好是比较正常,而我看的这个股,这个指标在隐藏的下方(或者上方)还有看不见的一块存在,那么这样的话,就是想要指标显示区域自动占满整个窗口,而不受未显示区域的影响。   我个人觉得很有可能是这个原因

附件

002.jpg
002.png

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-28 09:25 复制 查看全部楼层

N1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*100,COLORWHITE;
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSI2:=SMA(MAX(CLOSE-LC,0),N1*2,1)/SMA(ABS(CLOSE-LC),N1*2,1)*100,COLORAAAA00;
TJ1:=PLOYLINE(RSI1<50,RSI1),LINETHICK2;
短趋势:=EMA(RSI,N1/3);
中趋势:EMA(RSI1,N1/2);
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:=REF(RSI1,BARSLAST(D1)),COLORFF00FF,LINETHICK;
下:=REF(RSI1,BARSLAST(D2)),COLOR00FF00,LINETHICK;
向上:CROSS(RSI1,上*1.01),LINETHICK;
相对能量:=(RSI1-(上+下)/2)/(上+下)/2*100,LINETHICK;
STICKLINE(相对能量>0,50,相对能量+50,2,0),COLORRED;
STICKLINE(相对能量<0,50,相对能量+50,2,0),COLORCYAN;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
STICKLINE(C>0,下,下,1,0),COLOR00FF00;
STICKLINE(C>0,上,上,1,0),COLORFF00FF;
DRAWTEXT(CROSS(RSI1,H*1.01),上,'★');
DRAWTEXT(CROSS(L*0.99,RSI1),下,'★');

DRAWICON(D1,RSI1,2);
DRAWICON(D2,RSI1,1);
{20;50;80;}

附件

tdxjietu3.JPG
查看全部打赏

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表