【送 送】需要拿去

[通达信]
设置
11734 22 李老大2011 Lv.4 发表于 · 2021-1-21 09:15 显示全部楼层 正序浏览 |
跳转到指定楼层
别人的,加了一些内容,送给需要的人。
图1  S仪表K线指标(主图):

DRAWGBK(C>0, RGB(0,0,50),RGB(00,0,0),0,0,1);
DRAWKLINE(H,O,L,C);
买线:=EMA(C,3);
卖线:=EMA(SLOPE(C,25)*18+C,55);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);

ISDOWN:=IF(CLOSE<OPEN,1,0);
ISUP:=IF(CLOSE>OPEN,1,0);
STICKLINE(买线<卖线 AND ISDOWN,HIGH,OPEN,0,0),COLORCYAN;
STICKLINE(买线<卖线 AND ISDOWN,CLOSE,OPEN,3,0),COLORCYAN;
STICKLINE(买线<卖线 AND ISDOWN,CLOSE,LOW,0,0),COLORCYAN;
STICKLINE(买线>=卖线 AND ISUP,HIGH,CLOSE,0,1),COLORRED;
STICKLINE(买线>=卖线 AND ISUP,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(买线>=卖线 AND ISUP,OPEN,LOW,0,1),COLORRED;
STICKLINE(买线>=卖线 AND ISDOWN,CLOSE,LOW,0,0),COLORRED;
STICKLINE(买线>=卖线 AND ISDOWN,HIGH,OPEN,0,0),COLORRED;
STICKLINE(买线>=卖线 AND ISDOWN,CLOSE,OPEN,3,1),COLORRED,LINETHICK2;
STICKLINE(买线>=卖线 AND ISDOWN,CLOSE*1.0018,OPEN*0.9988,1.8,0),COLORCYAN;
STICKLINE(买线<卖线 AND ISUP,HIGH,CLOSE,0,1),COLORCYAN;
STICKLINE(买线<卖线 AND ISUP,CLOSE,OPEN,3,1),COLORCYAN;
STICKLINE(买线<卖线 AND ISUP,OPEN,LOW,0,1),COLORCYAN;

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,13),LINETHICK2;
MA3:MA(CLOSE,21);
MA4:MA(CLOSE,62),LINETHICK2;
MA120:MA(CLOSE,120);
MA6:MA(CLOSE,250);
DRAWBMP(BU=1,L,'B');
DRAWBMP(SEL=1,HIGH*1.038,'S');

{======================================================}
显示仪表盘1:=1;
总涨幅周期:=350;
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:=MA(C,5),COLORCYAN,LINETHICK2;
MA24:=MA(C,24),COLORGREEN,LINETHICK2;
MA72:=MA(C,72),COLORRED,LINETHICK2;
MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;
{=======================仪表盘=========================}
主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);
初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;
底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;
探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;
观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);
有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);
放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);
DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0)COLOR00BF00;
DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0)COLORFF00FF;
DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0)COLORFF8080;
DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0)COLOR009500;
DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0)COLOR00BF00;
{======================================================}
高点位:=REFDATE(HHV(H,总涨幅周期),DATE);
低点位:=REFDATE(LLV(L,总涨幅周期),DATE);
低位价:=REF(L,BARSLAST(低点位=L)),COLORGREEN,NODRAW;
高位价:=REF(H,BARSLAST(高点位=H)),COLORRED,NODRAW;
曾最大涨幅:=(高位价-低位价)/低位价*100;
当前涨幅:=(C-低位价)/低位价*100;
ZFA:=CON2STR(CONST(曾最大涨幅),2);
ZFB:=CON2STR(CONST(当前涨幅),2);
ZFC:=STRCAT('【曾最大涨幅】:',ZFA);
ZFD:=STRCAT(ZFC,'%');
ZFE:=STRCAT(ZFD,'【当前总涨幅】:');
ZFF:=STRCAT(ZFE,ZFB);
ZFG:=STRCAT(ZFF,'%');
DRAWTEXT_FIX(ISLASTBAR,0,1,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,1,0,ZFG),COLORYELLOW;
{========================额外==========================}
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
Z4:=STRCAT(Z3,GNBLOCK);
Z5:=STRCAT(Z4,' ');
Z6:=STRCAT(Z5,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.012,0,STRCAT(Z6,ZHBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0,0.075,0,STRCAT('【自定板块】:',ZDBLOCK)),COLORYELLOW;
{======================================================}
DRAWRECTREL(IF(CODELIKE('999999') OR CODELIKE('399001'),0,760),IF(CODELIKE('999999') OR CODELIKE('399001'),0,12),IF(CODELIKE('999999') OR CODELIKE('399001'),0,890),IF(CODELIKE('999999') OR CODELIKE('399001'),0,70),RGB(255,0,0));
DRAWRECTREL(IF(CODELIKE('999999') OR CODELIKE('399001'),0,760),IF(CODELIKE('999999') OR CODELIKE('399001'),0,12),IF(CODELIKE('999999') OR CODELIKE('399001'),0,890),IF(CODELIKE('999999') OR CODELIKE('399001'),0,70),IF(CONST(DYNAINFO(51))>=1,RGB(0,255,0),RGB(255,0,0)));
NNN1:=CON2STR(CONST(DYNAINFO(51)),2);
NNN2:=STRCAT('【 内外比:',NNN1);
NNN3:=STRCAT(NNN2,' 】');
DRAWTEXT_FIX(IF(CODELIKE('999999') OR CODELIKE('399001'),DRAWNULL,1),0.76,0.015,0,NNN3),COLORYELLOW;
DRAWTEXT_FIX(IF(CODELIKE('999999') OR CODELIKE('399001'),DRAWNULL,CONST(DYNAINFO(51))>=1),0.76,0.015,0,NNN3),COLORBLACK;
{=======================均线解盘===============================}
DRAWRECTREL(0,IF(显示仪表盘1=0,135,0),IF(显示仪表盘1=0,288,0),IF(显示仪表盘1=0,630,0),RGB(0,0,255));
DRAWTEXT_FIX(显示仪表盘1=0,0.08,0.16,0,'【 均线解盘 】'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.23,0,'主升浪: 5>24>72>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>MA200,0.238,0.23,0,'≡★≡'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.285,0,'主浪回调: 24>5>72>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>MA200,0.238,0.285,0,'≡★≡'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.34,0,'主浪深调: 24>72>5>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>MA200,0.238,0.34,0,'≡★≡'),COLORMAGENTA;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.395,0,'初升浪: 200>5>24>72'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72,0.238,0.395,0,'≡★≡'),COLOR0080FF;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.45,0,'底部反弹: 200>72>5>24'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MA72 AND MA72>MA24 AND MA5>MA24,0.238,0.45,0,'≡★≡'),COLORYELLOW;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.51,0,'探底阶段: 200>72>24>5'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MA72 AND MA72>MA24 AND MA24>MA5,0.238,0.51,0,'≡★≡'),COLORGREEN;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C>=MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C>=MA200,0,0.565,0,'牛市行情: 72>200 C>200 牛市 ---'),COLORYELLOW;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C<MA200,0,0.565,0,'未知行情: 72>200 C<200 观望 ---'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C>=MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORMAGENTA;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C>=MA200,0,0.565,0,'初入牛市: 72<200 C>200 牛到 ---'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C<MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORGREEN;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C<MA200,0,0.565,0,'熊市行情: 72<200 C<200 放弃 ---'),COLORBLACK;


图2  BS仪表K线指标需要下载仪表公式压缩包。
下载后解压放在通达信文件里的T0002文件里的signals里即可。

附件

没有图标.png
有图标.png
仪表公式图.rar

74.43 KB, 下载次数: 51, 下载积分: 分享值 -2 个

举报

扔鸡蛋(0) 回复

时主
Lv.5
发表于 2021-1-22 22:39 复制 查看全部楼层
谢谢分享,辛苦了!

举报

扔鸡蛋(0) 回复

万龙
Lv.2
发表于 2021-1-22 21:14 复制 查看全部楼层
       
谢谢分享,辛苦了!

举报

扔鸡蛋(0) 回复

幽兰花儿
Lv.4
发表于 2021-1-22 12:40 复制 查看全部楼层
谢谢分享,精彩!

举报

扔鸡蛋(0) 回复

凡人119
Lv.5
发表于 2021-1-22 08:39 复制 查看全部楼层
源码分享,

举报

扔鸡蛋(0) 回复

金色218
Lv.2
发表于 2021-1-22 08:07 复制 查看全部楼层
没有分享值了,先收藏,过两天再下载,谢谢楼主,先为你点赞。

举报

点亮(2) 扔鸡蛋(0) 回复

唐qiuguo
Lv.3
发表于 2021-1-22 00:34 复制 查看全部楼层
这个应该好玩!

举报

扔鸡蛋(0) 回复

丛林法则
Lv.4
发表于 2021-1-22 00:25 复制 查看全部楼层
支持理想论坛!谢谢分享,辛苦了!

举报

扔鸡蛋(0) 回复

考勤门禁
Lv.2
发表于 2021-1-21 23:40 复制 查看全部楼层
谢谢分享拿来看看好使不

举报

扔鸡蛋(0) 回复

一种境界
Lv.2
发表于 2021-1-21 23:17 复制 查看全部楼层
拿来看看好使不

举报

扔鸡蛋(0) 回复

刘琦999999
Lv.2
发表于 2021-1-21 22:33 复制 查看全部楼层
谢谢分享,辛苦了!

举报

扔鸡蛋(0) 回复

稳稳慢牛
Lv.0
发表于 2021-1-21 19:56 复制 查看全部楼层
支持理想论坛!谢谢分享,辛苦了!

举报

扔鸡蛋(0) 回复

天雪0088
Lv.5
发表于 2021-1-21 16:06 复制 查看全部楼层
互助分享,人人分享,人人受益

举报

扔鸡蛋(0) 回复

冬季123321
Lv.5
发表于 2021-1-21 13:08 复制 查看全部楼层
有实战意义的指标  谢谢老师分享

举报

扔鸡蛋(0) 回复

王国栋
Lv.4
发表于 2021-1-21 12:54 复制 查看全部楼层
不显示仪表盘哎,要不要建个自定义数据?

举报

扔鸡蛋(0) 回复

雁过留香
Lv.3
发表于 2021-1-21 12:05 复制 查看全部楼层
为了让分享能够坚持下去,提倡互助分享,人人分享,人人受益,支持理想论坛!

举报

扔鸡蛋(0) 回复

於意云何
Lv.4
发表于 2021-1-21 11:45 复制 查看全部楼层
非常感谢 以前一个集成的里面有了  感谢一下

举报

点亮(2) 扔鸡蛋(0) 回复

气垫
Lv.6
发表于 2021-1-21 11:43 复制 查看全部楼层
谢谢楼主   给你点赞      互助捧场

举报

扔鸡蛋(0) 回复

个新股民
Lv.1
发表于 2021-1-21 09:20 复制 查看全部楼层
那些即使遇到了相会,还不敢自信必能成功的人,只能得到失败。

举报

点亮(6) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表