请老师帮忙改一下指标

[通达信]
设置
2116 2 小占占 Lv.3 发表于 · 2021-1-22 02:01 显示全部楼层 正序浏览 |
跳转到指定楼层
总家数:INDEXADV+INDEXDEC,NODRAW;
涨家数:INDEXADV,NODRAW;
跌家数:INDEXDEC,NODRAW;

差数:INDEXADV-INDEXDEC,NODRAW;
涨停数:"880006$C",NODRAW;
跌停数:"880006$O",NODRAW;
STICKLINE(差数>0,0,差数,3,0),COLORYELLOW;
STICKLINE(差数<0,0,差数,3,0),COLOR00FF00;
MM:=SUM(差数,15),COLOR0000FF;
M1:=SMA(MM,3,1);
M2:=SMA(M1,3,1);
M3:=SMA(M2,3,1),LINETHICK2;  
STICKLINE(差数>0&&差数>总家数*0.6,0,差数,3,0),COLOR0000FF;
STICKLINE(差数<0&&差数<总家数*-0.6,0,差数,3,0),COLORBLUE;


      增加一些功能:当大盘下跌时向上的柱子变成绿心,当大盘上涨时,向下的柱子变成红心。如果大盘上涨同时柱子也向上,就不用变化,维持原样。当大盘下跌

      时,柱子也向下,也不用变化维持原样。      谢谢老师相助。

举报

扔鸡蛋(0) 回复

小占占
Lv.3
发表于 2021-1-22 20:39 复制 查看全部楼层
本帖最后由 小占占 于 2021-1-22 21:14 编辑
闹海老龙神 发表于 2021-1-22 09:22
{供参考}
总家数:INDEXADV+INDEXDEC,NODRAW;
涨家数:INDEXADV,NODRAW;


谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

闹海老龙神
Lv.5
发表于 2021-1-22 09:22 复制 查看全部楼层
{供参考}
总家数:INDEXADV+INDEXDEC,NODRAW;
涨家数:INDEXADV,NODRAW;
跌家数:INDEXDEC,NODRAW;
涨跌幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,NODRAW;

差数:INDEXADV-INDEXDEC,NODRAW;
涨停数:"880006$C",NODRAW;
跌停数:"880006$O",NODRAW;
STICKLINE(差数>0,0,差数,3,0),COLORYELLOW;
STICKLINE(差数<0,0,差数,3,0),COLOR00FF00;
MM:=SUM(差数,15),COLOR0000FF;
M1:=SMA(MM,3,1);
M2:=SMA(M1,3,1);
M3:=SMA(M2,3,1),LINETHICK2;  
STICKLINE(差数>0&&差数>总家数*0.6,0,差数,3,0),COLOR0000FF;
STICKLINE(差数<0&&差数<总家数*-0.6,0,差数,3,0),COLORBLUE;

STICKLINE(涨跌幅<0 AND 差数>0,0,差数/2,2,0),COLORGREEN;
STICKLINE(涨跌幅>0 AND 差数<0,0,差数/2,2,0),COLORRED;
查看全部打赏
  • 小占占+40理想币 共享币 +4分享值 : 很给力,投资愉快,理想因你而精彩;
  • 福阿德+8理想币 +7共享币 分享值 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表