请老师帮助将通达信转大智慧改下这个公式

[大智慧]
设置
1532 5 耕金老牛 Lv.3 发表于 · 2021-1-24 23:40 显示全部楼层 正序浏览 |
跳转到指定楼层
VAR11:=1;
VAR12:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR14:=LLV(LOW,5);
VAR15:=HHV(HIGH,4);
C1:=(EMA((((VAR12-VAR14)/(VAR15-VAR14))*100),4)*VAR11),COLORRED,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR11),COLORFFFFFF,LINETHICK2;
AA:=C1>=C2 ;
BB:=C2>C1 ;
DRAWICON(CROSS(C1,C2),L-0.1,1);
DRAWICON(CROSS(C2,C1),H+0.1,2);
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0.5,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0.5,0),COLOR00FF00;
{红}
STICKLINE(AA,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(BB,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
{理想论坛-股票公式网站 ■■■}
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORRED;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0),NODRAW;
TJ2:=IF(BARSLAST(立桩量)=1 ,1,0);
STICKLINE(立桩量 !=1,REF(HIGH,BARSLAST(立桩量)),
REF(HIGH,BARSLAST(立桩量)),1,1),COLORCYAN;
{STICKLINE(立桩量 !=1,REF(LOW,BARSLAST(立桩量)),
REF(LOW,BARSLAST(立桩量)),1,1),COLORCYAN;}
成立1:=TJ2=1;
条件成立1:=FILTER(成立1,5);
DRAWTEXT(条件成立1, REF(HIGH,BARSLAST(立桩量)),'看跌'),COLORLIBLUE;
TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0),NODRAW;
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量2)),
REF(HIGH,BARSLAST(立桩量2)),1,1),COLORYELLOW;}
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量2)),
REF(LOW,BARSLAST(立桩量2)),1,1),COLORYELLOW;
TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
条件成立2:=FILTER(成立2,5);
DRAWTEXT(条件成立2,REF(LOW,BARSLAST(立桩量2)),'看涨'),COLORLIMAGENTA;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立桩量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
成立:=TJ3=1;
条件成立:=FILTER(成立,5);
DRAWTEXT(条件成立 AND 下跌!= VAR6,L*0.97,'☆成立');
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),BBF,'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;
STICKLINE(1,C,O,2.8,0),COLOR666600;
STICKLINE(立桩量,C,O,2.8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORCCCCCC;

举报

扔鸡蛋(0) 回复

耕金老牛
Lv.3
发表于 2021-1-26 22:19 复制 查看全部楼层
VAR11:=1;
VAR12:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR14:=LLV(LOW,5);
VAR15:=HHV(HIGH,4);
C1:=(EMA((((VAR12-VAR14)/(VAR15-VAR14))*100),4)*VAR11);
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR11);
AA:=C1>=C2 ;
BB:=C2>C1 ;

AAF:=LLV(LOW,34);
BBF:=MA(AAF,4);
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1);
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2);
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3);
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4);
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5);
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:=VAR1;
中线:=VAR6;
下跌:=IF(VAR1=VAR6,VAR6, 0);
TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0);
TJ2:=IF(BARSLAST(立桩量)=1 ,1,0);

成立1:=TJ2=1;
条件成立1:=FILTER(成立1,5);

TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0);
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;

TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
条件成立2:=FILTER(成立2,5);

TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立桩量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
成立:=TJ3=1;
条件成立:=FILTER(成立,5);

LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);


X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);

XG:CROSS(88,RSI) or (条件成立1, REF(HIGH,BARSLAST(立桩量)));
通达信可以大智慧不行    这句(条件成立1, REF(HIGH,BARSLAST(立桩量)))说语法错误怎么改啊

举报

点亮(0) 扔鸡蛋(0) 回复

一不做
Lv.4
发表于 2021-1-25 16:33 复制 查看全部楼层
这是主图还是副图?请问

举报

扔鸡蛋(0) 回复

耕金老牛
Lv.3
发表于 2021-1-25 13:42 复制 查看全部楼层
大智慧和通达信真的各有千秋 这个公式在通达信很流畅 在大智慧用就卡成狗狗了 哈哈哈

举报

点亮(0) 扔鸡蛋(0) 回复

耕金老牛
Lv.3
发表于 2021-1-25 13:24 复制 查看全部楼层
非常感谢 恭祝股市长红

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2021-1-25 08:36 复制 查看全部楼层
VAR11:=1;
VAR12:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR14:=LLV(LOW,5);
VAR15:=HHV(HIGH,4);
C1:=(EMA((((VAR12-VAR14)/(VAR15-VAR14))*100),4)*VAR11) ;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR11) ;
AA:=C1>=C2 ;
BB:=C2>C1 ;
DRAWICON(CROSS(C1,C2),L-0.1,1);
DRAWICON(CROSS(C2,C1),H+0.1,2);
STICKLINE(AA,C,O,8,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,8,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
{红}
STICKLINE(AA,CLOSE,OPEN,8,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,6,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,4,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,2,0),COLORCC66FF;
{蓝}
STICKLINE(BB,CLOSE,OPEN,8,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,6,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,4,0),COLORFFBB00;
STICKLINE(BB,CLOSE,OPEN,2,0),COLORCYAN;
{理想论坛-股票公式网站 ■■■}
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1) ;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2) ;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3) ;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4) ;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5) ;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORRED;
下跌:=IF(VAR1=VAR6,VAR6,0);
TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0) ;
TJ2:=IF(BARSLAST(立桩量)=1 ,1,0);
{STICKLINE(立桩量<>1,REF(HIGH,BARSLAST(立桩量)),
REF(HIGH,BARSLAST(立桩量)),1,1),COLORCYAN;}
{STICKLINE(立桩量 !=1,REF(LOW,BARSLAST(立桩量)),
REF(LOW,BARSLAST(立桩量)),1,1),COLORCYAN;}
成立1:=TJ2=1;
条件成立1:=FILTER(成立1,5);
DRAWTEXT(条件成立1, REF(HIGH,BARSLAST(立桩量)),'看跌'),COLOR00FA9A;
TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0);
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量2)),
REF(HIGH,BARSLAST(立桩量2)),1,1),COLORYELLOW;}
{STICKLINE(CLOSE AND 下跌<>VAR6,REF(LOW,BARSLAST(立桩量2)),
REF(LOW,BARSLAST(立桩量2)),1,1),COLORYELLOW;}
TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
条件成立2:=FILTER(成立2,5);
DRAWTEXT(条件成立2,REF(LOW,BARSLAST(立桩量2)),'看涨'),COLORFF69B4;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立桩量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
成立:=TJ3=1;
条件成立:=FILTER(成立,5);
DRAWTEXT(条件成立 AND 下跌<>VAR6,L*0.97,'☆成立');
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),BBF,'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;
{STICKLINE(1,C,O,8,0),COLOR666600;
STICKLINE(立桩量,C,O,8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORCCCCCC;};
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表