请老师帮忙做个选股公式

[通达信]
设置
1209 2 小斌仔王智勃 Lv.2 发表于 · 2021-2-22 12:18 显示全部楼层 正序浏览 |
跳转到指定楼层
需求:选出0轴上方的紫色柱
公式源码:
RSVCC:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;

STICKLINE( RSVCC>0,60,0,8,0),COLOR880022;

STICKLINE( RSVCC>0,-40,0,8,0),COLOR003300;

LC:=REF(CLOSE,1);

RS1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100-50;

WR10:=100*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))-50;

TB:=MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1));

MD:=MA(RS1,6),COLOR0000FF,NODRAW;

0,COLORWHITE;

STICKLINE(-25,-25,-25,5,1),COLORWHITE;

STICKLINE(25,25,25,5,1),COLORWHITE;

RSI:RS1,COLORLIRED;

MR:MD,COLORGRAY,LINETHICK1;

IF(MR>REF(MR,1) OR RSI>MR,MR,DRAWNULL),COLORRED,LINETHICK1;

活跃:=(RS1-WR10)/4,NODRAW;

饱和:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

STICKLINE(活跃>0,0,活跃,0,1),COLORFF00FF;

STICKLINE(活跃<0,0,活跃,0,1),COLORBROWN;

STICKLINE(活跃>17 AND 活跃<19.5,0,活跃,0,1)COLOR858500;

STICKLINE(活跃>19.5,0,活跃,0,1),COLORBLUE;

活跃度:活跃,COLORLIMAGENTA,NODRAW;

饱和度:饱和,COLORBLACK,NODRAW;

STICKLINE(饱和度=100,0,-2,2,1),COLORLIBLUE;

{图示}

买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20+C,42);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

DRAWICON(BU,L-0.1,1);

DRAWICON(SEL,H+0.1,2);

VM:=MA(RS1,5),COLORFF00FF,NODRAW;

DRAWTEXT(ISLASTBAR AND RSI>REF(RSI,1),0, '▲'),COLORDD00FF;

DRAWTEXT(ISLASTBAR AND RSI<REF(RSI,1),0, '▼'),COLORBLUE;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2021-2-22 13:25 复制 查看全部楼层

LC:=REF(CLOSE,1);

RS1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100-50;

WR10:=100*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))-50;



MD:=MA(RS1,6);
RSI:=RS1,COLORLIRED;




活跃:=(RS1-WR10)/4;



XG:活跃>0;
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

闹海老龙神
Lv.5
发表于 2021-2-22 13:21 复制 查看全部楼层
{供参考}
LC:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100-50;
WR10:=100*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))-50;
活跃:=(RS1-WR10)/4;

选股:活跃>0;
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表