老师,帮忙编写一个macd上kdj的j值在同一个指标公式中

[通达信]
设置
1245 2 李好要2008 Lv.2 发表于 · 2021-2-22 12:40 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 李好要2008 于 2021-2-22 13:10 编辑

老师,帮忙编写一个macd上kdj的j值在同一个指标公式中,只显示有j 值,不显示K和D值。谢谢
1122.JPG
11111.jpg

举报

扔鸡蛋(0) 回复

李好要2008
Lv.2
发表于 2021-2-22 14:51 复制 查看全部楼层
谢谢老师,非常感谢

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2021-2-22 14:22 复制 查看全部楼层
用压缩比例把两图放到一个页面,历史图形可能会与现在不一样,用沙盘推演观察下:
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
JJ:=3*K-2*D;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACDD:(DIF-DEA)*2,COLORSTICK;
倍数:=CONST(HHV(JJ,0)-LLV(JJ,0))/CONST(MAX(HHV(DIF,0),MAX(DEA,MACDD))-MIN(LLV(DIF,0),MIN(DEA,MACDD)));
差值:=CONST(LLV(JJ/倍数,0)-MIN(LLV(DIF,0),MIN(DEA,MACDD)));
J:JJ/倍数-差值,COLORGRAY,LINETHICK2;
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表