请老师帮助在MACD绿柱选出第二个指标

[通达信]
设置
1458 3 心只有你 Lv.5 发表于 · 2021-2-22 16:42 显示全部楼层 正序浏览 |
跳转到指定楼层
请在MACD绿柱的范围内,选出第二次绿柱由长变短的信号。

附件

股票信号.png

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2021-2-22 17:59 复制 查看全部楼层
心只有你 发表于 2021-2-22 17:10
谢谢,但指标选出的是第一个信号,我要的是第二个信号。

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
零下一:=FILTERX(MACD<0 AND MACD=LLV(MACD,BARSLAST(MACD>0)),BARSLAST(MACD>0));
拐点:=MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2);
零下一天数:=BARSLAST(零下一);
零下二:CROSS(SUM(拐点 AND 零下一天数>3,零下一天数)=1 AND SUM(MACD<0,零下一天数)=零下一天数,0.5);
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

点亮(0) 扔鸡蛋(0) 回复

心只有你
Lv.5
发表于 2021-2-22 17:10 复制 查看全部楼层
休闲者68 发表于 2021-2-22 16:59
BARSLASTCOUNT(REF(MACD.MACDREF(MACD.MACD,1);

谢谢,但指标选出的是第一个信号,我要的是第二个信号。

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2021-2-22 16:59 复制 查看全部楼层
BARSLASTCOUNT(REF(MACD.MACD<REF(MACD.MACD,1) AND MACD.MACD<0,1))>3 AND  MACD.MACD>REF(MACD.MACD,1);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表