请老师帮忙做个选出黄色线下的红色和黄色柱子选股公式

[通达信]
设置
988 1 小斌仔王智勃 Lv.2 发表于 · 2021-2-22 18:05 显示全部楼层 正序浏览 |
跳转到指定楼层
需求:选出黄色线下的红色和黄色柱子(如图)
公式源码:
VARA:=XMA(XMA(XMA((CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3)),2),2),2)*100;
量线:=SMA(VARA,2,1)-8;
阻力线: 80;
买: 50;
底:20;
BB:=DRAWTEXT(CROSS(量线,50),50,'买'),COLORFF00FF;
机构量能:EXPMA(量线,1),NODRAW;
杭州龙:EXPMA(量线,22),NODRAW;
杭州龙1:=EXPMEMA(机构量能,2);
STICKLINE(机构量能,(REF(机构量能,1)),机构量能,5,0),COLOR000077;
STICKLINE(机构量能,(REF(机构量能,1)),机构量能,4,0),COLOR000099;
STICKLINE(机构量能,(REF(机构量能,1)),机构量能,3,0),COLOR0000BB;
STICKLINE(机构量能,(REF(机构量能,1)),机构量能,1.5,0),COLOR0000DD;
STICKLINE(机构量能,(REF(机构量能,1)),机构量能,0.5,0),COLOR0000FF;
STICKLINE(机构量能,(REF(杭州龙,1)),杭州龙,5,0),COLOR000077;
STICKLINE(机构量能,(REF(杭州龙,1)),杭州龙,4,0),COLOR000099;
STICKLINE(机构量能,(REF(杭州龙,1)),杭州龙,3,0),COLOR0000BB;
STICKLINE(机构量能,(REF(杭州龙,1)),杭州龙,1.5,0),COLOR0000DD;
STICKLINE(机构量能,(REF(杭州龙,1)),杭州龙,0.5,0),COLOR0000FF;
金色持有:=REF(机构量能>REF(机构量能,1),1);
STICKLINE(金色持有,(REF(机构量能,1)),机构量能,5,0),COLOR007777;
STICKLINE(金色持有,(REF(机构量能,1)),机构量能,4,0),COLOR009999;
STICKLINE(金色持有,(REF(机构量能,1)),机构量能,3,0),COLOR00BBBB;
STICKLINE(金色持有,(REF(机构量能,1)),机构量能,1.5,0),COLOR00DDDD;
STICKLINE(金色持有,(REF(机构量能,1)),机构量能,0.5,0),COLOR00FFFF;
绿色减仓:=机构量能<REF(机构量能,1);
STICKLINE(绿色减仓,(REF(机构量能,1)),机构量能,5,0),COLOR007700;
STICKLINE(绿色减仓,(REF(机构量能,1)),机构量能,4,0),COLOR009900;
STICKLINE(绿色减仓,(REF(机构量能,1)),机构量能,3,0),COLOR00BB00;
STICKLINE(绿色减仓,(REF(机构量能,1)),机构量能,1.5,0),COLOR00DD00;
STICKLINE(绿色减仓,(REF(机构量能,1)),机构量能,0.5,0),COLOR00FF00;
STICKLINE(绿色减仓,(REF(杭州龙,1)),杭州龙,5,0 ),COLOR007700;
STICKLINE(绿色减仓,(REF(杭州龙,1)),杭州龙,4,0 ),COLOR009900;
STICKLINE(绿色减仓,(REF(杭州龙,1)),杭州龙,3,0 ),COLOR00BB00;
STICKLINE(绿色减仓,(REF(杭州龙,1)),杭州龙,2,0 ),COLOR00DD00;
STICKLINE(绿色减仓,(REF(杭州龙,1)),杭州龙,1,0 ),COLOR00FF00;
DRAWTEXT(CROSS(机构量能,20),20,'抄底'),COLORFF00FF;
DRAWTEXT(CROSS(机构量能,50),50,'买'),COLORFF00FF;
DRAWTEXT(CROSS(REF(机构量能,1),机构量能),机构量能,'S'),COLOR00FFFF;
DRAWTEXT(CROSS(机构量能,REF(机构量能,1)),机构量能,'B'),COLORFF00FF;

附件

微信图片_20210222180524.png

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2021-2-23 07:42 复制 查看全部楼层
有未来。
VARA:=XMA(XMA(XMA((CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3)),2),2),2)*100;
量线:=SMA(VARA,2,1)-8;
机构量能:=EXPMA(量线,1);
CROSS(机构量能,20);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表