请老师帮忙做个选股公式

[通达信]
设置
1272 3 早日回本 Lv.2 发表于 · 2021-2-22 19:08 显示全部楼层 正序浏览 |
跳转到指定楼层

麻烦老师帮我做个 底背离选股公式


CC:=VOL*100/CAPITAL;
AA:=(CC-LLV(CC,89))/(HHV(CC,89)-LLV(CC,89))*100;
BB:=(CC-LLV(CC,144))/(HHV(CC,144)-LLV(CC,144))*100;
N:=6;
M1:=5;
M2:=5;
VARQS4:=IF(REF(AA,1)=100 AND AA<100,1,0),nodraw;
VARQS5:=IF(REF(BB,1)=100 AND BB<100,1,0),nodraw;
VARQS6:=IF(REF(AA,1)=0 AND AA>0,-1,0),nodraw;
VARQS7:=IF(REF(BB,1)=0 AND BB>0,-1,0),nodraw;
ZERO:0,nodraw;
天量89:=VARQS4,colorred;
地量89:=VARQS6,colorgreen;
地量144:=VARQS7,colorgreen;
天量144:=VARQS5,,colorred;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),coloryellow,LINETHICK1;
D:SMA(K,M2,1),colorcyan,LINETHICK1;
J:3*K-2*D,colormagenta,LINETHICK1;
暴涨启动:ABS(VARQS4)+ABS(VARQS5),nodraw;
高安全区:0,colorred;
安全区:20,colorcyan;
风险区:100,colorgreen;
U1:=BARSLAST(REF(CROSS(K,D),1));
U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND d<50;
底背离:=IF(U2>0,1,0);
DRAWLINE(U1=0,D,底背离,REF(D,U1),0),colorred,LINETHICK2;
DRAWLINE(底背离,D,底背离,REF(D,U1),0),colorred,LINETHICK2;
DRAWTEXT(底背离,REF(D,U1)*1.00,'底背离'),coloryellow;
DRAWICON(暴涨启动,J-0.75*(J-REF(J,1)),'buy');
DRAWICON(暴涨启动,J-1.25*(J-REF(J,1)),'buy');
DRAWTEXT(暴涨启动,0,' 暴涨'),colorwhite;
rr:=MAX(C,O);
q1:=HHV(rr,5);
q2:=d<REF(d,1) AND REF(d,1)>REF(d,2);
A2:=BARSLAST(REF(q2,1));
DRAWLINE(暴涨启动,0,暴涨启动,J,0),colormagenta,LINETHICK1;
顶背离:= REF(q1,A2+1)<q1 AND k<REF(k,A2+1) AND q2;
DRAWLINE(A2=0 ,D,顶背离,REF(D,A2),0),colorwhite,LINETHICK2;
DRAWLINE(顶背离,D,顶背离,REF(D,A2),0),colorwhite,LINETHICK2;
DRAWTEXT(顶背离,REF(D,A2)*1.02,'顶背离'),colorgreen;
Var3:=(2*CLOSE+HIGH+LOW)/4;
Var4:=LLV(LOW,34);
VarA:=HHV(HIGH,34);
VarB:=EMA((Var3-Var4)/(VarA-Var4)*100,13);
VarC:=EMA(0.667*REF(VarB,1)+0.333*VarB,2);
暴跌来临:ABS(VARQS6)+ABS(VARQS7),nodraw;
oo:=VarB-VarC;
STICKLINE(oo>0,VarB,VarC,8,0),colorred;
STICKLINE(oo<0,VarB,VarC,8,0),colorgreen;
WWWCHNMONEYCOM:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
DRAWICON(暴跌来临,J+0.75*ABS((J-REF(J,1))),'sell');
DRAWICON(暴跌来临,J+1.25*ABS((J-REF(J,1))),'sell');
DRAWTEXT(暴跌来临,110,'暴跌'),colorligreen;
DRAWLINE(暴跌来临,100,暴跌来临,J,100),colorligreen,LINETHICK1;

举报

扔鸡蛋(0) 回复

早日回本
Lv.2
发表于 2021-2-22 19:32 复制 查看全部楼层
非常感谢老师帮助

举报

扔鸡蛋(0) 回复

中文您注
Lv.3
发表于 2021-2-22 19:19 复制 查看全部楼层
CC:=VOL*100/CAPITAL;
AA:=(CC-LLV(CC,89))/(HHV(CC,89)-LLV(CC,89))*100;
BB:=(CC-LLV(CC,144))/(HHV(CC,144)-LLV(CC,144))*100;
N:=6;
M1:=5;
M2:=5;
VARQS4:=IF(REF(AA,1)=100 AND AA<100,1,0),NODRAW;
VARQS5:=IF(REF(BB,1)=100 AND BB<100,1,0),NODRAW;
VARQS6:=IF(REF(AA,1)=0 AND AA>0,-1,0),NODRAW;
VARQS7:=IF(REF(BB,1)=0 AND BB>0,-1,0),NODRAW;
ZERO:0,NODRAW;
天量89:=VARQS4,COLORRED;
地量89:=VARQS6,COLORGREEN;
地量144:=VARQS7,COLORGREEN;
天量144:=VARQS5,,COLORRED;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1),COLORYELLOW,LINETHICK1;
D:=SMA(K,M2,1),COLORCYAN,LINETHICK1;
J:=3*K-2*D,COLORMAGENTA,LINETHICK1;
暴涨启动:=ABS(VARQS4)+ABS(VARQS5),NODRAW;
高安全区:=0,COLORRED;
安全区:=20,COLORCYAN;
风险区:=100,COLORGREEN;
U1:=BARSLAST(REF(CROSS(K,D),1));
U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND D<50;
底背离:IF(U2>0,1,0);
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2021-2-22 19:19 复制 查看全部楼层
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORYELLOW,LINETHICK1;
D:=SMA(K,3,1),COLORCYAN,LINETHICK1;
J:=3*K-2*D,COLORMAGENTA,LINETHICK1;

U1:=BARSLAST(REF(CROSS(K,D),1));
U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND D<50;
底背离:IF(U2>0,1,0);
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表