请老师帮助将两个买入改成选股指标

[通达信]
设置
1186 3 晨海凌风 Lv.1 发表于 · 2021-2-22 22:07 显示全部楼层 正序浏览 |
跳转到指定楼层
一、
乾线:=MA(C,3) ;
坤线:=MA(REF(LLV(C,3),2),2) ;
MA32:=MA(C,32) ;
XX:=O<乾线 AND O<坤线 AND O<MA32 AND C>乾线 AND C>坤线 AND C>MA32;


N:=5;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:=8;
准备买入:=CROSS(VAR1,VAR2);


MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:=FILTER(YXF=1,5);




V1:=MA(C,3)=HHV(MA(C,3),7);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
VAR3A:=3;
VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);


XG:XX AND 准备买入 AND 加仓 AND VAR2A;

二、
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:FILTER(MR,10);



举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2021-2-23 09:16 复制 查看全部楼层
快乐398 发表于 2021-2-23 00:00
老师好!请问现在如何能看到十大流通股东中的持股变化情况?谢谢老师!祝老师工作愉快!


通过通达信软件的专业财务数据可以看到十大股东合计持有和第一大股东持有

其他的资料需要外部数据。(注意下载专业财务数据。)


{十大股东持A股合计
第一大流通股东持A股量(股)}


十大股东合计:FINVALUE(264);
第一股东持股:FINVALUE(265);

附件

tdxjietu1.JPG
查看全部打赏
  • 快乐398+10理想币 : 谢谢老师!您辛苦了!祝老师投资愉快!

举报

点亮(0) 扔鸡蛋(0) 回复

快乐398
Lv.4
发表于 2021-2-23 00:00 复制 查看全部楼层

老师好!请问现在如何能看到十大流通股东中的持股变化情况?谢谢老师!祝老师工作愉快!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2021-2-22 22:11 复制 查看全部楼层
共振选股




乾线:=MA(C,3) ;
坤线:=MA(REF(LLV(C,3),2),2) ;
MA32:=MA(C,32) ;
XX:=O<乾线 AND O<坤线 AND O<MA32 AND C>乾线 AND C>坤线 AND C>MA32;


N:=5;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:=8;
准备买入:=CROSS(VAR1,VAR2);


MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:=FILTER(YXF=1,5);




V1:=MA(C,3)=HHV(MA(C,3),7);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
VAR3A:=3;
VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);


XG:=XX AND 准备买入 AND 加仓 AND VAR2A;


AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:FILTER(MR,10) AND XG;
查看全部打赏
  • 快乐398+4理想币 +2分享值 : 谢谢老师

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表