请老师帮助改成选股公式

[通达信]
设置
1150 3 郭健好 Lv.3 发表于 · 2021-2-22 22:25 显示全部楼层 正序浏览 |
跳转到指定楼层
就是要把出击的粉色柱子选出来,谢谢啊!!!


VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=VAR2<REF(VAR2,1);
VAR15:=VAR2>REF(VAR2,1);
VAR16:=VAR8 OR VAR10;
VAR17:=VAR9 OR VAR11;
VAR18:=VAR13 AND VAR14;
VAR19:=VAR16 OR VAR18;
VAR20:=VAR12 AND VAR15;
XG:=LAST(VAR19,7,1) AND VAR20,COLORRED,STICK;
UP:=CROSS(XG,VAR19) AND VAR20<2.1 AND C>O;
STICKLINE(UP,50,0,4,0),COLOR0000FF;
STICKLINE(UP,50,0,3,0),COLOR6600FF;
STICKLINE(UP,50,0,2,0),COLORFF00FF;
STICKLINE(UP,50,0,1,0),COLORFF99FF;
STICKLINE(UP,50,0,0.3,0),COLORFF3366,;
DRAWTEXT(UP,53,'出击'),COLORWHITE;
均价线:3*SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1),3,1),COLORLIBLUE,LINETHICK2;
你恐慌我贪婪:IF(均价线<=8,30,0),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(你恐慌我贪婪,8),33,'我贪婪'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

郭健好
Lv.3
发表于 2021-2-22 22:51 复制 查看全部楼层
谢谢啊!!!老师祝你股票长虹,天天涨停板。

举报

点亮(0) 扔鸡蛋(0) 回复

超峰666
Lv.2
发表于 2021-2-22 22:36 复制 查看全部楼层
VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=VAR2<REF(VAR2,1);
VAR15:=VAR2>REF(VAR2,1);
VAR16:=VAR8 OR VAR10;
VAR18:=VAR13 AND VAR14;
VAR19:=VAR16 OR VAR18;
VAR20:=VAR12 AND VAR15;
XG:=LAST(VAR19,7,1) AND VAR20,COLORRED,STICK;
选股:CROSS(XG,VAR19) AND VAR20<2.1 AND C>O;

举报

扔鸡蛋(0) 回复

郭健好
Lv.3
发表于 2021-2-22 22:27 复制 查看全部楼层
请看图选出粉色的柱子  出击

附件

出击.JPG

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表