请老师帮忙合并一个选股

[通达信]
设置
1246 1 狼要吃肉 Lv.3 发表于 · 2021-2-23 09:27 显示全部楼层 正序浏览 |
跳转到指定楼层
选股一
DIF:=EMA(CLOSE,12)-EMA(CLOSE,25);
DEA:=EMA(DIF,5);
MACD:=(DIF-DEA)*2;
MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120)));
XG:NOT(REF(MACD120,1)=MACD120);


选股二

XA_1:=MA(CLOSE,46)+MA(CLOSE,46)*10/100;
XA_2:=MA(CLOSE,23)+MA(CLOSE,23)*5/100;
XA_3:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
XA_4:=MA(HIGH,5);
XA_5:=CLOSE>REF(CLOSE,1)*1.088;
XA_6:=IF(CODELIKE(1),0,1);
XA_7:=IF(NAMELIKE(2),0,1);
XA_8:=IF(NAMELIKE(3),0,1);
XA_9:=DYNAINFO(17)>0;
XA_10:=XA_7 AND XA_8 AND XA_9;
XG:CROSS(XA_4,XA_1) OR CROSS(XA_3,XA_1) OR CROSS(XA_3,XA_2) AND XA_5;

选股三
妖股线:=EMA((CLOSE-MA((1.2*CLOSE+HIGH+LOW)/3,20))/MA((1.2*CLOSE+HIGH+LOW)/3,20)*100,3);
XG:CROSS(妖股线,5);


举报

扔鸡蛋(0) 回复

闹海老龙神
Lv.5
发表于 2021-2-23 09:30 复制 查看全部楼层
{供参考}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,25);
DEA:=EMA(DIF,5);
MACD:=(DIF-DEA)*2;
MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120)));
XG1:=NOT(REF(MACD120,1)=MACD120);

XA_1:=MA(CLOSE,46)+MA(CLOSE,46)*10/100;
XA_2:=MA(CLOSE,23)+MA(CLOSE,23)*5/100;
XA_3:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
XA_4:=MA(HIGH,5);
XA_5:=CLOSE>REF(CLOSE,1)*1.088;
XA_6:=IF(CODELIKE(1),0,1);
XA_7:=IF(NAMELIKE(2),0,1);
XA_8:=IF(NAMELIKE(3),0,1);
XA_9:=DYNAINFO(17)>0;
XA_10:=XA_7 AND XA_8 AND XA_9;
XG2:=CROSS(XA_4,XA_1) OR CROSS(XA_3,XA_1) OR CROSS(XA_3,XA_2) AND XA_5;

妖股线:=EMA((CLOSE-MA((1.2*CLOSE+HIGH+LOW)/3,20))/MA((1.2*CLOSE+HIGH+LOW)/3,20)*100,3);
XG3:=CROSS(妖股线,5);

选股:XG1 AND XG2 AND XG3;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表