请老师帮助合并一下选股预警

[通达信]
设置
1388 6 梧桐す雨 Lv.2 发表于 · 2021-2-23 10:36 显示全部楼层 正序浏览 |
跳转到指定楼层
公式一:

VAR01:=LLV(L,10);
VAR02:=HHV(H,25);
趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4);
价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1);
价5:=MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1);
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW;
ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED;
逃顶高手:=A AND ABB;
地量一:=MA(V,3)/MA(V,20)<0.4;
地量二:=COUNT(V/(V,20)<0.4,3)=3;
地量三:=V/MA(V,30)<0.5 AND V/HHV(V,30)<0.2;
AA:=SUMBARS(VOL,CAPITAL);
地量四:=VOL<MA(VOL,AA)/3;
地量选股:=(地量一 OR 地量二 OR 地量三 OR 地量四)=1 AND (REF(地量一,1) OR REF(地量二,1) OR REF(地量三,1) OR REF(地量四,1))=0;
P1:=5;
P2:=4;
VARAB:=LLV(LOW,P1);
VARBB:=HHV(HIGH,P1);
KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED;
DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE;
庄家:=KA1;
散户:=DA1;
低吸:=CROSS(庄家,散户) AND 庄家<30;
VAR2D:=(2*CLOSE+HIGH+LOW)/4;
VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR04:=LLV(LOW,5);
VAR05:=HHV(HIGH,4);
庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03;
散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03;
短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1;
低吸1:=CROSS(庄家1,散户1) AND 庄家1<30;
买入:=逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1);
{短线买入立柱图}
STICKLINE(买入,0,6,3,0),COLORRED;
DRAWICON(买入,5,5)COLORFF00FF ;
DRAWTEXT(逃顶高手 AND 地量选股,2,'地量'),COLORYELLOW;
DRAWTEXT(买入,4.5,'短线买入'),COLORYELLOW; VAR21:=REF(CLOSE,1);
VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1) * 100));
短期顶部:CROSS(+80,VAR22) *8,COLORWHITE,LINETHICK2,STICK;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖点:=CROSS(85,RSI1)*30,COLOR00FF00,LINETHICK2;
卖:IF(卖点,6.5,0),STICK,COLORGREEN,LINETHICK4;
洗钱A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
量1:=EMA(洗钱A,3);
量2:=EMA(洗钱A,5);
量3:=EMA(洗钱A,7);
STICKLINE(量1>量2,量3,量1,3,1),COLORRED;
STICKLINE(量1<量2,量3,量1,2,0),COLORCYAN;
T1:=量2>量3 AND 量1<REF(量1,1);
T2:=量2<量3 AND 量1>REF(量1,1);
STICKLINE(T1,量1,量3,2,0),COLORYELLOW;
STICKLINE(T2,量1,量3,3,1),COLORFF00FF;
洗钱B:=SMA(洗钱A,13,1);
分水岭:SMA(洗钱B,2.5,1.5),LINETHICK2,COLORWHITE;
牛线:3*洗钱B-2*分水岭,LINETHICK2,COLORFF00FF ;
熊线:4*分水岭-3*洗钱B,LINETHICK2,COLORFF6633;
DIF1:=EMA(C,12)-EMA(C,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD1,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD1,QM),0);
QF:=LLVBARS(DIF1,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIF1,QF),0);
XG1:=MACD1<0 AND MACD1>MQDZ AND DIF1<0 AND DIF1>DQDZ AND C=LLV(C,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG:REF(XG1,1)=1 AND MACD1>REF(MACD1,1);
VAR21A:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR61:=REF(CLOSE,1);
VAR70A:=SMA(MAX(CLOSE-VAR61,0),6,1)/SMA(ABS(CLOSE-VAR61),6,1)*100;
DRAWICON(CROSS(90,VAR70A),H*0.8.04,9);
MTM1:=C-REF(C,1);
A013:=HHV(HIGH,34);
A014:=(2*CLOSE+HIGH+LOW)/4;
A015:=LLV(LOW,34);
A016:=EMA(((A014-A015)/(A013-A015))*100,13);
A017:=EMA(0.667*REF(A016,1)+0.333*A016,2);
KKMD:=A016-A017>1 AND A016<30 AND A017<30;
DRAWTEXT(FILTER(KKMD,30),L*0.05,'▲短买'),COLOR00FFFF;
VAR06:=REF(C,1);
VAR07:=SMA(MAX(C-VAR06,0),6,1)/SMA(ABS(C-VAR06),6,1)*100;
DRAWTEXT(CROSS(82,VAR07),H*0.9,'◤减仓'),COLORGREEN;
RSVB:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100;
K:=SMA(RSVB,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VARA6:=(2*C+H+L)/3;
VARA7:=EMA(EMA(EMA(VARA6,4),4),4);
VARA8:=(VARA7-REF(VARA7,1))/REF(VARA7,1)*100;
VARA9:=MA(VARA8,3)+0.03;
VARA10:=MA(VARA8,1);
DRAWICON(CROSS(VARA9,VARA10) AND J>90,H*0.96,12),COLORGREEN;
DRAWTEXT(CROSS(VARA9,VARA10) AND J>90,H*1.02,'卖'),COLORCYAN;
LCD:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100;
建仓:CROSS(RSI,11)*10,COLORRED;


公式二:

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
貔貅:=(AV + NEWVOL);
XG:CROSS(貔貅,0);

要求:公式1的“短线买入”(笑脸红柱体) + 公式1的“建仓” + 公式2,  3个合为1个做预警输出
本主题由 任务系统 于 2021-2-23 10:38 审核通过

举报

扔鸡蛋(0) 回复

梧桐す雨
Lv.2
发表于 2021-2-23 17:45 复制 查看全部楼层
高高山山 发表于 2021-2-23 15:39
VAR01:=LLV(L,10); VAR02:=HHV(H,25); 趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4); 价:=EMA(MA((((C-REF(C, ...

麻烦老师解决下

附件

微信图片编辑_20210223174406.jpg

举报

扔鸡蛋(0) 回复

高高山山
Lv.4
发表于 2021-2-23 15:39 复制 查看全部楼层
VAR01:=LLV(L,10); VAR02:=HHV(H,25); 趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4); 价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1); 价5:=MA(价,5); 量:=EMA(MA((V-REF(V,1))/V,5),1); 量5:=MA(量,5); 角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1; W:=(C/REF(C,1))>1.01; 横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100); 量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100); 量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5; A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW; ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED; 逃顶高手:=A AND ABB; 地量一:=MA(V,3)/MA(V,20)<0.4; 地量二:=COUNT(V/(V,20)<0.4,3)=3; 地量三:=V/MA(V,30)<0.5 AND V/HHV(V,30)<0.2; AA:=SUMBARS(VOL,CAPITAL); 地量四:=VOL<MA(VOL,AA)/3; 地量选股:=(地量一 OR 地量二 OR 地量三 OR 地量四)=1 AND (REF(地量一,1) OR REF(地量二,1) OR REF(地量三,1) OR REF(地量四,1))=0; P1:=5; P2:=4; VARAB:=LLV(LOW,P1); VARBB:=HHV(HIGH,P1); KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED; DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE; 庄家:=KA1; 散户:=DA1; 低吸:=CROSS(庄家,散户) AND 庄家<30; VAR2D:=(2*CLOSE+HIGH+LOW)/4; VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR04:=LLV(LOW,5); VAR05:=HHV(HIGH,4); 庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03; 散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03; 短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1; 低吸1:=CROSS(庄家1,散户1) AND 庄家1<30; 买入:=逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1); {短线买入立柱图} STICKLINE(买入,0,6,3,0),COLORRED; DRAWICON(买入,5,5)COLORFF00FF ; DRAWTEXT(逃顶高手 AND 地量选股,2,'地量'),COLORYELLOW; DRAWTEXT(买入,4.5,'短线买入'),COLORYELLOW; VAR21:=REF(CLOSE,1); VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1) * 100)); 短期顶部:CROSS(+80,VAR22) *8,COLORWHITE,LINETHICK2,STICK; LC:=REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; 卖点:=CROSS(85,RSI1)*30,COLOR00FF00,LINETHICK2; 卖:IF(卖点,6.5,0),STICK,COLORGREEN,LINETHICK4; 洗钱A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE; 量1:=EMA(洗钱A,3); 量2:=EMA(洗钱A,5); 量3:=EMA(洗钱A,7); STICKLINE(量1>量2,量3,量1,3,1),COLORRED; STICKLINE(量1<量2,量3,量1,2,0),COLORCYAN; T1:=量2>量3 AND 量1<REF(量1,1); T2:=量2<量3 AND 量1>REF(量1,1); STICKLINE(T1,量1,量3,2,0),COLORYELLOW; STICKLINE(T2,量1,量3,3,1),COLORFF00FF; 洗钱B:=SMA(洗钱A,13,1); 分水岭:SMA(洗钱B,2.5,1.5),LINETHICK2,COLORWHITE; 牛线:3*洗钱B-2*分水岭,LINETHICK2,COLORFF00FF ; 熊线:4*分水岭-3*洗钱B,LINETHICK2,COLORFF6633; DIF1:=EMA(C,12)-EMA(C,26); DEA1:=EMA(DIF1,9); MACD1:=2*(DIF1-DEA1); QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0); QM:=LLVBARS(MACD1,QZQ+20); MQDZ:=IF(QM>QZQ,REF(MACD1,QM),0); QF:=LLVBARS(DIF1,QZQ+20); DQDZ:=IF(QF>QZQ,REF(DIF1,QF),0); XG1:=MACD1<0 AND MACD1>MQDZ AND DIF1<0 AND DIF1>DQDZ AND C=LLV(C,QZQ+20) AND MQDZ<0 AND DQDZ<0; XG:REF(XG1,1)=1 AND MACD1>REF(MACD1,1); VAR21A:=(REF(HIGH,1)+REF(LOW,1))/2; VAR61:=REF(CLOSE,1); VAR70A:=SMA(MAX(CLOSE-VAR61,0),6,1)/SMA(ABS(CLOSE-VAR61),6,1)*100; DRAWICON(CROSS(90,VAR70A),H*0.8.04,9); MTM1:=C-REF(C,1); A013:=HHV(HIGH,34); A014:=(2*CLOSE+HIGH+LOW)/4; A015:=LLV(LOW,34); A016:=EMA(((A014-A015)/(A013-A015))*100,13); A017:=EMA(0.667*REF(A016,1)+0.333*A016,2); KKMD:=A016-A017>1 AND A016<30 AND A017<30; DRAWTEXT(FILTER(KKMD,30),L*0.05,'▲短买'),COLOR00FFFF; VAR06:=REF(C,1); VAR07:=SMA(MAX(C-VAR06,0),6,1)/SMA(ABS(C-VAR06),6,1)*100; DRAWTEXT(CROSS(82,VAR07),H*0.9,'◤减仓'),COLORGREEN; RSVB:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100; K:=SMA(RSVB,3,1); D:=SMA(K,3,1); J:=3*K-2*D; VARA6:=(2*C+H+L)/3; VARA7:=EMA(EMA(EMA(VARA6,4),4),4); VARA8:=(VARA7-REF(VARA7,1))/REF(VARA7,1)*100; VARA9:=MA(VARA8,3)+0.03; VARA10:=MA(VARA8,1); DRAWICON(CROSS(VARA9,VARA10) AND J>90,H*0.96,12),COLORGREEN; DRAWTEXT(CROSS(VARA9,VARA10) AND J>90,H*1.02,'卖'),COLORCYAN; LCD:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100; 建仓:CROSS(RSI,11)*10,COLORRED;   公式二:  LC:=REF(CLOSE,1); RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100); TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10); HD:=(HIGH - REF(HIGH,1)); LD:=(REF(LOW,1) - LOW); DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10); DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10); PDI:=((DMP * 100) / TR1); MDI:=((DMM * 100) / TR1); ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5); AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5); WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10))); NEWVOL:=(RSI5 - WR10); 貔貅:=(AV + NEWVOL); XG:CROSS(貔貅,0);

举报

扔鸡蛋(0) 回复

梧桐す雨
Lv.2
发表于 2021-2-23 12:46 复制 查看全部楼层
闹海老龙神 发表于 2021-2-23 10:52
{供参考}
VAR01:=LLV(L,10);
VAR02:=HHV(H,25);

公式一:

VAR1:=REF(CLOSE,2);
A2: SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,  COLORGREEN;
车弩机: IF(A2<12,30,0);
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
弯弓: IF(VAR3<12,30,0);
逢高派发区: STICKLINE(A2>80,A2+1,A2-1,1.5,0),  COLORRED;
VAR1J:=CLOSE/(EMA(EMA((C+L+H)/3,3),26)*0.9)<0.95 ;
放箭:IF(VAR1J,15,0),STICK,LINETHICK3,COLORRED;
DRAWTEXT(VAR1J ,8,'箭'),COLORF0F000;
VARE1:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
VARE2:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
VARE3:=IF(VARE1>0.010, 0.900, 1) AND IF(VARE1>(-0.025), 1, 1.200);
VARE4:=VARE3*(VARE2-VARE1)*100;
VARE5:=SUM(VARE4, 10);
VARE6:=SMA(VARE5, 40, 1);
VARE7:=IF(CLOSE AND MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);{VAR38>VAR39;}
VARE8:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VARE7>0, 91, 0);
追击:IF(VARE8>90,30,0),STICK,LINETHICK3,COLORBLUE;
DRAWTEXT(VARE8>90,30,'追击'),COLORYELLOW;


公式二:

VAR01:=LLV(L,10);
VAR02:=HHV(H,25);
趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4);
价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1);
价5:=MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1);
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW;
ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED;
逃顶高手:=A AND ABB;
P1:=5;
P2:=4;
VARAB:=LLV(LOW,P1);
VARBB:=HHV(HIGH,P1);
KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED;
DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE;
庄家:=KA1;
散户:=DA1;
低吸:=CROSS(庄家,散户) AND 庄家<30;
VAR2D:=(2*CLOSE+HIGH+LOW)/4;
VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR04:=LLV(LOW,5);
VAR05:=HHV(HIGH,4);
庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03;
散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03;
短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1;
低吸1:=CROSS(庄家1,散户1) AND 庄家1<30;
买入:=逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1);
短线买入:=买入;

LCD:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100;
建仓:=CROSS(RSI,11)*10;

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
貔貅:=(AV + NEWVOL);
XG:=CROSS(貔貅,0);

预警:短线买入 AND 建仓 AND XG;


公式2就是老师刚刚帮我做的合并。现在需要公式1的“车弩机”和公式2合并即可。

举报

点亮(0) 扔鸡蛋(0) 回复

梧桐す雨
Lv.2
发表于 2021-2-23 11:16 复制 查看全部楼层
感谢两位老师的操作

举报

扔鸡蛋(0) 回复

闹海老龙神
Lv.5
发表于 2021-2-23 10:52 复制 查看全部楼层
{供参考}
VAR01:=LLV(L,10);
VAR02:=HHV(H,25);
趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4);
价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1);
价5:=MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1);
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW;
ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED;
逃顶高手:=A AND ABB;
P1:=5;
P2:=4;
VARAB:=LLV(LOW,P1);
VARBB:=HHV(HIGH,P1);
KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED;
DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE;
庄家:=KA1;
散户:=DA1;
低吸:=CROSS(庄家,散户) AND 庄家<30;
VAR2D:=(2*CLOSE+HIGH+LOW)/4;
VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR04:=LLV(LOW,5);
VAR05:=HHV(HIGH,4);
庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03;
散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03;
短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1;
低吸1:=CROSS(庄家1,散户1) AND 庄家1<30;
买入:=逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1);
短线买入:=买入;

LCD:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100;
建仓:=CROSS(RSI,11)*10;

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
貔貅:=(AV + NEWVOL);
XG:=CROSS(貔貅,0);

预警:短线买入 AND 建仓 AND XG;
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!
  • 梧桐す雨+10理想币 共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

哦哈哈哦qq
Lv.3
发表于 2021-2-23 10:50 复制 查看全部楼层
VAR01:=LLV(L,10);
VAR02:=HHV(H,25);
趋势线:=EMA((C-VAR01)/(VAR02-VAR01)*4,4);
价:=EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1);
价5:=MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1);
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 AND W ,COLORYELLOW;
ABB:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,横盘 AND 量比 AND 量横盘 AND 角)=1 AND W ,COLORRED;
逃顶高手:=A AND ABB;
P1:=5;
P2:=4;
VARAB:=LLV(LOW,P1);
VARBB:=HHV(HIGH,P1);
KA1:=MA((CLOSE-VARAB)/(VARBB-VARAB)*100,P2),COLORRED;
DA1:=MA(0.667*REF(KA1,1)+0.333*KA1,2),COLORWHITE;
庄家:=KA1;
散户:=DA1;
低吸:=CROSS(庄家,散户) AND 庄家<30;
VAR2D:=(2*CLOSE+HIGH+LOW)/4;
VAR03:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR04:=LLV(LOW,5);
VAR05:=HHV(HIGH,4);
庄家1:= EMA((VAR2D-VAR04)/(VAR05-VAR04)*100,4)*VAR03;
散户1:= EMA(0.667*REF(庄家1,1)+0.333*庄家1,2)*VAR03;
短进1:=CROSS(庄家1,散户1) AND 庄家1<50 AND 29<庄家1;
低吸1:=CROSS(庄家1,散户1) AND 庄家1<30;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
貔貅:=(AV + NEWVOL);
LCD:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LCD,0),4.1,1)/SMA(ABS(CLOSE-LCD),4.1,1)*100;

XG:CROSS(貔貅,0) and 逃顶高手 AND 低吸 AND (短进1 OR 低吸1) AND 趋势线>REF(趋势线,1) and CROSS(RSI,11);
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!
  • 梧桐す雨+10理想币 共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表