请老师帮助将公式中出现红黄颜色的改为通达信选股公式

[通达信]
设置
1341 2 小财神祺祺 Lv.2 发表于 · 2021-2-23 10:55 显示全部楼层 正序浏览 |
跳转到指定楼层
XA_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_2:=EMA(CLOSE,89);
XA_3:=EMA(EMA(EMA(HIGH,13),13),13);
XA_4:=EMA(EMA(EMA(HIGH,5),5),5);
XA_5:=IF(CLOSE>OPEN,CLOSE,OPEN);
XA_6:=IF(CLOSE>OPEN,OPEN,CLOSE);
XA_7:=LLV(XA_5,4);
XA_8:=HHV(XA_6,4);
XA_9:=XA_5>=XA_7 AND XA_6<=XA_7 AND XA_5>=XA_8 AND XA_6<=XA_8;
XA_10:=REF(XA_5,1)>=XA_7 AND REF(XA_6,1)<=XA_7 AND REF(XA_5,1)>=XA_8 AND REF(XA_6,1)<=XA_8;
XA_11:=REF(XA_5,2)>=XA_7 AND REF(XA_6,2)<=XA_7 AND REF(XA_5,2)>=XA_8 AND REF(XA_6,2)<=XA_8;
XA_12:=REF(XA_5,3)>=XA_7 AND REF(XA_6,3)<=XA_7 AND REF(XA_5,3)>=XA_8 AND REF(XA_6,3)<=XA_8;
XA_13:=XA_9 AND XA_10 AND XA_11 AND XA_12;
XA_14:=REF(XA_8,BARSLAST(XA_13));
XA_15:=(REF(OPEN,5)+REF(CLOSE,5))/2;
XA_16:=(HIGH+LOW+CLOSE+OPEN)/4;
XA_17:=MAX(XA_15,MAX(XA_16,HHV(HIGH,5)));
XA_18:=MIN(XA_15,MIN(XA_16,LLV(LOW,5)));
DRAWKLINE(XA_17,XA_15,XA_18,XA_16);
XA_19:=XA_17=XA_15;
XA_20:=XA_19;
XA_21:=REF(XA_17,BARSLAST(XA_20));
XA_22:=EMA(CLOSE,5)-EMA(CLOSE,55);
XA_23:=EMA(XA_22,10);
XA_24:=XA_22-XA_23;
XA_25:=XA_17>XA_21*0.98 AND CLOSE>XA_4 AND CLOSE>XA_3 AND CLOSE>XA_2 AND XA_4>=REF(XA_4,1);
STICKLINE(XA_25,XA_17,XA_18,3.2,1),COLORMAGENTA;
STICKLINE(XA_25,XA_15,XA_16,3.2,0),COLORMAGENTA;
STICKLINE(XA_25,XA_15,XA_16,3,0),COLORMAGENTA;
STICKLINE(XA_25,XA_15,XA_16,1.9,0),COLORMAGENTA;
STICKLINE(XA_25,XA_15,XA_16,1.1,0),COLORMAGENTA;
STICKLINE(XA_25,XA_15,XA_16,0.3,1),COLORMAGENTA;
STICKLINE(XA_25<1,XA_17,XA_18,3.2,1),COLORLIBLUE;
STICKLINE(XA_25<1,XA_15,XA_16,3.2,0),COLORLIBLUE;
STICKLINE(XA_25<1,XA_15,XA_16,2,0),COLORLIBLUE;
STICKLINE(XA_25<1,XA_15,XA_16,1,1),COLORLIBLUE;
XA_26:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_27:=XA_26>9.85 AND NOT(OPEN=CLOSE) AND XA_1>4;
XA_28:=XA_26>9.85 AND NOT(OPEN=CLOSE) AND XA_1>4 AND XA_1<9.3;
XA_29:=REF(HIGH,BARSLAST(XA_28));
XA_30:=REF(LOW,BARSLAST(XA_28));
STICKLINE(HIGH,XA_29-XA_29*0.001,XA_29,3,0),COLORWHITE;
XA_31:=XA_26>9.85 AND NOT(OPEN=CLOSE) AND XA_1>4 AND XA_1<9.3;
XA_32:=(CLOSE-REF(CLOSE,BARSLAST(XA_31)))/REF(CLOSE,BARSLAST(XA_31))*100;
B:REF(XA_8,BARSLAST(XA_13)),NODRAW;
A:REF(HIGH,BARSLAST(XA_28)),NODRAW;
S:REF(XA_17,BARSLAST(XA_20)),NODRAW;
XA_33:=XA_18=REF(XA_18,1) AND XA_17<REF(XA_17,1) AND XA_19;
XA_34:=XA_18=REF(XA_18,1) AND XA_18=REF(XA_18,2) AND XA_18=REF(XA_18,3) AND XA_18=REF(XA_18,4);
XA_35:=(XA_17+XA_18)/2*1.02;
XA_36:=(XA_17+XA_18)/2*0.98;
STICKLINE(XA_34,XA_35,XA_36,3.2,1),COLORGREEN;
STICKLINE(XA_34,XA_35,XA_36,2.6,0),COLORGREEN;
STICKLINE(XA_34,XA_35,XA_36,2.6,0),COLORGREEN;
STICKLINE(XA_34,XA_35,XA_36,0.5,1),COLORGREEN;
STICKLINE(S>XA_17 AND REF(S<XA_17,1),XA_15,XA_16,1,0),COLORBLUE;
VZF:VOL/REF(VOL,1)*100-100,NODRAW;
XA_37:=XA_1>=9.84 AND REF(XA_1<9.84,1) AND REF(XA_1<9.84,2);
STICKLINE(XA_1>=9.84,XA_35,XA_36,3.4,0),COLOR00AAFF;
STICKLINE(XA_1>=9.84,XA_35,XA_36,2,0),COLOR00CCFF;
STICKLINE(XA_1>=9.84,XA_35,XA_36,0.5,0),COLORYELLOW;
STICKLINE(XA_37,XA_35,XA_36,0.5,0),COLORRED;
STICKLINE(CLOSE,XA_21,XA_21,3,0),COLORGREEN,LINETHICK3;


麻烦高手老师可否将公式中出现红黄颜色的改为通达信选股公式,谢谢

举报

扔鸡蛋(0) 回复

小财神祺祺
Lv.2
发表于 2021-2-23 11:18 复制 查看全部楼层
闹海老龙神 发表于 2021-2-23 10:59
{供参考}
XA_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_2:=EMA(CLOSE,89);

老师,但是我希望修改的红黄色同时出现(如图)的选股公式,麻烦请再帮忙一下 ,谢谢

附件

1.png
2.png

举报

点亮(0) 扔鸡蛋(0) 回复

闹海老龙神
Lv.5
发表于 2021-2-23 10:59 复制 查看全部楼层
本帖最后由 闹海老龙神 于 2021-2-23 11:22 编辑

{供参考}
XA_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_2:=EMA(CLOSE,89);
XA_3:=EMA(EMA(EMA(HIGH,13),13),13);
XA_4:=EMA(EMA(EMA(HIGH,5),5),5);
XA_5:=IF(CLOSE>OPEN,CLOSE,OPEN);
XA_6:=IF(CLOSE>OPEN,OPEN,CLOSE);
XA_7:=LLV(XA_5,4);
XA_8:=HHV(XA_6,4);
XA_9:=XA_5>=XA_7 AND XA_6<=XA_7 AND XA_5>=XA_8 AND XA_6<=XA_8;
XA_10:=REF(XA_5,1)>=XA_7 AND REF(XA_6,1)<=XA_7 AND REF(XA_5,1)>=XA_8 AND REF(XA_6,1)<=XA_8;
XA_11:=REF(XA_5,2)>=XA_7 AND REF(XA_6,2)<=XA_7 AND REF(XA_5,2)>=XA_8 AND REF(XA_6,2)<=XA_8;
XA_12:=REF(XA_5,3)>=XA_7 AND REF(XA_6,3)<=XA_7 AND REF(XA_5,3)>=XA_8 AND REF(XA_6,3)<=XA_8;
XA_13:=XA_9 AND XA_10 AND XA_11 AND XA_12;
XA_14:=REF(XA_8,BARSLAST(XA_13));
XA_15:=(REF(OPEN,5)+REF(CLOSE,5))/2;
XA_16:=(HIGH+LOW+CLOSE+OPEN)/4;
XA_17:=MAX(XA_15,MAX(XA_16,HHV(HIGH,5)));
XA_18:=MIN(XA_15,MIN(XA_16,LLV(LOW,5)));
XA_19:=XA_17=XA_15;
XA_20:=XA_19;
XA_21:=REF(XA_17,BARSLAST(XA_20));
XA_22:=EMA(CLOSE,5)-EMA(CLOSE,55);
XA_23:=EMA(XA_22,10);
XA_24:=XA_22-XA_23;
XA_25:=XA_17>XA_21*0.98 AND CLOSE>XA_4 AND CLOSE>XA_3 AND CLOSE>XA_2 AND XA_4>=REF(XA_4,1);
XA_37:=XA_1>=9.84 AND REF(XA_1<9.84,1) AND REF(XA_1<9.84,2);

选股:XA_1>=9.84 AND XA_25 AND XA_37;



举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表