请老师帮助把下面的主图指标改为选股预警公式

[通达信]
设置
1979 2 浩云98888 Lv.4 发表于 · 2021-2-23 12:50 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮助,把下面的主图指标,改为突破压力位和高点压力M的2个选股预警公式,谢谢!


N:=8;

P:=0;

ZGD:=HHV(H,60);

ZGD2:=CONST(ZGD);

ZDD:=LLV(L,60);

ZDD2:=CONST(ZDD);

GJ:=(C+H+L+O)/4;

明日阻力:=L+(GJ-L)+(C-L);

明日支撑:=L+(C-GJ);

KOH:=L > REF(H,1);

KOL:=H < REF(L,1);

HIF:=L > REF(H,BARSLAST(KOH)+1);

NHIF:=L <=REF(H,BARSLAST(KOH)+1);

LIF:=H < REF(L,BARSLAST(KOL)+1);

NLIF:=H >=REF(L,BARSLAST(KOL)+1);

下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

RRRSV:=SMA(下档线,3,1);

KKK:=SMA(RRRSV,3,1);

DDDDD:=((3 * RRRSV) - (2 * KKK));

JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

RSV24:=SMA(JJ12,3,1);

K24:=SMA(RSV24,3,1);

D24:=((3 * RSV24) - (2 * K24));

压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORWHITE,LINETHICK1;

底部:=LLV(HIGH,30),COLOR00FF00;

AA:=REF(H,N)=HHV(H,2*N+1);

AA1:=REF(L,N)=LLV(L,2*N+1);

QY:=BACKSET(AA,N+1);

QY1:=BACKSET(AA1,N+1);

CC:=FILTER(QY,N) AND H=HHV(H,N+1);

CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);

DDD:=BARSLAST(CC);

DD1:=BARSLAST(CC1);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

GDCS1:=CONST(DINGBUTS);

DDCS1:=CONST(DDTS1);

GDCS13:=CONST(REF(HIGH,GDCS1-1));

DDCS13:=CONST(REF(L,DDCS1-1));

DINGBUTS1:=REF(DINGBUTS,DDD+1);

DDTS2:=REF(DDTS1,DD1+1);

GDCS2:=CONST(DINGBUTS1);

DDCS2:=CONST(DDTS2);

GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));

DDCS23:=CONST(REF(L,DDTS2-1));

XG1:=BACKSET(ISLASTBAR,GDCS1);

XD1:=BACKSET(ISLASTBAR,DDCS1);

XG2:=BACKSET(ISLASTBAR,DINGBUTS1);

XD2:=BACKSET(ISLASTBAR,DDTS2);

XDD:=IF(DDCS13 <=DDCS23,XD1,XD2);

BCG:=SUM(XG1,0);

BCD:=SUM(XDD,0);

STARDAY:=IF(DDCS2 < GDCS2,DDCS2,GDCS2);

高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) ,COLORGREEN,LINETHICK2;

低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),COLORBLUE,LINETHICK2;

高:=CONST(MAX(MAX(MAX(ZGD2,高点压力),GDCS13),GDCS23));

低:=CONST(MIN(MIN(MIN(ZDD2,DDCS23),DDCS13),低点支撑));

ZGSTAR:=(高点压力+低点支撑)/2;

ZGEND:=CONST((高点压力+低点支撑)/2);

M:=INTPART(3*N/5);

AAA:=REF(H,M)=HHV(H,2*M+1);

QYY:=BACKSET(AAA,M+1);

CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);

DDDD:=BARSLAST(CCC),NODRAW;

GDTSS:=IF(CCC,CURRBARSCOUNT,0);

DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);

GDCS11:=CONST(DINGBUTSS);

DINGBUTS11:=REF(DINGBUTSS,DDDD+1);

GDCS22:=CONST(DINGBUTS11);

上缺口:=P=0 AND HIF AND BARSLAST(KOH) < BARSLAST(NHIF)AND BARSLAST(HIF) < BARSLAST(NHIF);

HG:=IF(上缺口,REF(H,BARSLAST(KOH)+1),DRAWNULL);

下缺口:=P=0 AND LIF AND BARSLAST(KOL) < BARSLAST(NLIF) AND BARSLAST(LIF) < BARSLAST(NLIF);

LG:=IF(下缺口,REF(L,BARSLAST(KOL)+1),DRAWNULL);

AA11:=REF(L,M)=LLV(L,2*M+1);

QY11:=BACKSET(AA11,M+1);

CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);

DD11:=BARSLAST(CC11);

DDTSS:=IF(CC11,CURRBARSCOUNT,0);

DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);

DDCS11:=CONST(DDTS11);

DDTS22:=REF(DDTS11,DD11+1);

DDCS22:=CONST(DDTS22);

今日阻力:REF(明日阻力 , 1),NODRAW;

今日支撑:REF(明日支撑 , 1),NODRAW;

压力位:IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;

底部位:IF(ISLASTBAR,底部,DRAWNULL),NODRAW;

{WWW.55188.COM}

STICKLINE(上缺口,HG,HG*1.001,10,0),COLOR888888;

STICKLINE(下缺口,LG,LG*0.999,10,0),COLOR888888;

高点压力M:DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1), COLORRED,LINETHICK1;

低点支撑M:DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1), COLORRED,LINETHICK1;

STICKLINE(XG2,GDCS23,GDCS23,0.5,1),COLORWHITE;

STICKLINE(XG1,GDCS13,GDCS13,0.5,1),COLORYELLOW;

STICKLINE(XD2,DDCS23,DDCS23,0.5,1),COLORMAGENTA;

STICKLINE(XD1,DDCS13,DDCS13,0.5,1),COLORCYAN;

STICKLINE(ISLASTBAR AND C >=今日阻力,今日阻力,今日阻力,10,1),COLOR0000FF;

STICKLINE(ISLASTBAR AND C < 今日阻力,今日阻力,今日阻力,10,1),COLOR00FF00;

举报

扔鸡蛋(0) 回复

人生好累
Lv.0
发表于 2021-2-23 23:26 复制 查看全部楼层

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2021-2-23 16:05 复制 查看全部楼层
有未来
1
N:=8;
M:=INTPART(3*N/5);

AAA:=REF(H,M)=HHV(H,2*M+1);

QYY:=BACKSET(AAA,M+1);

CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);

DDDD:=BARSLAST(CCC),NODRAW;

GDTSS:=IF(CCC,CURRBARSCOUNT,0);

DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);

GDCS11:=CONST(DINGBUTSS);

DINGBUTS11:=REF(DINGBUTSS,DDDD+1);

GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,M)=LLV(L,2*M+1);

QY11:=BACKSET(AA11,M+1);

CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);

DD11:=BARSLAST(CC11);

DDTSS:=IF(CC11,CURRBARSCOUNT,0);

DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);

DDCS11:=CONST(DDTS11);

DDTS22:=REF(DDTS11,DD11+1);

DDCS22:=CONST(DDTS22);
高点压力M:=DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1);
CROSS(C,高点压力M);

2
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

RRRSV:=SMA(下档线,3,1);

KKK:=SMA(RRRSV,3,1);

DDDDD:=((3 * RRRSV) - (2 * KKK));

JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

RSV24:=SMA(JJ12,3,1);

K24:=SMA(RSV24,3,1);

D24:=((3 * RSV24) - (2 * K24));

压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD))));


压力位:=IF(ISLASTBAR,压力2,DRAWNULL);
(REF(压力位=DRAWNULL,1)&&压力位&&C>压力位)=1;
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 牛年迎好运,牛年呈吉祥,财源广进,恭喜发财!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表