请老师帮助为选股公式加入一个条件

[通达信]
设置
1564 4 李伟阿 Lv.2 发表于 · 2021-2-23 19:16 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师为此选股公式加入一个条件--如下图:

公式源码:

{突破阴K翻红}

HH:=HHVBARS(H,1);
TJ:=C<O;
T:=BARSLAST(TJ);
TT:=BARSLAST(CROSS(C,REF(H,T)));
XG:=COUNT(HH=0,TT+1)=1 AND HH=0 AND COUNT(TT=0,T)=1 ;

Q:=BACKSET(XG,REF(T,1)+2);
QT:=BARSLAST(CROSS(Q=1,0.5));

STICKLINE(XG,L,H,0,0),COLORRED; {突破平台线画黄K}
STICKLINE(XG,CLOSE,OPEN,3,0),COLORRED; {突破平台线画黄K};

YY:=IF(Q=1,REF(H,QT),DRAWNULL);

STICKLINE(YY,REF(H,T),REF(H,T),3,0),COLOR00FF00;

选股公式:

HH:=HHVBARS(H,1);
TJ:=C<O ;
T:=BARSLAST(TJ);
TT:=BARSLAST(CROSS(C,REF(H,T)));
XG:COUNT(HH=0,TT+1)=1 AND HH=0 AND COUNT(TT=0,T)=1 ;

附件

999.jpg

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2021-2-25 17:13 复制 查看全部楼层
李伟阿 发表于 2021-2-24 08:59
谢谢ainin老师的解答……。但有失败的例子(如下图),能否请老师再改进一下……底底抬高的公式……万分 ...

把你失败案例截图(有红箭头)的全部代码发出来,我看看。

举报

点亮(0) 扔鸡蛋(0) 回复

李伟阿
Lv.2
发表于 2021-2-24 08:59 复制 查看全部楼层
ainin 发表于 2021-2-24 08:04
-----------------------------------

HH:=HHVBARS(H,1);

谢谢ainin老师的解答……。但有失败的例子(如下图),能否请老师再改进一下……底底抬高的公式……万分感谢!!

附件

666.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

李伟阿
Lv.2
发表于 2021-2-24 08:55 复制 查看全部楼层
本帖最后由 李伟阿 于 2021-2-24 08:58 编辑

谢谢ainin老师的解答……。但有失败的例子(如下图),能否请老师再改进一下……底底抬高的公式……万分感谢!!

附件

666.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

ainin
Lv.5
发表于 2021-2-24 08:04 复制 查看全部楼层

-----------------------------------

HH:=HHVBARS(H,1);
TJ:=C<O ;
T:=BARSLAST(TJ);
TT:=BARSLAST(CROSS(C,REF(H,T)));
XGTJ:=COUNT(HH=0,TT+1)=1 AND HH=0 AND COUNT(TT=0,T)=1 ;

XG:LLV(L,SUMBARS(XGTJ,1))>LLV(L,SUMBARS(XGTJ,2)) and XGTJ;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表