请老师帮忙做个选股公式

[通达信]
设置
1183 2 王者无畏1979 Lv.3 发表于 · 2021-2-23 22:27 显示全部楼层 正序浏览 |
跳转到指定楼层
选出牛回头 牛暴涨 和对应的回调出黄色的阶段底部区域 一共三个谢谢老师

DRAWRECTREL(0,725,130,999,RGB(0,0,1)),NOFRAME;
QQA:=1;
DRAWGBK(1=±3¾°í¼*QQA,RGB(0,50,100),RGB(88,0,0),0,'11',0);
Z1:=STRCAT(HYBLOCK,' ')*QQA;
Z2:=STRCAT(Z1,DYBLOCK)*QQA;
Z3:=STRCAT(Z2,' ')*QQA;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK))*QQA,COLORRED;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25)*QQA,DOTLINE,COLORBLUE;
ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1*QQA,LINETHICK2,COLORRED;
ZD2:EMA(ZD1,25)*QQA,LINETHICK2;
DRAWBAND(ZD1,RGB(55,0,0),ZD2,RGB(0,91,0));
DRAWKLINE(H*QQA,O*QQA,L*QQA,C*QQA);
STICKLINE(ZD1>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;
STICKLINE(ZD1>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
&#187;&#216;μ÷&#194;ò:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=ZD1>HIGH AND &#187;&#216;μ÷&#194;ò AND L<=ZD1;
DRAWTEXT(XG,L,'&#161;&#248;&#197;£&#187;&#216;í·'),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
{DRAWTEXT(XG2,L,'&#161;&#248;×¥&#197;£'),COLORYELLOW;}
DRAWTEXT(XG2 AND L<ZD1,L,'¨I&#197;£±&#169;&#213;&#199;'),COLORRED;
本主题由 任务系统 于 2021-2-23 22:28 审核通过

举报

扔鸡蛋(0) 回复

人生好累
Lv.0
发表于 2021-2-23 23:25 复制 查看全部楼层
牛回头


E12:=EMA(C,12);

E17:=EMA(C,17);

V20:=MA(V,20);

ZT:=C>REF(CLOSE,1)*1.095;

ZD:=L>=0.992*E17 AND L<=1.015*E12 ;

ZF:=O/L<1.035 AND REF(C,1)/O<1.02;

ZU:=DYNAINFO(24)>1.5;

ZTO: COUNT(ZT,12)>=3 AND DYNAINFO(37)>0 AND ZD AND LAST(L>0.98*E17,3,0) AND ZF ;

举报

点亮(0) 扔鸡蛋(0) 回复

超峰666
Lv.2
发表于 2021-2-23 22:44 复制 查看全部楼层
有乱码符号

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表