求选出今日次高连板股票的方法

[通达信]
设置
1528 5 大风青青 Lv.2 发表于 · 2021-2-23 23:16 显示全部楼层 正序浏览 |
跳转到指定楼层
如题,用公式选出今天第二高的连板票,可以用自定义数据或者DLL数据,不知道能不能行,求高手指教!

补充内容 (2021-2-24 23:37):
涨停率:=IF(CODELIKE('688'),0.2,IF(CODELIKE('300') AND DATE>1200823,0.2 ,IF(NAMELIKE('S' OR '*'),0.05,0.1)));
最高:=TDXDLL1(1,DATE,9001,000003);
次高:=IF(最高>=7,IF(6,5,4),IF(3,2,1));

一连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(C,1)<ZTPRICE(REF(C,2),涨停率) AND V>1 AND DYNAINFO(21)=0;
二连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(C,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)<ZTPRICE(REF(C,3),涨停率) AND V>1 AND DYNAINFO(21)=0;
三连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(C,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)<ZTPRICE(REF(C,4),涨停率) AND BARSCOUNT(C)>30 AND V>1 AND DYNAINFO(21)=0;
四连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(CLOSE,4),涨停率) AND REF(CLOSE,4)<ZTPRICE(REF(CLOSE,5),涨停率) AND V>1 AND DYNAINFO(21)=0;
五连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)<ZTPRICE(REF(C,6),涨停率);
六连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)<ZTPRICE(REF(C,7),涨停率);
七连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)<ZTPRICE(REF(C,8),涨停率);
八连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)>=ZTPRICE(REF(C,8),涨停率) AND REF(C,8)<ZTPRICE(REF(C,9),涨停率);
九连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)>=ZTPRICE(REF(C,8),涨停率) AND REF(C,8)>=ZTPRICE(REF(C,9),涨停率) AND REF(C,9)<ZTPRICE(REF(C,10),涨停率);
十连板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)>=ZTPRICE(REF(C,8),涨停率) AND REF(C,8)>=ZTPRICE(REF(C,9),涨停率) AND REF(C,9)>=ZTPRICE(REF(C,10),涨停率) AND REF(C,10)<ZTPRICE(REF(C,11),涨停率);
十一板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)>=ZTPRICE(REF(C,8),涨停率) AND REF(C,8)>=ZTPRICE(REF(C,9),涨停率) AND REF(C,9)>=ZTPRICE(REF(C,10),涨停率) AND REF(C,10)>=ZTPRICE(REF(C,11),涨停率) AND REF(C,11)<ZTPRICE(REF(C,12),涨停率);
十二板:=C>=ZTPRICE(REF(C,1),涨停率) AND REF(CLOSE,1)>=ZTPRICE(REF(C,2),涨停率) AND REF(C,2)>=ZTPRICE(REF(C,3),涨停率) AND REF(C,3)>=ZTPRICE(REF(C,4),涨停率) AND REF(C,4)>=ZTPRICE(REF(C,5),涨停率) AND REF(C,5)>=ZTPRICE(REF(C,6),涨停率) AND REF(C,6)>=ZTPRICE(REF(C,7),涨停率) AND REF(C,7)>=ZTPRICE(REF(C,8),涨停率) AND REF(C,8)>=ZTPRICE(REF(C,9),涨停率) AND REF(C,9)>=ZTPRICE(REF(C,10),涨停率) AND REF(C,10)>=ZTPRICE(REF(C,11),涨停率) AND REF(C,11)>=ZTPRICE(REF(C,12),涨停率) AND REF(C,12)<ZTPRICE(REF(C,13),涨停率);


IF(最高>=7 AND 六连板,五连板,四连板);

举报

扔鸡蛋(0) 回复

大风青青
Lv.2
发表于 2021-2-24 23:39 复制 查看全部楼层
蓝天蓝888 发表于 2021-2-24 20:07
今天第二高“”的连板票,概念不好理解。

如果最高是7板,次高可能是6,5,4,3 连板这种,想把次高的自动归纳到一起,我弄了个公式,IF函数好像实现不了

举报

点亮(0) 扔鸡蛋(0) 回复

大风青青
Lv.2
发表于 2021-2-24 23:36 复制 查看全部楼层
ainin 发表于 2021-2-24 08:18
“”今天第二高“”的连板票,概念不好理解。是所有A股中股价第二的连板票,还是该股次高位的连板票?

如果最高板是六连板,那么第二高连板可能是5板,四板,三板,这种情况

举报

点亮(0) 扔鸡蛋(0) 回复

驯龙诀
Lv.3
发表于 2021-2-24 20:26 复制 查看全部楼层
弄个涨停板阶梯股票池,肉选一目了然

举报

扔鸡蛋(0) 回复

蓝天蓝888
Lv.6
发表于 2021-2-24 20:07 复制 查看全部楼层
今天第二高“”的连板票,概念不好理解。

举报

扔鸡蛋(0) 回复

ainin
Lv.5
发表于 2021-2-24 08:18 复制 查看全部楼层
“”今天第二高“”的连板票,概念不好理解。是所有A股中股价第二的连板票,还是该股次高位的连板票?

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

回顶部 到页底
快速回复 返回顶部 返回列表