请老师帮忙做两个选股公式(一个出现'关注'字样,一个K线那个是黄色的柱子,做这...)

[通达信]
设置
1833 2 小鱼刺 Lv.3 发表于 · 2021-4-7 09:56 显示全部楼层 正序浏览 |
跳转到指定楼层
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

{生命线:EMA(X,15),COLOR00FF00,LINETHICK3;}
VAR4:=(2*CLOSE+HIGH+LOW)/4;
成本区:EMA(VAR4,90)*0.995,COLORWHITE,LINETHICK2,POINTDOT;
操作区:EMA(VAR4,142)*0.998,COLORRED,LINETHICK1;
铁底区:EMA(VAR4,250)*0.885,COLORYELLOW,LINETHICK1;

{拐点显示}
VAR1:=(O+L+H+C)/4;
拐点:=MA(C,3);  拐点1:=MA(C,3);
GD1:=REF(COUNT(拐点<=REF(拐点,1),5)=5 ,1) AND 拐点>REF(拐点,1);
GD2:=REF(COUNT(拐点1<=REF(拐点1,1),5)=5 ,1) AND 拐点1>REF(拐点1,1);
DRAWICON(GD1,0.98*C,1);
DRAWICON(GD2,0.98*C,9);
VARA:=AMOUNT/VOL/100;
VARB:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VARC1:=SUM(AMOUNT,7)/VARA/100;
VARD:=DMA(VARB,VOL /VARC1);
VARE:=(CLOSE-VARD) /VARD*100;
VARF:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=(CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100;
K:=SMA(VARF,3,1);
DRAWTEXT(REF(BIAS18,1)>=5 AND CROSS(VARJ,VARE) AND K>88 ,H+0.5,''),COLORYELLOW;
条件:= O>C AND C<REF(C,1) AND REF(C,1)<REF(C,2) AND REF(O,1)>REF(C,1) AND REF(O,2)>REF(C,2) ;
STICKLINE(条件 ,O ,C ,7 ,0 ),COLOR00FFFF;
STICKLINE(条件 ,L ,H ,0 ,0 ),COLOR00FFFF;
DRAWTEXT(COUNT(C<REF(C,1),5)=5,L*0.995,'关注');




{波段王买入信号加入主图}
C11:=(CLOSE+LOW+HIGH)/3;
C22:=EMA(C11,6);
C3:=EMA(C22,5);
C4:=CROSS(C22,C3);
DRAWTEXT(C4,LOW/1.01,'波★'),COLORWHITE;
{MACD买入加入主图信号}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
DRAWTEXT(CROSS(DIFF,DEA),L-0.2,'M买入'),COLORWHITE;

附件

关注和黄柱子.jpg

举报

使用道具 扔鸡蛋(0) 回复

学悟2020
Lv.2
发表于 2021-4-7 10:29 复制 查看全部楼层
条件: O>C AND C<REF(C,1) AND REF(C,1)<REF(C,2) AND REF(O,1)>REF(C,1) AND REF(O,2)>REF(C,2) ;

举报

使用道具 扔鸡蛋(0) 回复

学悟2020
Lv.2
发表于 2021-4-7 10:27 复制 查看全部楼层

关注:COUNT(C<REF(C,1),5)=5;

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表